Question about Vibe CBR10 Car Subwoofer

1 Answer

Vibe cbr1 subwoofer

I have just installed a second hand vibe cbr10 subwoofer with built in amp i believe i have wired it up properly, but there is still no sign of power as the light does not come on at all i dont know whether it is that the actual sub doesnt work or whether i have wired it up incorrectly but i have th cable attatched from the positive terminal on the battery to the positive terminal on the sub/amp and the cable from the other terminal on the sub/amp attatched to an earth point, i have the cable connected from the back of my jvc stereo to the input terminals on the sub/amp and also the wire connected from the am cable from my stereo to the middle termina on the sub/amp could you help me please?

Posted by on

1 Answer

Re: vibe cbr1 subwoofer

Might not be eathed properly. Check the earth on the battery as well. Theres more juice goin through there now so it might need a bigger earth or ground.

Posted on Jan 09, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Vibe subwoofer not powering on

you could of blown the amp. check the fuse in the amp to see if its blown and make sure your getting good ground and positive connections

Mar 23, 2010 | Vibe CBR10 Car Subwoofer

1 Answer

I bought i vibe cbr 10 5 months ago and now when its playing it keeps chiping in and out any suggestions as to why thats happening

check the wiring of your power amp that driver your sub woofer, use #4 wire for better performance.

Mar 03, 2010 | Vibe CBR10 Car Subwoofer

1 Answer

How do you take out the subwoofer part?

the speaker should be fixed by screws/bolts, in the front, when assembled someone would have had to fix unit together so think how they built it and work backwards , some speakers are bolted from the rear so look for acces points to get to that the port may twist to release

Dec 22, 2009 | Vibe CBR10 Car Subwoofer

1 Answer

The woofer wont turn off

The only wires that should be going to the subs are the Speaker wire, The power, goes to the amp, Blue the remote wire should only go to the remote spot on the amp wich is usually labeled rem. and the ground all goes to the amp.

Nov 19, 2009 | Vibe CBR10 Car Subwoofer

1 Answer

My twin jbl 12'' sub in a enclosure dont seem to be giving bass

Those 12's Need to be in a Ported Inclosure to release the Air that the Bass Produces. Use a 1 Inch Key Hole Bit and make 1 Hole at the Top Corner of Each Portion of the Box. Top Left and Top Right. Please Rate My Response! Thanks!

Feb 02, 2009 | JBL GT412 Car Subwoofer

2 Answers

JL 12W2 Subwoofer

bad wires to the cone from the conectors

Oct 01, 2008 | Jl Audio 12W3 Car Subwoofer

1 Answer

Driver's side under dash fuse box 2004 vibe

Please do not rate me for this...this is what kids are for. Personally, I kneel outside the door, so I don't have to stand on my head.

Apr 25, 2008 | Vibe CBR10 Car Subwoofer

1 Answer

Changing a fuse on 2004 Vibe

Many vehicles have the fuse block under the hood (for fire protection) otherwise your owners manual should be very helpful.

Apr 20, 2008 | Vibe CBR10 Car Subwoofer

Not finding what you are looking for?

Open Questions:

See all Vibe CBR10 Car Subwoofer Questions

Vibe CBR10 Car Subwoofer Logo

Related Topics:

344 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vibe Car Speakers & Subwoofers Experts

xxxxxx xxx

Level 3 Expert

4679 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21840 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Vibe Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides