Question about Sony KP-57WS500 57" Rear Projection Television

1 Answer

KP-57WS500 adjustment. After a lot of questions and responses I had determined the problem with my television was a bad blue tube (television would fade blue, have a blue haze, flicker, then shut off). A common problem with the KP-57WS500 I'm told. I ordered a complete assembly online and installed it. Now it needs adjusting as the wording on screen is yellow overlapping blue and a little hazy. So, this is my question. How to adjust. I have looked online for a solution and nothing seems to exactly match my issue. I downloaded a service manual and it helped a lot with the replacement but the adjustments are a little confusing. If anyone can help I would appreciate it.

Posted by on

  • cfcphxaz Nov 14, 2009

    I tried using the service manual to make adjustments as suggested. I let the television warm up for about 20-25 minutes. I had to isolate the green tube. After doing this the picture (actual television) has disappeared. I can still hear sound and navigate the service menu. There is no instuction on how to revert back to original settings, or at least I cannot locate them. I turned off the tv without saving settings and turned back on entering service menu. I cannot get picture back. Do I make adjustments in relation to the service menu text or to the actual television programming? Also, how can I undo whatever change cause the picture to go out?

  • cfcphxaz Nov 14, 2009

    I am using the service manual specific for this television and the 51" and 65" models. There is a number at bottom of front page maybe you are refering to: 9-965-932-06

    I am using pgs 38-42 and the reference charts that follow.

    As for the diagnostic check, I read page 7 of the manual that relates to this. According to this section if there is an error the led will blink a certain number of times specifying the error. The led blinks 9 times which states an audio error, however the audio works fine. The front panel is off still, maybe that has something to do with it.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 350 Answers

The service manual has the adjustments in it, at least mine does anyway. You need an oscilloscope pursuant to the manual. If not I am including a link that may actually be easier and quicker to follow.
http://www.somelifeblog.com/2007/06/sony-projection-tv-red-line-repair.html
I hope this helps and good luck!
KP-57WS500 adjustment. - 0dc3233.png

Posted on Nov 14, 2009

  • 1 more comment 
  • CURT
    CURT Nov 14, 2009

    What service manual do you have and what pages are you referencing that you followed?

  • CURT
    CURT Nov 14, 2009

    Can you get the TV into self diagnosis mode? If so, how many times do the lights flash?

  • CURT
    CURT Nov 14, 2009

    Error codes in normal (customer) mode are not displayed. You must enter PJED service mode to see the error code.


×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Replaced convergance chips adjusted red but blue will not adjust in any direction pico fuse is good Sony KP-57WS500


You can try to adjust in service mode but it sounds like you did not do this repair correctly. I would suggest getting instructions from sites such as www.TvRepairKits.com

Feb 12, 2012 | Sony KP-57WS500 57" Rear Projection...

1 Answer

The color is off on the TV. I have I blue line like a shadow. what could it be?


the convergence of blue tube inside you T.V. has a problem..
convergence controls the alignment of three tubes
maybe some capacitors has leak
or vary their capacitance.
it can be adjust but only for those experienced technician.

Sep 02, 2011 | Sony KP-57WS500 57" Rear Projection...

1 Answer

My screen is all blue the picture fades in and out behind the blue. Is it the bulbs or something more we are at a loss.


Yes, your blue picture tube is bad. Sony had a big problem with this series and bad tubes. The gun assembly of these tubes breaks loose from the welds. The tube is no longer available.

May 28, 2010 | Sony KP-57WS500 57" Rear Projection...

1 Answer

Television plays with a blue screen


This is one of a group of sets that had bad picture tubes; many were replaced in warranty(I know as I did dozens of them).

The tubes are no longer available from Sony and the only way to get one is to remove the one in the set and send it our for "rebuild".

The problem here is all three tubes can fail.

There is a way to try to adjust the set without replacing any parts and with only minimal effort.

I have performed this for a lot of people and the sets can last up to another year or two--it is only a way to compensate for the blue tube and may just buy you some additional life with the set.

let me know and I can post the instructions here for you.

SD TECH

Apr 16, 2010 | Sony KP-57WS500 57" Rear Projection...

1 Answer

Sony KP-57WS500 fades blue, flickers, then shuts off. According to all similar problems I've read it seems to be a blue tube problem, however I would like to make sure. Also, looking for tubes doesn't seem...


Ok, I have a option for you--the set you have mentioned did have bad tubes---all of them--if picture comes on blue and then it shuts off there is one simple thing you can try---first the tubes are only available on a rebuild basis--means you have to remove the bad one and send it out of for rebuild--expensive.


If you want to know the simple option that may allow you to use the set---rate this solution here and I will tell you what to try--no parts to buy--just an adjustment-


SD TECH-

Nov 04, 2009 | Sony KP-57WS500 57" Rear Projection...

1 Answer

Sony KP-53V45 color issues


When ever a tube starts to short or is shorted set always will have over bearing drive lines then shut down like RED if it was bad, set would come on long enough for red lines across set then shut down this is the same with all 3 tubes.Also if you think it might be green tube disconnected green CRT board on neck of green tube if set comes on and plays then it is green tube do all 3 tube this way one at a time this will tell you if you have other problems.

Dec 02, 2008 | Sony KP-57WS500 57" Rear Projection...

2 Answers

Kp-57ws500


Do either the red or the green crts come up at all?? If not the heaters in the blue crt could be bad - loading down the HV and the shutdown circuit turns the set off.. Only repair for that is to replace the blue crt, but I would have it tested first.. In the shop here we use a B&K467 to test for shorts and emission leaks but that's old school.. B&K has since come out with far superior crt tester/rejuvenators..
Bill

Dec 09, 2007 | Sony KP-57WS500 57" Rear Projection...

1 Answer

Sony kp-57ws500


Probable bad blue CRT and if blue goes bad guess what might
happen to the red and green.........T.

Nov 07, 2007 | Sony KP-46WT500 46" Rear Projection...

5 Answers

Sony KP-57WS500 57 in. Rear Projection Television


Hi Guys

Your problem here has to do with the amount of aging that happens to the three colour tubes - red, green and blue.

Blue actually ages slower than red and green. What actually happens is the green tube deteriorates and due to green being the predominant colour for brightness causes the blue tube`s flyback lines to appear - especially when switching between inputs or when the video is blanked.

No replacing the blue tube will not solve your problem as the tube is actually the best one of the three.

As someone mentioned there is a way to adjust this by removing the speaker grill assembly in front of the set. Doing the service mode adjustment with the remote is not the right way to solve the problem - you would be adjusting the colour gain and off-set values and would seriously be compromising the white balance of the set.

On the left hand side behind the speaker cover you will see a black square block with six adjustment points. Look for the one marked SCR BLUE, Switch the set to a unused input so the blue lines become visible. Now adjust the BLUE point counter clockwise until the lines disappear. A small adjustment should do it, Switch back to a picture and make sure the whites are still white.

This should sort your problem. I would however suggest asking a Sony service centre to do this for you. This is a dangerous thing to do as you will be working close to the 35Kv supply the the anodes of the three tubes.

I hope this answers your question.

Goo luck.

Jun 05, 2007 | Sony KP-57WS500 57" Rear Projection...

Not finding what you are looking for?
Sony KP-57WS500 57" Rear Projection Television Logo

Related Topics:

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

kakima

Level 3 Expert

102366 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1667 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...