Question about Hifonics Brutus BX 2005D Car Audio Amplifier

1 Answer

I have a 2000 watt hifonics brutus amp ...it worked fine but 1 day it just stopped working..the power light doest light up but the hifonics led lights are still on...whats the problem?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 524 Answers

There is a step up converter inside the amp that likes to come loose from the board. This may be your problem. Otherwise Check all the chips for burns or disconnect

Posted on Mar 22, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a hifonics brutus 1606d 1600 watt amp it gets power green light is on lit up across the top but i cant get any sound


Your amplifier may have experienced circuit failure other than a dead short that still allows power to be applied

Dec 05, 2016 | Hifonics Car Audio & Video

1 Answer

Brutus elite hifonics BRE1600.1D. Not as powerfull now.


Make sure of voltage going in to Brutus.

Mar 23, 2014 | Car Audio & Video

1 Answer

Is the brutus amp blue led light suppose to stay on when the car is off?


No. The LED should be off when the radio is off (amp turns off as well)

It sounds like you have constant 12volts applied to your remote turn on lead. The amplifier will have 3 connections for power:

1. 12volt constant
2. chassis ground
3. 12volt switched power - this wire should come directly from your head unit. It only sends 12 volts when the radio is on allowing to amp to power up only when the radio is on.

Dec 22, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

I have 2 12 inch jl audio w7's with a kicker crossover and a powerbass equalizer 5 bands. i wanted to know if add a hifonics brutus 2100 d class amp to my subs at 1 ohm would it over power my subs. please...


Short answer: NOPE!

The Hifonics Brutus 2100 is stated to produce 2100 watts RMS @ 1ohm load. Most amplifier manufacturers overstate their claims. The 2100 watt output is most likely at 14.4 volts and not the 12.6 volts your car will actually be providing the amp.

But, even if the actual output was 2100 watts that would be 1050 watts to each 12w7. The 12w7's are rated at 1000watts RMS and 2000watts peak. As a MECP certified installer, any system I have done using 12w7's have had a MINIMUM of 1000 watts being provided to each speaker. My personal preference is to run 1500 watts each and keep the gains adjusted lower on the amp. Thus allowing the amp to run cooler and allow the additional headroom for those "show-off" moments!

Dec 22, 2010 | Hifonics Car Audio & Video

1 Answer

Will hilfonics brutus 2010d mono work??


Well with the correct powering system, heaps of paralleled 12 volt Batteries, & a Beefed up Alternator to charge them, I guess so, BUT it is only Mono, so you will need TWO to provide stereo output

Mar 06, 2010 | Hifonics Brutus BX 1605D Car Audio...

1 Answer

Hifonics brutus 2000 watt help??!!??


If an RCA took a dive your amp has most likely seen a very nasty input spike and may never be the same as its circuitry has been damaged.....sorry

Mar 09, 2009 | Hifonics Brutus BXi 1206D Car Audio...

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp


Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Jan 01, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Okay i have a problem hifonics brutus 1500 mono d class amp


well your amplifier is obviously going into protect mode,(i used to have this amp and it is awesome) anyway i would go through just to be sure and check all the power connections with a test light, remote wire, positive, and ground. and check the fuse to see if it is still good. you can buy a test light at wal-mart and any automotive store. if you stil have a problem then i would check to see if your running below 1 ohm on this amp. that would cause it to go into protect mode. if all this fails i would just go buy a new one.

Oct 07, 2007 | Hifonics Brutus BX 1505D Car Audio...

Not finding what you are looking for?
Hifonics Brutus BX 2005D Car Audio Amplifier Logo

548 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...