Question about RTO PasLode 900420 Impulse Framing Nailer

2 Answers

Problem with battery connection

Hiya

for some reason my paslode im350 seems to have developed a problem with the battery connection.. if I push and hold the battery in a bit, I get the green light flashing and all works, or if I don't fully put it in the same. Is there anything I can do, or is this commen?

Thanks

Patrick

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 24 Answers

Look inside where the battery and you should see two terminals under them you should see two battery pads, if there worn or damaged they may cause the problem you are having. They may need to be replaced. Good luck!

Posted on Nov 13, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 89 Answers

If you remove the battery and look into where the battery goes at the bottom you will see the two prongs that make contact with the battery pack gently pry away from the side not to far but just a bit if you can not insert battery when done you pried to, far just bend them back until all works properly

Posted on Nov 11, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Paslode 350 tell no light


If you have no light at all in the handle and you're sure you have a charged battery, then I would look at the battery contacts - that tool has the contacts molded into a circuit board assembly so if it is not obvious I would take it to a repair center to be diagnosed.

May 07, 2014 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

Changed the circuit board on a Paslode IM350 and now the fan wont work any Ideas welcome


fan motor could have gone bad, spark unit(little black box in handle) could be bad. one of the three top conections could be loose, or hooked up wrong, battery contacts on end of circuit board assembly could be placed a little off( battery not making contact with circuit mold assembly) pinched one of the wires going to the trigger area, or fan area

Sep 26, 2012 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

Paslode im350 fires every time,but nails dont come out


Unless you have the wrong nails or a problem with the feeder and/or feeder spring it is probably dirty and the driver is hanging up on the cylinder. These tools need to be cleaned and lubed after using them for some time. If you look on Paslode's website there is a manual that explains how to do it. There are also videos on YouTube that show this. It is somewhat complicated and the tool has to be disassembled quite a bit. If you don't feel comfortable doing this work then you may want to want a servicing dealer that repairs these tools. There is a rubber o-ring on the head and a filter on the top that should be replaced too. Here is a link to the cleaning guide.

Paslode IMCT cleaning guide

Aug 26, 2012 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

Paslode IM350 90CT Nail Gun gun light green gas full battery charged fan works gun wont fire


Try a different gas cartridge and make sure the top of the cartridge is snapped tightly onto the cartridge body.

Jun 23, 2011 | Air Tools & Compressors

1 Answer

IM350 when battery inserted flashes green then goes to red. Tried battery in other gun and works ok. Tried full charged battery (green in other gun) and led goes red in this one. Measured voltage at 6.74v....


Hi,

Check the battery contacts in the gun...

Here is a tip that I wrote about the Paslode nailers and the problems that can come up with them.

I also have a link to the Paslode manuals which contain Paslode cleaning and troubleshooting guides.

If you need parts for your Paslode, there also is a link for a site that sells the Paslode nailer parts.

Paslode Cordless Nailer Problems



heatman101


Feb 05, 2011 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

Hi .my im350 nail gun isnt working gas and battery ok and gun is cleaned.light on green .but when depresssed makes strange noise and lights on fire from fan end?


Hi,

Here is a tip that I wrote about the Paslode nailers and the problems that can come up with them.

I also have a link to the Paslode manuals which contain Paslode cleaning and troubleshooting guides.

If you need parts for your Paslode, there also is a link for a site that sells the Paslode nailer parts.

Paslode Cordless Nailer Problems



heatman101



././

Oct 24, 2010 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

My paslode IM350 fires about once every 20


by service im assuming you mean replacing the o-ring and seals/gaskets. If not do that. But if you have it may be more of an internal problem with the air valve leaking around the piston.

Aug 03, 2009 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

Paslode im350 piston will not return


It sounds as if the piston o ring is worn. Does the piston drop if you just give it a slight bump with no nails in the magazine, if so that is the problem and would need replaced. Let me know otherwise and I will dig deeper

Jan 24, 2009 | Itw Devilbiss Itw Paslode Cnp 65Y Coil...

1 Answer

Paslode im350


Stuart - this sounds like an air problem - you should perform the following test. With the air nailer close to the compressor you must monitor the airpressure after the gun fires. it sounds like the air is not gettting through diapram fast enough or there is a blockage in line. Blockage in line is not suspected for the following reason . It sounds like the air hose is holding enough air to fire 2-4 nails and then you must wait for the line to fill up again and then it fires ok. The pressure regulator out to the line controls this and they do fail. try this test and report back to me - I know I can solve this for you as I have extensive background in compressor and the like.

Oct 22, 2008 | Itw Devilbiss Itw Paslode Cnp 65Y Coil...

Not finding what you are looking for?
RTO PasLode 900420 Impulse Framing Nailer  Logo

278 people viewed this question

Ask a Question

Usually answered in minutes!

Top RTO Air Tools & Compressors Experts

John Trevino

Level 3 Expert

1383 Answers

Brad Brown

Level 3 Expert

15441 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Are you a RTO Air Tool and Compressor Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...