Question about Alpine MRP-M650 Car Audio Amplifier

1 Answer

MRP-M450 puts out no sound to the subs

I have an MRP-M450 and the power light turns but it doesn't put out anything to the subwoofers. It all worked perfectly fine after I hooked it up but i was driving and my subs just stopped working with the amp. I have checked the subs on a different amp and the work just fine.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers
Re: MRP-M450 puts out no sound to the subs

The amplifier may be overloaded, check to see if it can handle 4 OHM loads and 2 OHM loads. if it turns off at high volume the amp may be overloaded. if so try a 8 OHM load. if it still turns off it may be an internal problem.

Posted on Jan 07, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Just bought a alpine mrp-m450 amp and It turns on, I have my rca input connected and my output to my sub but my sub isn't making any noise, my sub is fine I just tested it

make sure the protection light isn't on. Also, make sure your are getting signal through the rca's. you may have to turn the sub on, in the radio settings.

Dec 27, 2014 | Car Amplifiers

1 Answer

I haw alpine mrp-m350 amplifier how many sub can i

Hook up the MRP-M350 to one 4-ohm sub, and you get 200 watts RMS; connect a second 4-ohm subwoofer and the power output increases to 350 watts! All that juice means that your subs won't just be loud, they'll sound clean and thumping.

Apr 08, 2010 | Alpine MRP-M350 Car Audio Amplifier

1 Answer

Wheres the power.. No bump

it might be that your subs are too powerful for the amp, check the model of the sub or subs online and check out how many watts they can take, because you might need to upgrade your amp or downgrade your subs

Jul 03, 2009 | Alpine MRP-M450 Car Audio Amplifier

2 Answers

Amp light flickering

do you have a capacitor its like an extra battery, if you turn the volume way up with cvr's pullin big power, it cuts out because theres not a steady flow of power.... hope this helps

Jun 30, 2008 | Alpine MRP-M450 Car Audio Amplifier

1 Answer

Not enough bass

its prolly the deck, did you try turning the alpine's input gain controls up...

its not the wiring, if the wiring was insuficient, it would just melt...

you might also see if you could adjust the bass frequencies or crossover frequency, the crv might just have a different resonant frequency then the rav 4

May 16, 2008 | Alpine MRP-M450 Car Audio Amplifier

1 Answer

Amp light is on but doesn't put anything out to my subs

if you are sure its the amp. the problem is internal. but if your not sure, try a different stereo or source of sound to the inputs of the amp. if there is still no sound than it is the amplifier and it could be a number of things.

Jan 07, 2008 | Alpine MRP-M450 Car Audio Amplifier

2 Answers

Alpine MRP M450 Problem

Sounds like it is getting too hot and a thermal overheat protection switch is shutting it off. Check to make sure your gain isnt over 3/4.

Dec 05, 2007 | Alpine MRP-M450 Car Audio Amplifier

1 Answer

Just died out..

Have you determined if the problem is with the amplifier or the subwoofer?


Have you checked the wiring to make sure that there are no loose connections?

Oct 18, 2007 | Alpine MRP-M450 Car Audio Amplifier

1 Answer

The light on top on my MRP-M450 blinks and the amp doesn't work

Well if you took off the cover on the amp and nothing seems to be burn't, check the voice coils on the sub. It's possible the voice coils have separated and is causing the amp to short it self out due to ground error. If that doesn't help let me know and I'll tell you the next step.

Sep 29, 2007 | Alpine MRP-M450 Car Audio Amplifier

2 Answers

Alpine mrp-m450 Amp won't stay on

im having the same problem with my amp, I took it to best buy and they said the amp was recieving power and recieving signals from the deck and i had everything hooked up right but that in the circuit board all the connections were blown, meaning i have a blown amp, i hope this isnt your problem but it definetly sounds like it. GOODLUCK

Nov 12, 2006 | Alpine MRP-M450 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRP-M650 Car Audio Amplifier Logo

Related Topics:

329 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Are you an Alpine Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides