Question about Onkyo TX-SR674 Receiver

1 Answer

Standby button flashing

I purchased this receiver new online two weeks ago and I worked fine at first. Now when I plug it in and push the button, it shuts off and turns back to flashing but it never really turns on or shows a display. Can you help me?

Posted by on

  • 1 more comment 
  • Anonymous Mar 06, 2008

    I have the same problem with my Onkyo. It appears to shut-off and the STANDBY button flashes. It only seems to do this if the volume is above about 60 or so... I'm wondering if there are some issues with my speakers (Infinity Primus) that are causing the amplifier circuitry to shut-down on purpose.

  • Anonymous Apr 30, 2008

    I have the same problem. If I turn the volume above about 40 the receiver shuts of, the louder I turn it the quicker it turns off. And the standby button will flash.

  • Anonymous Mar 27, 2014

    when push on button amp turns on then back off



1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Re-Onkyo :

I'm not an owner of Onkyo but in my Denon owners manual it mentions
"reainitialization of microprocessor" basically resets all to default .
Not sure if your reciever is new just out of the box or used ?

Just a bump in the road

Posted on Jan 07, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

Denon AVR-1908 won't power on

Are you getting a standby light at all? Is it flashing? Do you here a click when you plug the unit in? If the answer is no to all of these then you blew a fuse. If you do have soome sort of standby light, then your set is in protect mode. More than likely for a blown channel. If no lights, but you ar egetting a click, you could have a bad transformer. Use a DVM and see if it is open or not. Good luck

Aug 23, 2012 | Denon AVR-1908

1 Answer

Hi, I have a Panasonic W32D2DP its about 5 years old. It worked fine until about 3 weeks ago. It started cutting off and going to standby. It worked fine after for a few more hours, then would do it...

It's going to be cheaper to buy a new TV. Once you get this problem solved, another one will pop up. The parts for a TV that's 5 years old are not going to be cheap. Most TV repair shops stop carrying parts after 4 years, & the manufacturer stops making them after 7-10 years. With a semi-major purchase like a TV, it's best to purchase an extended warranty. ipmart. com offers a cheap repair manual. You'll be suprised how expensive repair shops can be when it involves "out-of-warranty" work.

May 08, 2009 | Televison & Video

1 Answer

My remote control doesn't work. nothing happens when i use it

It can be a faulty infra-red receiver board, usually wont pick up signal from wide angle or distance. what is your tv?

Mar 18, 2009 | Televison & Video

1 Answer

Remote does not open garage door

It sounds like the wall button has the lock feature engauged.

Is there a small green LED flashing inside the wall button?
Push and hold the lock button for about two seconds and the LED should stop flashing. This will unlock the garage door opener and your remotes should start working. You may have to reprogram your remotes and homelink again since you triedprograming in the lock mode.

Good luck.

Jan 20, 2009 | Chamberlain 950CB Remote Control

1 Answer

New wireless mouse quit working after 2 days.

Hi bobbii1968,

  1. Try replacing the batteries. Do not use alkaline batteries. Use ordinary Eveready battery.
  2. Check polarity when placing battery in mouse
  3. Ensure red infrared light is on. If on, there is hope in getting the mouse to work
  4. Plug in USB wireless receiver.
  5. Press button on receiver and below the mouse.
  6. This should work fine.
Update us again if the above does not work?

Thank you for taking time to read this.

Jan 07, 2009 | HP Computers & Internet

1 Answer

Brand new avr588 receiver is turned on for five seconds and then cuts off to standby

Hi donnie025,

I can't believe you haven't received an answer before now.

The red flashing light normally indicates that the protection circuit has been tripped. It can be caused by something as simple as a short in a speaker wire. Even if there is one strand of loose wire that makes contact with the back of the receiver, another wire, etc. it can cause a short. To protect itself the receiver will simply shut down.

1st. I would suggest disconnecting all the speaker wires from the back of the receiver. Then turn on the receiver (obviously you won't hear any sound) and see if the receiver does the same thing. If it does you should try disconnecting all of the source components (DVD player, Cable box etc.) and try again. If it still does it the receiver is bad and needs to be serviced or exchanged if you still can.

2nd. If the receiver stays on after you disconnect, then turn off the receiver and connect one speaker at a time, then power on the receiver at test it after connecting each speaker. This way if it suddenly shuts down after connecting a speaker you know which speaker or wire to check.

Let me know how it works out for you, I hope this helps if you haven't figured it out already.
Matt @ OneCall

Nov 08, 2008 | Denon AVR588 Receiver

2 Answers

Sound, but no picture. Standby light blinking 5 times

A few weeks ago my set started flashing to a black screen. Now a couple of weeks later, i have no picture, but the set turns on and i have sound. The standby light is flashing. I purchased the set in 2000 so it is seven years old. This is the first problem. Could it be all three of the bulbs? Could it be all three of the bulbs? no as you say that sound is ok that means your power supply &high voltage section is ok. please check chroma ic luminance section or system control section stand by ckt ihanks

Sep 11, 2007 | Sony KP-53HS10 TV

Not finding what you are looking for?
Onkyo TX-SR674 Receiver Logo

305 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Audio Players & Recorders Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers


Level 3 Expert

5318 Answers

The Knight
The Knight

Level 3 Expert

75025 Answers

Are you an Onkyo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides