Question about Cobra 29 LTD CB Radio

1 Answer

Losed all i have a 97 model cobra 29 ltd classic with talk back and is sliltly tweeked and i turned it on and it worked fine a few hours later i turned it back on to try and get ahold of a friend but i got nothing. when my friend arived i hooked it up in his truck on a diffiernt antanna and wiring harness witch fit and ext. speaker and still got no noise exept  the talk back from the mic. no static or anything. the board inside is not burnt nothing inturnal seems to be the problem any ideas?

Posted by on

Ad

1 Answer

The talk back may be nothing more than a 10 ohm resistor shorted across the pa/external speaker outputs. If this is the sitution, the resistor may have damaged the audio chip. Remove the resistor and see if this corrects the problem. If not you may need to replace the audio chip. Hope this helps
Ed
NC Electronic
Mills Wyomign

Posted on Jan 07, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No rf signal.


try it on a base station antenna and see if it still happens. If it does it should be under warrenty so send it back and get another .

Apr 08, 2014 | Cobra 29 LTD CB Radio

1 Answer

My cobra 29 classic wont turn on


polarity protection diode near power input burnt.

Apr 14, 2013 | Cobra 29 LTD CB Radio

1 Answer

Hello i own a cobra 29 ltd classic from 1993 today i was talkin skip like crazy!! running about 100 watts out of a texas star modulator!! i left for a while came back talked for a while everything was good...


sounds like the amp got hot and shorted on the bias.. and is keyed up a few watts. to fix you will have to have the amp repaired. new power transistor. to fix. 3174269649 Texas.

Dec 12, 2010 | Cobra 29 LTD CB Radio

1 Answer

I have a cobra 29 nw ltd classic i cannot hear or be heared


Start with the antenna that you have hooked to it, is it grounded, is the coax in good shape, is the connector in good shape. stuff like that.

Jun 14, 2009 | Cobra 29 LTD CB Radio

2 Answers

Cobra 29 ltd classic ant light


Your SWR is probably NOT fine. You need to use an external meter if you have had work done to the radio. Especially if you have had a swing mod done to the radio. When you do this, the dead key of the radio is lower then the calibration knob on the radio can adjust for. It will always come up lower then it actually is.

Your radio might have been fine before the work was done on it because it was putting out very little power. Now you are most likely putting out 50 watts or more. Big jump from 4 watts.

When your raise the power in a radio, you will notice more when the antenna is not properly tuned.

In most cases with a stock CB, even when the antenna is not even near tuned, you will get a reading less then 1.5 anyway.

the more power you put out, the more important it is to have a good match.

But an external SWR meter, and check it. be careful if the ANT light is on.

You might also want to check your coax, connections to it, and your antenna for anything wrong.

Apr 22, 2009 | Cobra 29 LTD CB Radio

1 Answer

Cobra 29 LTD Classic not transmitting or receiving


ant. light should only come on if you have a high vswr a bad thing did you check that cb/pa switch is set to cb check your swr this is not a good place to mount ant. as it is close to metal of back of cab

Dec 20, 2008 | Cobra 29 LTD CB Radio

1 Answer

Cobra 29 LTD Classic not transmitting or receiving


As I understand from a tech friend of mine, most truck beds are not grounded well enough. Perhaps you could borrow/purchase a magnet mount antenna and locate it on the roof, for testing. Then you would have it narrowed down to the location.

Dec 05, 2008 | Cobra 29 LTD CB Radio

2 Answers

Cobra classic 29 ltd


Had fixed the same problem yesterday. My cobra worked when it wanted to, when it didn't it looked like you explained. I found out that on my cobra the blue wire on the mike connector was broken. When it disconnects, no sound. after soldering, everything works fine.

Dec 04, 2008 | Cobra 29 LTD CB Radio

Not finding what you are looking for?
Cobra 29 LTD CB Radio Logo

Related Topics:

164 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cobra Radio Communications Experts

Brad Brown

Level 3 Expert

17102 Answers

Steve

Level 3 Expert

3289 Answers

yadayada
yadayada

Level 3 Expert

79123 Answers

Are you a Cobra Radio Communication Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...