Question about Amplifiers & Preamps

2 Answers

NAD 304 power indicator

Good day to you all, i have this NAD 304 stereo integrated amplifier, whose LED power indicator is not turning into green anymore, it stays red for a long period of time. i read in the manual that it is in protect mode but the relays wont switch to green. i want to know if this is normal and leave it on till it turns green? or i should get it fixed to a repair shop already? thanks

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer
Re: NAD 304 power indicator - Amplifiers & Preamps

Change resistors 333 & 334 - 47k-1W

Posted on Jan 04, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers
Re: NAD 304 power indicator

Have it for a preventive maintenance if it lit red for too long. maybe some swiches are jamed. in that unit it uses electronic switch relays so maybe due to its age it was been coorded so the switches dont work

Posted on Jan 07, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

My NAD C372 integrated amp was working normally everyday. One day, on pushing in the "Power On" button, it did not light up. No response at all.

It could be anything from a blown fuse from a power surge to a shorted capacitor ijn the power supply. There are fuses in all amplifiers. Locate it and test it with an ohmmeter.

Dec 16, 2013 | NAD C372 Amplifier

1 Answer

Cracking noise nad c340

Sometimes you can find the faulty part by touching the parts inside the amp. Only touch the plastic parts not any metal parts! As it is on one channel you have a good channel to compare the bad. Often small transitors can become noisy so start with them!

Nov 18, 2012 | NAD C340 Integrated Amplifier

1 Answer

Amp shorts down during "Warm-up"

These needs repair.

Check for shorted drive / output transistor and associated circuits.

Aug 29, 2012 | NAD C270 2-Channel Amplifier

1 Answer

NAD C326BEE amp problem. Connected to recommended Wharfdale speakers and NAD CD player and previously working fine for a year. Now red light flashing on amp and no sound when system is turned on.

Generally speaking, an amp attempts to protect itself from heat, shorts, overloads and operator exuberance by refusing to turn on or stay on.

Overloads can be from excessive periods of high output or marginally low impedance loading by the speakers; and shorts would be wiring issues or a speaker blowing up.

You should be able to feel if it's hot. WHY is it overheating? Make sure it has sufficient ventilation on all sides and that vent holes are not blocked by dust balls. Ensure the fan (if equipped) is running as designed (some only operate on demand). Clean dust and debris from it.

If the amp comes back on after cooling, you're lucky. They only have so many self-protection cycles in their lives so continuously resetting or cycling their power without addressing the cause can do more harm than good.

If it protects immediately on a cool power up you should disconnect the speaker connections and try it 'naked'. If it comes up then diagnose which lead(s) are shorted. If it does not come up the problem is internal and should be left to an experienced and competent hands-on tech.

Check for loose speaker connections at the speaker as a root cause for ntermittent shutdown.

Page 6 and 13

May 27, 2011 | NAD C326BEE Amplifier

1 Answer

Nad 304 amplifier no output, relais not willing to

The 2 BIAS resistors of 47kohm, R333 R334, replaced with new 1W resistors. 1 resistor was totally open and 1 resistor was 55k.

It were 1/2W resistors, replaced them with 1W resistors. Very low cost repair for a High End amplifier. Should live for another 10 years.


Jan 07, 2010 | NAD Amplifiers & Preamps

1 Answer

Where do I connect the speaker wires?

Because your amp has 4 channels on it on side A you can connect 2 speakers for left and right and the B you can do the same. your red is positive and black is negative. so in total you can have 4 speakers connected to your amp

Jul 26, 2009 | Amplifiers & Preamps

2 Answers

NAD 304 AMP...No Sound at all on both channels, Black marks on inner case.

This may be a silly question, but the pre-out/main-in jumpers are installed, yes?

Sep 25, 2008 | Amplifiers & Preamps

1 Answer

Nad c350 no power at all

check your output stage for bad speakers cable or bare wire of cable touch the body of amp----short circuit speaker cable----bad speaker it self------ bad input cable or defective input device .
disconnect all and check if it is ok---start to connect one by one from input to outputs------if all above failed you must contact service center for help.

Aug 22, 2008 | NAD C320 2-Channel Amplifier

1 Answer

Sound through one channel

Only the right channel had a sound,the left channel is mute, whatever adjustment you did and whatever balancing you done nothigs happen,even you interchange the speakers. The problem is in the power amp. The STK IC there is busted already, it's better to change it with a new one so the performance become normal again.

Jun 14, 2008 | NAD C372 Amplifier

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

964 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts


Level 3 Expert

4518 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

66623 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides