Question about AudioBahn A2002T Car Audio Amplifier

1 Answer

Amp stoped working

I was driving home from work and it just quit. when i got home i checked my fuses, there good. when i unplug my ground wire the protection light barley comes on.......

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers
Re: amp stoped working

You should never disconnect the ground from the amp when it has B+ and remote voltage applied. This will cause damage to the head unit ith some amplifiers.

Does the protection light come on with the ground wire connected?

Posted on Jan 05, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

I wired a 1200 watt amp kit with a 2x 12 inch box set. I have checked the fuses and they are fine. There is no power. What do I need to check next.

if the power wire is ran to the battery an none of the fuses are bad , check ur ground wire make shore its get good ground an if thatdont work take apart the amp an see if the wire are connected to where ur power goes an the fuses

Jun 19, 2011 | xXx XA10002 Car Amp

1 Answer

New amp

Something is def. wrong. did you check the fuses on the amp after the light went out? probly have a bad connection somewhere. check ground wire and power make sure they have a good connection and arent cut up and shorting out.

Oct 21, 2009 | Pioneer Car Amplifier GM-7100M - Mono Bass...

1 Answer

Amp blows main power fuse..

No "fault" lights? If not it HAS to be a connection...whether they look bad or not, Redo them, ground FIRST.
Good Luck

Jun 21, 2009 | AudioBahn A8002T Car Audio Amplifier

3 Answers

Audiobahn amp help...

You have a Direct Short in the System Between the Head Unit and the Amp. Check the Ground on the Amp and then Check all the Wires behind the Stereo and the Common Ground There. You could even have a Spot in the New RCA Cables that is Touching Metal Somewhere. Please Rate My Response! Thanks!

Feb 09, 2009 | AudioBahn A2002T Car Audio Amplifier

1 Answer

Amp not turning on

wouldn't be the first JL amp I saw fried...but there are some tests you can do. First of all, double check your fuses, they may appear to be fine, but sometimes they are blown even if you can't see it. Either blindly change them or test them for continuity with a digital multimeter. Also, disconnect the remote turnon and jump power directly over from the power wire to the remote terminal on the amp, if the amp powers on then you have to go double check your remote wire. Hope this helps.

Jul 27, 2007 | Kenwood Excelon KAC-X811D Car Audio...

1 Answer

Fuse problems

output leads shorted by chance?

Jul 05, 2007 | Scosche Industries Scosche High...

2 Answers

Amp just abruptly stopped working (Pioneer GM-5300T)

Apart from the external DC power fuse (I hope you have one in-line), the majority of in-car amps have 2 mini fuses inside the unit to protect the output MOSFETs from overloading due to incorrect speaker connections, ie, if the output impedence is rated at 4ohms, anything less than that is considered to be a short circuit, and will overload the MOSFETs. After performing the tests suggested by KaeZoo, open the unit and look for printed markings on the circuit board, something like F1, F2, the fuses may not look like conventional fuses.

Jun 11, 2007 | Pioneer GM-5300T Car Audio Amplifier

1 Answer

Cadence z1200 stays in Safe Mode!

If the subs are rmoved from the amp (wiring), does the amp still go into protection without them hooked up? If no, shorted sub, if it still des, unplug RCA's, does it still go into protection? Also check voltage. Make SURE you have greater than 12 volts AT THE AMP using amps ground to check the power AND remote wires. Hit me back wth an update.Those amps rock.

Larry T
Winona Lake, IN

Sep 17, 2006 | Cadence Z8000 Car Audio Amplifier

3 Answers

Amp stopped working...

Has the amp been overheating lately? It's quite possible that the amp could have just blown. Smell around the outside of the amp for an electrical burnt smell. If available, see if a friend also has an amp hookup and try removing your amp and copnnecting to the friend's cables. That will tell you if it's a wiring problem or an amp problem.

Sep 13, 2006 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
AudioBahn A2002T Car Audio Amplifier Logo

Related Topics:

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21840 Answers

Are you an AudioBahn Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides