Question about Hoover U5507900 Elite Rewind Bagless Upright Vacuum

7 Answers

Hoover eite rewind vacuum has blocked airflow, how do i fix?

How to unblock blocked airflow in a hoover elite rewind

Posted by on

  • 1 more comment 
  • susanminton Jun 01, 2008

    I accidently sucked up some fabric from the sofa when vacuming around it. I turned off the unit immediatly. Now I cannot get the dirt cup to spin and there is no suction.

  • Lilredhen Aug 06, 2008

    My vac was getting very little suction, so I took out the HEPA filter and found that it was impacted with dirt and dust. I was surprised, as I have not had this vac very long at all. I brushed the filter out with a fingernail brush, but finally just opted to leave the HEPA filter out,and now my Hoover Elite has great suction and is no longer showing all yellow in the air flow indicator window. It defeats the purpose of removing allergens, but at least it now cleans my floor :(

  • jlentz2 May 11, 2010

    I have the same problem. I actually used my shop vac to vacuum the filters and stuck the hose into all the hoses and vacuumed them out. The vac does have some suction but the air flow indicator shows yellow. The suction is low from the hose and the bottom. Its also very loud and overheats. I've checked to make sure I put the filters in correctly. I've cleaned every possible part and checked to make sure that the belt was not broken. I'm stuck. I've only had the thing a few months.

×

Ad

7 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I had the same issue, but with a little time and a screwdriver, i got my vacuum working like new.

First, remove the bottom cover where the brush is located. Once the cover is off you'll see the vacuum inlet hose just behind the brush. Clear out any debris you find in there.

Second, on the back of the unit, where the attachment hose connects to the vacuum remove the three screws and clean out any debris you see in there. (dont be afraid to get your hands dirty)

hope this helps!
Country Music Guy


Posted on Apr 19, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Is there suction at the end of the hose, if not then the blockage is in the hose, unhook the hose and dig out the debris, if hose isn't blocked, then clean out the filters, if they get clogged, then air can;t flow thru them and you won't have suction. If you have suction at the end of the hose, then it is clogged down in the nozzle asm. there is an inlet by the brush roll and it comes up to where the hose plugs into. Clean the clog out.

Posted on Jan 15, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

If you have no suction from the hose or the suction meter stays yellow when you put your hand on the end, it's the internal filter that needs cleaning.

There is a filter inside the cleaning cup... First remove the debris cup, now open the top like you are emptying it out. Here in the lid part grab onto the bottom yellow plastic peice and twist it open. This will expose the filter that is inside the yellow perforated cylinder. Use a toothbrush, bang it on the side, etc, and then put it back together and sing praises to fixya, and me :-)

Posted on Feb 04, 2010

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Took apart filters and cleaned them with leaf blower then took off hose 3 screws and blew out hugh clog of hair and junk works like new. twenty mins start to finish !

Posted on Mar 21, 2010

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

I thought I had cleaned all hoses and filters too, little did I know the main tube was clogged with a huge clump of hair far enough in that I could not see it at first glance. I got the hair out after using a coat hanger and some banging. Works like new..... It would have been a big waste of money if I had brought my vacuum to be serviced and that was the problem..... Check that main tube.

Posted on Mar 14, 2010

I had the same problem. There wasn't any suction at the end of the hose and when I tried using the vacuum I saw it spitting dust out. I couldn't find a clog anywhere until I openned up the central cylinder and removed the filter. The filter was completely clogged. Once I cleaned that out the vacuum returned to normal.

Posted on Oct 13, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have clean out the hose and cleand out the filters and vacume is still clogging up...

Posted on Feb 18, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What is the belt part no. for a hoover elite rewind?? model no. UH71009RM


If you look up the Hoover page for the UH71009 (the non-remanufactured Elite Rewind), there are 3 different belt model numbers listed. One part number is simply for a 2 pack of the belts. See http://hoover.com/products/details/uh71009/elite-rewind-bagless-upright/ . Click on the Parts & Accessories tab.

I believe the belt part number is 38528058 , http://hoover.com/parts/details/38528058/sra-r-b-562932001-belt/ .

I hope this helps.

Cindy Wells

Oct 04, 2015 | Hoover Vacuums

1 Answer

How do u repair a broken rubber belt that helps spin the brush?


Hi, it's Cindy from Crucial Vacuum.

Unfortunately there is no way to fix a broken belt. The only way to repair the vacuum is to purchase a new belt.

You can purchase your replacement belts direct from Crucial Vacuum with free shipping and an exclusive 10% coupon for Fixya.com viewers, use code: FIXYA10

http://www.crucialvacuum.com/hoover-elite-rewind-belt.html

I hope this was helpful. If you would like further assistance, please feel free to give us a call at 877.750.9239. We have helpful and friendly customer care representatives on the line ready to assist you.


Cindy Yuk
Crucial Vacuum Customer Care
http://www.crucialvacuum.com

Apr 27, 2014 | Hoover U5507900 Elite Rewind Bagless...

1 Answer

Hoover elite power wont stay on


go to http://hoover.com/ and get the section support download the inst.manual, section troubleshooting, videos for guide for troubleshooting and fix it.
God bless you

Sep 16, 2012 | Hoover Elite Rewind Bagless Upright...

1 Answer

My deluxe elite rewind vacuum spits out dirt


The elite rewind does not have any fancy features. This sound like you have a blockage in the foot or base of the vac. remove the bottom cover to look under. Also check the hose, it can be in there as well.

Apr 16, 2010 | Vacuums

1 Answer

My HooverDeluxe Elite Rewind became extra loud


If the belt is really worn it can cause that. I wold try changing the belt if you haven't recently. Here are the belts you need:

Hoover Elite Rewind Belts


Nov 14, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

How do I clean the lifetime hepa filter


Check with the manufacturer. I have always had good response from Hoover.

Sep 23, 2009 | Hoover U5507900 Elite Rewind Bagless...

1 Answer

Hoover Elite Rewind - powerhead brushes are not turning


most likely band is broken. Usually there is a spare in the box or on the unit when new. Unscrew 2-3 screws by beater bar (brushes) pull off cover and replace band.

Jul 09, 2009 | Hoover U5507900 Elite Rewind Bagless...

1 Answer

Hoover U5507900 Elite Rewind problem


May have to replace the cord reel asm. It will have to be taken out and inspected, if can't see a problem, then replace it. If this is less then one year old, then it is still under warranty and should be taken to a warranty shop along with proof of purchase.

Dec 31, 2007 | Hoover U5507900 Elite Rewind Bagless...

Not finding what you are looking for?
Hoover U5507900 Elite  Rewind  Bagless Upright Vacuum Logo

4,098 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...