Question about Sony Grand WEGA KDF-42WE655 42" Rear Projection HDTV

1 Answer

Not sound or picture from the TV

When I go to turn the TV on, from the TV or remote, the yellow power / standby light comes on (green I think) and stays lit but there is no sound or picture from the screen. There are no blinking lights or red light illuminated? Do I need to replace the bulb? Thanks.

Posted by on

  • bhotz Jan 04, 2008

    Thanks, that's sounds like a logical start. The TV is 16 months old but I purchased as a floor demo. Its strange that light isn't red or blinking. Technician is coming out to check it out next week. Thanks again.



1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 579 Answers

If it has been over 2 years on this bulb, I would start there cause it will need one soon anyway.
Projection TV makers charge an arm and a leg for their replacement lamps. They make it easy to do but as a result the custom lamp assy is expensive. The trick is to just buy the bulb for your model TV from any number of us aftermarket sources at a fraction of the lamp price and install it in the old lamp yourself. really easy. However, this is one of the model that Sony has class action lawsuits against them on because it has so many problems with the light engine. See this:

Posted on Jan 03, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Proscan LED TV Will power up the red standby light & standby on amber when turned on but does not show picture or sound unless I unplug and replug over

Fault at its main digital board. Short circuited component/s at it. Contact any service technician; or the authorized service center. If you wish to get some details; check the site linked here. Surf the site with patience. Pull up older posts.
In most cases, the main board might have to be replaced. If so, a software [firmware] update too might be necessary.

Feb 14, 2016 | Proscan Televison & Video

1 Answer

How can i repair a tv that turns on but has no picture or sound

Have you tried a factory reset? I had a similar problem my TV was stuck on standby (red light only) I did this
  1. Turn on the TV.
  2. Wait approximately 40 seconds for the TV to completely start up.
  3. On the TV remote control, press and hold the UP ARROW button
and it worked!

Oct 16, 2015 | Sony KDL46EX400 46 in. HD-Ready TV

1 Answer

Standby light changes from red to green

hi this fault could be down to capacitor in the power supply, they bulge or go leaky, you need to take the back off the tv, to have a look. try and find a tv tech in your area hope it helps


Jan 05, 2014 | LG 42PX5D 42 in. Plasma HDTV

3 Answers

No Picture on Toshiba 42RV530U

I had a similar problem to this yesterday. Tv is same Toshiba model as you mentioned about 4 months old. In my case, after the TV working perfectly following installation, the standby LED on the front (the one that is red on standby and green when on) went to a flashing orange (after switching on from standby) and the picture disappeared although the sound remained OK. I was unable to get any response from the setup or menu on the remote, otherwise I would have tried resetting the TV. Regardless of how much switching off/on (including disconnecting the powerlead and leaving for few minutes), disconnecting all peripherals, etc., nothing helped. I looked up Toshiba's web site and under support they basically suggest switching off the TV and restarting using the onset buttons (not the remote) and pressing the menu button (again the one on the set (not the remote) and if you could get the menu box to appear then reset to default settings. I tried this but the results were the same. I therefore thought the TV was defective. However, after much frustration I did the following (I think): 1) Disconnect everything from the TV 2) Powered up from the mains switch whilst keeping BOTH the startup and menu buttons on the side of the TV pressed down. The result in my case was that the standby led and one of the two beside it flashed green simultaneously. However, when the buttons were released, the TV started up the same (flashing LED orange and sound no picture). 3) Pretty well defeated at this point, after doing the procedure at (2) several times with the same results, I somehow thought of pressing the standby button on the remote either whilst the two buttons on the set were depressed or just after they were released. I am afraid I cannot remember which and cannot replicate the problem as I don't know what caused it in the first place. 4) The TV then started normally ( no reception as I had not aerial connected, etc.,) but I was able to gain access to the screen menu/setup buttons via the remote which were in French rather than English. However, after reconnecting everyrthing the TV has worked fine (obviously after resetting the language via the menu). I am sorry I cannot be more precise but I hope this might be of help to someone with a similar problem.

Oct 04, 2009 | Toshiba REGZA 42 in. Flat-Panel LCD HDTV

1 Answer

When i on the tv by remote the red standby light turns into green and i hear the tv sound but not picture and after a one or two second the green light turns into red. The tv goes into standby mode when i...

the high voltage or flyback transformer is not working.the sound runs off a separate fixed power supply.if you run your hand across the screen,is there static?that would mean the high voltage is ok but there is another circuit fault

Jul 08, 2009 | Sony FD Trinitron WEGA KV-36FS120 36" TV

1 Answer

Pioneer 53

Unplug the TV for maybe 10 minutes, then turn it on. Sometimes these units simply need to recycle. If that doesn't work, you've likely got serious problems.

Apr 11, 2017 | Pioneer SD-533HD5 53" Rear Projection HDTV

1 Answer

NEC PX 42XM1A won't power on

Any chance you might think that it is your remote control faulty? As you need it to turn your plasma on from standby via remote (only). Let me know.

Apr 23, 2009 | Televison & Video

1 Answer

Picture wont come on screen

this problem is in the power supply.the red lights indicate as the standby mode.

Jan 23, 2009 | Sony FD Trinitron WEGA KV-36FS120 36" TV

Not finding what you are looking for?
Sony Grand WEGA KDF-42WE655 42" Rear Projection HDTV Logo

Related Topics:

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts


Level 3 Expert

102366 Answers

The Knight
The Knight

Level 3 Expert

75025 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides