Question about Kenwood KNA-G510 GPS Receiver

6 Answers

Kna-g510 gps receiver not working

I get a black screen when selecting the channel for the device and the title display say "Navigation off". I have it connected to the kvt-617 dvd head unit.

Posted by on

  • 3 more comments 
  • Anonymous Jan 25, 2008

    same prob. Anyone with solution?

  • Anonymous Jan 25, 2008

    Same Prob everything is hookedup correctly still Nav box still dimmed as a touch screen button... Cannot select it.

  • Anonymous Mar 11, 2008

    same problem. I have the kna-g510 connected to a kenwood ddx 8019. it was working before but now it shows a blue screen and at the top it says "navigation off" how to fix it? i tried using the sd card for updates but the navigation system doesn't power on and there is power/fuses are ok to the head unit. HELP

  • mi2much Apr 21, 2008

    Wow... I forgot about this post because I fixed the issue the evening after posting the question. What I did was doubled back and checked my power connections for the nav unit. I was using the wrong sized wire tap. I was to big and did not pentrate the wire I was tapping into fully for power. Also, If you want to watch DVDs on your head while driving just ground out the parking brake and speed sensor wires. Hope this helps.

  • turtlehunter Jan 04, 2009

    I have a DDX512 and a KNA-G510, the nav comes on for a few seconds the the screen says no nav and it is all blue, but now the nav will not show at all just a blue screen, does anyone have a solution?

×

Ad

6 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same problem wityh KNA-G430, comes on for a minute or so then the screen goes dead, then NO NAVIGATION blue screen, tried everything. The GPS comes back on after turning off and on a few times but only lasts about 1 minute. Funny thing is if navigating the sound still comes over with the directions but the screen is still blue with NO NAVIGATION displayed????Can anyone give me some idea as to what to do? Much appreciated.

Posted on Mar 18, 2010

  • Ramp1 Jun 27, 2012

    I have the exact same problem.. did you ever find a solution???

×

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Had the same problem - there are 2 din plugs in my unit it was plug into the wrong one

Posted on Sep 18, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

In the setting for NAV "off" change the setting to "RGB" that should do it.

Posted on Aug 29, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I took the unit back to the shop that installed it...they disconnected all the power to the unit by cutting the wires & waiting for 5 mins. They connected everything back & just like that it was fixed...weird because i had disconnected the battery for a full week and connected it but the unit was still not powering on. I even sent the unit to Kenwood for repair but all they did was say that there was "no problem" and that it just needed adjustment. After that i had disconnected the wires to the actual navigation unit but it still didn't work. I then tried the download update from Garmin but i never got the screen to show me anything. I even tried resetting the dvd player unit (DDX-8019) by sticking the ball point pen in the reset button a couple of times but that didn't solve the problem before...good luck with your unit hope this helps.

Posted on Jun 29, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Yes i jusy got  a  kvt-819dvd allso with the kna-g510 and my navigation will not come on it says navigation on the screen but its blank screen 

Posted on Apr 20, 2008

  • rmss Apr 21, 2008

    hay guys did you guys get your kna-g510 to work yet if not . i know what to do there is a reset buttion on these kenwoods it is a very small button you will have to use a ball pint pin to do that after you reset it press the v buttion like 1-3 times and it should come onĀ 

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same problem, did anyone get to fix it?

Posted on Apr 17, 2008

  • robtrevino Apr 17, 2008

    I have the same problem, did anyone get to fix it?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I activate navigation on a Kenwood KVY-617DVD


You need to purchase the "hideaway navigation system" Model KNA-G510 separately for your stereo in order for navigation to work. Here's the link, just copy and paste
http://kenwoodusa.com/Car_Entertainment/2009_Car_Entertainment/KNA-G510

Jul 28, 2011 | Car Audio & Video

1 Answer

How do i play dvds from my ipod to my car sterio


You get an iPod FM transmitter & connect it to your iPod and set to a free channel, press play on iPod. Then tune it in on your car stereo.

Feb 03, 2010 | Kenwood KNA-G510 GPS Receiver

1 Answer

Maps Unavailable???


You should go back to that place who installed it for you and ask them. I'm not an expert, just another poster with another problem.

Aug 25, 2008 | Kenwood KNA-G510 GPS Receiver

2 Answers

Garmin's KNA-G510 won't find satellites unless I tell it I'm in another state and it expands satellite search


I have the g510 with a kenwood head unit. On the satellite screen, on the left it only shows one satellite and on the right it is showing that there are upwards of six or so satellites that it is receiving reception from. I thought it might be the antenna, so I bought a new one. Still having the same problem. It cannot find my location. I've updated the software, I don't know what to do!!

Aug 14, 2008 | Kenwood KNA-G510 GPS Receiver

1 Answer

KVT-719 NAV button not highlighted unable to select


Well I see no help here, but emailed kenwwod and they told me:

The Garmin menu is not accessible from the main source select screen, only thru the V.Select which you have already discovered.

The reason why "NAV" is displayed as an audio source is if you were to add a GMX30 XM Radio/NavTraffic antenna, you would be able to access XM radio (subscription required). So unless you have the GXM30, you will never use that source key.

Jul 12, 2008 | Kenwood KNA-G510 GPS Receiver

2 Answers

Navigation not working


Recheck your connections on the kna-g510 and ensure it is getting power, not too familar with the kvt-819, but I've got the kvt -915 and when I pull up the screen, there is an icon right by the src icon, that looks like a wrench. Press that and find A/V interface and ensure that the navigation input is set to RGB, also you can back out and go to user interface and ensure the Navigation is set to auto intstead of manual. That may be the case if it is similar to the kvt -915.

Apr 20, 2008 | Kenwood KNA-G510 GPS Receiver

1 Answer

I need a gps with maps of europe and north america


hello i got a navigation system for sale i do have some of thoes maps ill sell it to you for a good price i need the money or i will not sell it . you can email me at . dsm_rick@mchsi.com if you are intersted in the unit . thanks 

Mar 28, 2008 | Kenwood KNA-G510 GPS Receiver

1 Answer

Installing kna-g510


You have to select your video source to GPS instead of the source in the main menu to GPS

Jan 22, 2008 | Kenwood KNA-G510 GPS Receiver

2 Answers

Kenwood DV4100


Check the navigation setup and make sure the voice guidance is set to on. If it is, then the installer didn't catch the right wire for vss. Had the same problem, after getting my unit professionally installed, figured it was a problem with unit so I upgraded to the G510 and installed the DV4100 in my other vehicle myself, caught the right vss wire and now the unit works perfectly,displays turn by turn and gives voice guidance. Read previous solutions, they really help.

Dec 25, 2007 | Kenwood KNA-DV4100 GPS Receiver

1 Answer

KNA G510 arrow looking forward but when driving going backward


if you haven't done so already, upgrade to the latest firmware and see if it fixes the issue.

firmware can be found here

if this doesn't fix the issue, post a followup, if it does, please mark this as solved.

Nov 21, 2007 | Kenwood KNA-G510 GPS Receiver

Not finding what you are looking for?
Kenwood KNA-G510 GPS Receiver Logo

1,780 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood GPS Experts

yadayada
yadayada

Level 3 Expert

79066 Answers

Michael Galve
Michael Galve

Level 3 Expert

1269 Answers

Mike

Level 3 Expert

4348 Answers

Are you a Kenwood GPS Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...