Question about Hifonics Brutus BXi 1206D Car Audio Amplifier

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp

I have a hifonics brutus bxi 1206d amp and the power light turn on but no sound comes out can someone help me with this problem

Posted by on

  • 4 more comments 
  • datown7500 Jan 02, 2008

    yeap i check out all of that but the problem is in the amp

  • nenesto Jun 06, 2008

    everything was fine, connections are good, all new wire and evrything, had it in for a year pushin some 2 audiobauhn 10" subs, suddennlly just stopped workin, speakers work with other amp, burtus seems fine, green light and everything, but no sound?

  • chrls5 Jan 06, 2009

    hi there, it seems like brutus has some kind of a common design problem, the thing is that my brutus has the same symptoms, one day i was using it not even in the loudest setting and suddenly it just turned off , i went to check that out, but the power led was on, so i asked my self , what the heck is happening?, so i opened my Brutus BXi 606 and ran some tests to it ,, i'm still looking for the reason why the Brutus has no sound output, the thing is that the power led is controlled by a peripheral transistor that is not monitored by the (PSCU)power supply central unit it just turns on without knowing that something is wrong with the amp, one thing that i checked is that the switching mosfets are ok , but for some reason the pulse is either not coming out os the SMPS, or it comes out but gets attenuated in the switching protection stage, or better yet, in the very last part before it gets into the mosfet, there are 4 zener diodes, i don't know why,, and something in there i think is going on. so i decided to run a little test so y hooked up my external power supply and all grounded ok, so y took a wire and put it in serial with a 100 ohm resistor, then in free air y got like 12.35volts, and when i connected this to the stage where i said where the zener diodes, it fell down to 0.86volts, something very strange going on,, because i myself have done some SMPS's and from what i know , the pulse has to be as high as the voltage being supplied by the battery, so i am really confused, i hope this helped, I'm still looking for thew problem , just happened yesterday.

  • Anonymous May 12, 2009

    Same thing here, blue front lights up and everything

  • Anonymous Mar 23, 2014

    I have a Brutus elite hifonics BRE1600.1D
    The power cable leading directly to the amp loosened from the battery so the amp lost power.
    fixed that issue but now the amp doesn't kick as loud as it use to before the power lose. I tried a different amp and 12in L7 sounds fine. Any possible fix for the Brutus? Thanks.

  • Anonymous Apr 01, 2014

    I Have a Hifonics BXI 1606D that i got blown with all the Power Mosfets taken out, the output mosfets seem to be in tack they are: IRF3710. I really need the help in finding the right Mosfets for the power. Thanks in advance

×

Ad

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Ya my hifonics 1206d did about the same thing seemed to be an easy fix with power supply fet shorted and a fet in the finals this amp will seem to come on with a shorted final output but anyway mine worked for a little wile then started making a popping soud at high volume. found out the built in cross over has issues unfortuatly the parts on this doughter board have the part numbers removed and cant get a manual so i wait till i come across another one to compare with, since i fix car amps in my shop all the time.i think hifonics are not what the used to be back in the 90's like most amps now adays.

Posted on Mar 18, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same brutus 1500 d amp running two kicker 12' L7s in my escalade and it just did the same thing last week. funny thing is now the mids/ highs and 8' sub in the front run stronger than ever! i'm going to call hifonics to see what can be done and post what i find out for all..

Posted on Feb 17, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a hifonics brutus 1500damp and it has no sound where can i send it...but i dont have paperwork on it got it off the streets for 40.....

Posted on Oct 21, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Posted on Jan 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is the brutus amp blue led light suppose to stay on when the car is off?


No. The LED should be off when the radio is off (amp turns off as well)

It sounds like you have constant 12volts applied to your remote turn on lead. The amplifier will have 3 connections for power:

1. 12volt constant
2. chassis ground
3. 12volt switched power - this wire should come directly from your head unit. It only sends 12 volts when the radio is on allowing to amp to power up only when the radio is on.

Dec 22, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Where i could buy the spare part of my hifonics brutus amp? especially the chip type powers, can I bought it here in the philippines?


The parts are probably available mail order from companies like Digikey, Mouser and others. We need a part number to help further.
Sometimes companies have the chip manufacturers put a "house number" on the part rather than an industry standard to try to hide their design... those take a bit of reverse engineering to figure what the part is.

Dec 11, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Hifonics brutus 2000 watt help??!!??


If an RCA took a dive your amp has most likely seen a very nasty input spike and may never be the same as its circuitry has been damaged.....sorry

I’m happy to assist further over the phone at https://www.6ya.com/expert/robert_aad3edb7dfa380b9

Mar 09, 2009 | Hifonics Brutus BXi 1206D Car Audio...

2 Answers

Hifonics amp keeps blowing the main fuse


have u tried using thicker wire from the battery to the amp u need to put a fuse in there thats a minumum 60

Jul 15, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Brutus 1206D


set the lp filter to about 100 to 125 (or lower if want seep boomy only) , put the bass eq no more than 75% but i would recommend no more than 50%, gain is to match the sound not to adjust power with so it is a user preference start all the way down and slowly go up till u hear distortion then turn it back down by about 10 - 15 %, phase shoild typically be at 0 degrees, subsonic depends on if you r using sealed or ported ported turn it all the way down then adjust as needed to get rid of the lower sounds you dont want (muddy sloppy sounding bass) if sealed turn it all the way up to at least 35 hz.

Jun 18, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Brutus 1206D


u need at least another amp and set em at 2 ohm and then just take it to a shop aand ask thee guy to equalize it he shouldnt charge u or at least 10 bucks

Jun 18, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Brutus 1206D


yes it can only at 2 ohms never 1 ohm good luck

May 25, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

High Pitch Whine from Amp (not speaker)


make sure your rca andpower/remote wires are ran on seperate side of your car.it maybe recieving some kind of interference from the alternator. try buying higher shielded wiring too

Apr 20, 2008 | Hifonics Brutus BXi 1206D Car Audio...

Not finding what you are looking for?
Hifonics Brutus BXi 1206D Car Audio Amplifier Logo

2,024 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1165 Answers

Jaime Hernandez

Level 3 Expert

2336 Answers

Marvin
Marvin

Level 3 Expert

82322 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...