Question about DFI NT70-SC Motherboard

1 Answer

Dfi wt70ec socket 423 board never used and visiontekx1300512mb agp

Dont boot up getting 1 long beep and 2 short beeps
power supply new grafics card ati x1300 512mb agp installed
all drives spin motherboard lites up fine cpu installed correct.
all cards installed correct just no bios started.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 2,351 Answers
Re: dfi wt70ec socket 423 board never used and...

Either video adapter is not seated properly. Remove the video card & reseat.
Also, check to ensure the monitor cable is connected properly.

Posted on Jan 01, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

3 log beeps on power on

Gigabyte doesn't list 3 long beeps as an error code, so I'm not sure if you're actually getting 3 short beeps or maybe 1 long and 2 short or... But, for reference, Gigabyte's error code list is as follows (depending on whether you have an AWARD BIOS or an AMI):

1 short beep: System normal
2 short beep: CMOS Error
1 long beep and 1 short beep: Memory error
1 long beep and 2 short beep: Graphic card error
1 long beep and 3 short beep: AGP error
1 long beep and 9 short beep: Memory Error
Continuous long beep: Memory not correctly installed
Continuous short beep: Power supply unit failed

1 short beep: Memory Error
2 short beep: Memory parity check error.
3 short beep: Basic memory 64K address check error
4 short beep: Real Time Clock malfunction .
5 short beep: CPU error
6 short beep: Keyboard error
7 short beep: CPU interruption error
8 short beep: Graphic card error
9 short beep: Memory error
10 short beep: CMOS error
11 short beep: CPU cache memory malfunction

It might not be a lot of help, but it's somewhere to start... and at least this way you'll know what to be listening for.

Nov 30, 2013 | Gigabyte Motherboards

1 Answer

PC Freezes During Boot and at the BIOS Screen, EVGA P55 Classified 200

Beep Code Descriptions

1 short beep Normal POST - system is ok
2 short beeps POST Error - error code shown on screen
No beep Power supply or system board problem
Continuous beep Power supply, system board, or keyboard problem
Repeating short beeps Power supply or system board problem
1 long, 1 short beep System board problem
1 long, 2 short beeps Display adapter problem (MDA, CGA)
1 long, 3 short beeps Enhanced Graphics Adapter (EGA)
3 long beeps 3270 keyboard card

Aug 30, 2012 | Evga P55 Classified 200 (160LFE659KR)...

1 Answer

I have a DFI LanParty NFII Ultra motherboard. I had to move the power supply to a different machine and have purchased a new one to drive the DFI system (Win Power) rated at 650w. The power standby...

It's the craziest thing, I'm looking dead at the Motherboard Manual for the DFI LanParty NFII Ultra B motherboard, and the diagnostic LED lights are Not referred to.

Looking at the view of the System Board, the LED lights are shown down by the CMOS Battery.
LED 1, 2, 3, and 4.

The manual indicates only two types of BIOS Beeps are listed;

1) One Long beep followed by Three Short beeps.
Video error has occurred and BIOS cannot initialize the video screen to display any additional information

2) Single Long beep
A DRAM error has occurred. {Problem with the Ram Memory modules}

The BIOS program is a Phoenix - Award BIOS, but doesn't indicate what version or date.

[ The motherboard manual is downloaded for free from here,

Go to > To view the Products Manual - or to Download it - just click HERE.
{Click on HERE}

Allow up to 30 seconds for the file to download.

Offhand I would say it is Ram Memory that is the problem. Remove the ram memory module/s, and clean the gold plated contact pins with a pencil eraser, then use air to remove the eraser dust.

However, in looking up for information on the diagnostic LED lights, (The info IS out there. Maybe on DFI's support website, but I couldn't find it), I see that if you are using a graphics card that requires an additional power cable, you'd better have that baby plugged in.

The motherboard won't work if the additional power cable isn't plugged into the graphics card.


Dec 06, 2010 | DFI LanParty NFII Ultra B Motherboard

1 Answer

Abit av8 bios post codes 8.3 - 8.6 - 9.c What is failing on boot ? I get one long beep followed by 4 short beeps. I have swapped video cards and reflashed the bios with no help. If I reboot 2 or 3...

I still did not find beep code that match your problem..

Anyways here are the common beep codes for your motherboard.. it might help you too.
1. No beep - no reaction, the mother board is dead, power supply problem, processor and or ram problem.
2. 1beep - board is working fine.
3. One long beep then it shuts down - cpu problem, your processor is not working or missing.
4. 1short beep - system boots normally
5. 2short beeps - CMOS setting error.
6. 1long 1short beep - dram error
7. 1long 2 short beep - video card or monitor not connected
8. 1long 3 short beep - keyboard error.
9. 1long 9short beep - ROM error
10. Long beep - memory card is missing or not connected
11. Short beep - power supply error
12 Four beeps - there is no fan detected on Fan1 or Fan2 header. make sure to attach or reset CMOS bios to factory setting.

Hope this gave you an idea of your problem..

Much appreciated if you rate this help..thanks..

May 23, 2010 | Abit AV8-3rd Eye Motherboard

1 Answer

I have a DFI AM75-TC motherboard, 3beeps, no video

Hi richardbyers, three short beeps means there is a problem with your memory. (Base 64K memory failure). Unplug the power from the PC. Open the case & touch the bare metal on the case to discharge your self.
Remove the memory & reseat it. Leave the case opened & re-connect the power cord & try booting again. If you still hear three short beeps, shut the system down again as mentioned above. Gather some house hold alcohol & a couple cotton swabs. Drip a drop or two onto a cotton tip & wipe the memory's contacts, both sides & do not touch the contacts with your fingers during re-install or cleaning. Blow the memory slots out with canned air or use a clean paint brush. Insert the memory again & connect the power cord. Boot the PC. Try this first. If everything works out than good. If the problem does not clear its self let me know.

Good luck richardbyers!

Jan 06, 2009 | DFI AM75-TC Motherboard

1 Answer

I got beeps on my pc

1 Long beep and 2 Short is Graphics related.

Change GFX card if PCI/AGP
or if onboard install a GFX card and see what happens (with RAM and CPU reinstalled)

if it still bleeps with new card then remove power from PSU, remove BIOS batt and wait 10 mins (or do the bios jumper trick)
(still with new card installed)

just a thought... its always best to remove Data cables from board aswell as power from the devices (hdd,odd etc)

let me know how you get on...

Dec 08, 2008 | ASUS P5S800-VM Motherboard

2 Answers

My ECS 915 G-A elite group motherboard doesnot display anymore on the monitor..

have you tried to isolate what the cause of the problem? first check the video card if is properly inserted into the slot, and check the memory, and cable from CPU to monitor if it is connected properly. then boot your system. And try to observe this beep error code this might help you locate where the problem is.

short beep System is OK
2 short beeps POST Error - error code shown on screen No beep Power supply or system board problem Continuous beep Power supply, system board, or keyboard problem Repeating short beeps Power supply or system board problem
1 long, 1 short beep System board problem
1 long, 2 short beeps Display adapter problem (MDA, CGA)
1 long, 3 short beeps Display adapter problem (EGA)
3 long beeps 3270 keyboard card

thnk you.

Nov 29, 2008 | Motherboards

1 Answer

Agp issues

Do you have another video card to try? If so try it. But it sound like something is not seated correctly. Please respond back. Also do you have a built on video card for this board?

Feb 12, 2008 | Intel Desktop Board D850EMV2 Motherboard

1 Answer

AD77 Pro

Well 1 long with 2 short is a video problem. If not intergrated, remove the video card. Cean it & the slot. The other weird beeps may be for the memory. Remove & re-seat the dimms.
Here is a link for your AS77.


Jan 22, 2008 | DFI AD77 Pro Motherboard

Not finding what you are looking for?
DFI NT70-SC Motherboard Logo

Related Topics:

119 people viewed this question

Ask a Question

Usually answered in minutes!

Top DFI Motherboards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers


Level 3 Expert

5660 Answers


Level 3 Expert

2598 Answers

Are you a DFI Motherboard Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides