Question about Kenwood Excelon KDC-X789 CD Player

1 Answer

Amps and sub-woofer not working

Sub-woofer is on through the radio, getting power, pre-outs are hooked up, no sound coming through the woofer . . . Any suggestions?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Enter into the Audio Setup mode(press and hold volume button for at least 1 second). Next, repeatedly push the volume button until the display shows "2 ZONE". Make sure this feature is turned off. Hold the volume button again for at least 1 second to leave Audio Setup mode.

Now you need to make sure the Subwoofer Output is turned on. Do this by holding down(AM position) on the control knob(toggle stick) for at least 1 second. Each time the button is pressed, the Subwoofer Output is turned ON/OFF. the display should show "SW ON".

Next, you can go into Audio Control mode(press but do not hold volume button). Keep pressing on the volume knob until "Sub-WLevel" is displayed. Here you can adjust the amount of gain for the Subwoofer ranging from -15 to +15.

I hope this fixes your problem with it.

Cheers

Posted on Mar 13, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have no sound coming out of my sub woofer on my kenwood VR-407 everything else works great anyone have any ideas or solutions


yes it very much has everything to with it. your sub out is at a pre-amp lvl, so you can route that signal to another amp, then to your passive sub, or get a powered sub

Apr 19, 2013 | Kenwood VR-407 Receiver

1 Answer

Need sub woofer


Any powered sub woofer will work. Just hook it up to the sub pre out with an RCA Cable.

Aug 02, 2012 | Aiwa AV-D57 Receiver

1 Answer

Preout section cannot ingage


If you are using a pre out to a sub woofer, you need to make sure that the sub has it's own power amp or it will not work. You also need to go into the user menu and tell the amp that you are using a powered sub. Otherwise it will not turn on the pre amp output

Jun 20, 2012 | Denon Avr1610 5.1-channel Home Theater...

1 Answer

QUESTION ABOUT SPEAKERS. SPRCIFICALY WOOLFER. WHAT KIND OF WOOLFER SHOULD WORK BEST WITH THIS AMP?


hi,
Do you mean sub woofer. Then you can select any brands Active sub woofer ( active means built in amplifier) to connect with your system. They comes in different power (watts). you can use an active sub woofer with 100W output.
connect the sub woofer pre out of you amp to the pre input of sub woofer.
ok

Feb 05, 2011 | Technics SA-EX500 Receiver

1 Answer

Sub woofer


You are suppose to hook subs up to a amp.

May 04, 2010 | Car Audio & Video

1 Answer

No sound


if the display is working your pre-amp is ok
check the sub-woofer
amplifier is in the sub-woofer, check fuse inside first
after that mail again, thanks

Feb 15, 2010 | Bose 3 2 1 GSX System

1 Answer

I have a passive 450 watt sub that i have conected to my amp but i get no sound my amp is a mc voice 5.1 esl 24 bit amp


If this is a straight power amp it might require a pre amp
that inputs decoded 5.1 signal other wise the sub may not be receiving an input signal.
make sure there is nothing wrong with the sub by hooking it to one of the other channels FL or FR if this works then it got to be a problem with no signal getting to the sub woofer.

Nov 25, 2009 | Audio Players & Recorders

1 Answer

No Sub Woofer Pre out output


I've got the same model and the pre out transistor needs to be replaced,
sometimes you can get it to work by unplugging the reciever and the pre out
then plug in the reciever and plug the pre out in a couple of times or so untill it comes on
or unplug the amp from the wall then plug in the pre out , turn on the reciever wait for sounds to come on then plug in the amp.
if that don't do it the pre out transistor needs to be replaced

Oct 16, 2008 | Pioneer VSX-D511 Receiver

1 Answer

Amp and sub bass playing through all speakers


You need to go into the setup menu and find out if the radio has a sub low-pass filter that redirects the bass to the pre-out for the subs, and away from the main speakers. Fiddle in the audio menu.

Apr 15, 2007 | Xtreme Sound WMS336 CD Player

Not finding what you are looking for?
Kenwood Excelon KDC-X789 CD Player Logo

222 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4915 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

78238 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...