Question about Alpine MRD-M605 Car Audio Amplifier

1 Answer

Alpine amp mrd-m605

My alpine amplifier says "CUR" and isn't playing any sound out of it.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

The amplifier probably has shorted output transistors. If the amp gives the same error message with the speaker wires disconnected from the amp, the amp needs to be repaired.

Posted on Dec 31, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Is the alpine 3552 any good? I can't find any reviews.


alpine makes amaizing amps... as long as it's matched to the speakers/subs you are going to put on it this amp will last you a very long time... and it will put out amazing power... you won't be disappointed.

Dec 02, 2009 | Alpine MRD-M605 Car Audio Amplifier

1 Answer

How do you get it out of cur mode


Hello whatup_132,

If the M605 fails and displays "CUR", it means that there is excessive current to the amp.

The most common causes for excessive current draw is operating the amp into a lower impedance than it is rated to handle, shorted speaker voice coil(s), and/or shorted or grounded speaker wires.

The amp can operate into a load no lower than 2ohms. First power everything off and disconnect the positive amp power lead temporarily (easist way is to just pull the fuse). At this point you should ONLY have the ground and remote connected. Reconnect positive (insert fuse) and turn on the vehicle ignition and your head unit. If the amp still displays the "CUR" error, the output MOSFET's are probably defective and the amp requires repair or replacement. If it powers up normally, reconnect the speaker wires until you locate the faulty one, and then correct whatever is causing it.

Hope this helps.

Jul 17, 2009 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

2 Answers

I have an Alpine MRD-M605 amp that recently has started having issues. My subs only produce sound when my deck is turned up full blast. The setup had been working for over a year with no problems. The subs...


If your deck is aftermarket; Does it have a dedicated Subwoofer output? if so, check the control in the deck (sub gain). If you are using a factory radio, and a high to low level adapter (speaker wires to RCA), it may be bad (not too uncommon) or check your fader front/rear any difference? Otherwise, you have one of two problems. A bad preamp in the deck or a bad pre amp in the amp. Both are fairly uncommon. More than likely it's a setting. Hope this helps

Jun 23, 2009 | Alpine MRD-M605 Car Audio Amplifier

1 Answer

CUR display


Hello yte1771,

You can download the manual from Crutchfield.

The "CUR" display is an indication of excessive current and is most likely caused by too low impedance or a fault in the wiring or the amp itself. It's probably not your cap.

Hope this helps.

May 18, 2009 | Alpine MRD-M605 Car Audio Amplifier

1 Answer

CUR on alpine MRD M 605


check your ground and make sure you battery power is connect properly

Apr 14, 2009 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

1 Answer

CUR is showing on the display


The amp will reset when you cut the power off to it. Disconect bat for 30 sec and reconect. But to be honist with u if the wire jumped out and grounded some how during a high level, there is probley internal damage done.

Oct 17, 2008 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

1 Answer

CUR showing on the display


This means too much current, find and eliminate cause of excessie current and turn power off, also possibe power and ground are not big enough .Recommend 4guage wires

Oct 17, 2008 | Alpine MRD-M605 Car Audio Amplifier

1 Answer

CUR showing on the display


Have you measured the DC resistance of the woofer to determine if it's OK? You will need to disconnect it from the amp. Check each voice coil individually.

 

If you disconnect both speaker wires from the amp, does it still show an overcurrent condition?

 

 

Oct 20, 2007 | Alpine MRD-M605 Car Audio Amplifier

1 Answer

Mrd-m605 troubleshooting\


Yeah, how about you give us more info please.

Oct 26, 2006 | Alpine MRD-M605 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRD-M605 Car Audio Amplifier Logo

Related Topics:

179 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4946 Answers

hoyzee1

Level 2 Expert

150 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...