Question about Texas Instruments TI 810 Matrix Printer

1 Answer

TI 810 Blowing F2 fuse

I have a TI 810 dot matrix printer that blows the F2 (3A, 125 V) fuse as soon as the power is turned on. I've disconnected all cables from the motherboard, and tried different power supply, driver, and processor boards, but F2 still blows. Anyone have any ideas?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that got 5 achievements.


    Visited the website for 3 consecutive days.


    An expert who has answered 20 questions.

  • Contributor
  • 40 Answers
Re: TI 810 Blowing F2 fuse

Try Changing the bridge rectifier near the transformer.

Posted on Dec 31, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Print head lowest pin not working

The printhead is probably bad. You can check the cable for complete insertion, unusual wear or physical cuts. There are 2 nuts on either side that attach the head to the carrage. Remove these and you can remove the printhead. There are little coils and hammers that strike the wires. Look at those for burns, misalignment or the wires being broken or too short.
Replace the printhead if necessary.

Apr 02, 2014 | Texas Instruments TI 810 Matrix Printer

1 Answer


The paper out switch is on the left behind the paper. It is loose or has gotten bent. Tighten the screws or bend the lever out towards you a little and reinsert the paper.

Jan 18, 2014 | Texas Instruments TI 810 Matrix Printer

2 Answers

My TI 810 printer has begun to error out. It prints a few lines, and the lines appear to "slide" to the left, until it is printing off the left edge of the paper, and then it stops printing, and the error...

This is a ribbon problem, it needs to be changed. The fact that the lines "slide" to the left prove that the carrier is not going back to its original position every time.
So, the solution is to change the ribbon.

Aug 24, 2010 | Texas Instruments TI 810 Matrix Printer

3 Answers

Blowing out fuses

Check that your getting clean power, not daisy chaining the printer through several power strips, and that if running off a battery or strip that you have not overloaded the circuit.

Oct 06, 2009 | OKI MICROLINE 320 Turbo Matrix Printer

1 Answer

Drivers needed for ADP 210 dot matrix printer

Feb 21, 2009 | Epson LX 810 Matrix Printer

1 Answer


Stone Systems $55.00 - 1-3 day lead time - Call: 1-800-289-9973

Ask for Rob Stone

Jan 08, 2009 | Texas Instruments TI 810 Matrix Printer

1 Answer

Windows xp printer install

Hi, Have you tried the Epson driver "ep10759.exe"? It is available at It this still doesn't workout for you, pls post back as to how you connect the 810 to your PC (USB or LPT/Parallel), Good luck and kind regards.

Oct 08, 2007 | Epson LX-300 Matrix Printer

2 Answers

Printer isn't printing in english or any other "language"

Usually when that happens there is a loose cable. If that doesn't fix the problem try downloading new drivers to see if that helps.

Jul 23, 2007 | Texas Instruments TI 810 Matrix Printer

Not finding what you are looking for?
Printers & Copiers Logo

Related Topics:

245 people viewed this question

Ask a Question

Usually answered in minutes!

Top Texas Instruments Printers & Copiers Experts

Gareth Cockram
Gareth Cockram

Level 3 Expert

657 Answers

Shawn DuRee

Level 3 Expert

353 Answers

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Are you a Texas Instruments Printer and Copier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides