Question about Vacuums

1 Answer

Hoover upright windtunnel isnt propelling itself anymore

It has suction, it just wont go foreward and its hard to push. i opened the bottom part and saw that the v shape belt was loose but i dont know if thats all i have to do. i cant find a manual online for u6470-900 hoover. should replacing that one belt make it work..in theory?

Posted by on

  • Anonymous Mar 11, 2008

    besides no self propell, the height adjustment is messed up. very short pile carpet. to set to medium is too high, to set to low pile it just drags. someone recently changed belt 4 me then caught long carpet string- put machine away like that and didn't tell me. haven't been able to use it since.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

If the V belt is loose with the handle down, then maybe the idler wheel under neath the belt isn't contacting the belt, may be jammed down, just push on it to see if it moves up and down. Belts don't last very long, you may want to replace both of them.

hoover upright windtunnel isnt propelling itself a - 510ca75.jpg

Posted on Feb 14, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Hoover Windtunnel bagless self-propelled model #U6616-90. The vaccuum works fine, but the suction hose will hardly ****. There are no obstructions in the hose line. What could be wrong?


The only possible place where it could be clogged is where the hose goes into the motor if the hose is clear. Take the bottom off completely and use a flashlight and investigate. Hope this helped.

Jan 05, 2011 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover self-propelled windtunnel U6430-900 flat belt gets hot & becomes hard to push. It has a filter bag. Purchased 8/2/01. Took one plate off bottom. Used a compressor to blow out dirt & dust. ...


Belts get hot when fibers from carpet get wound arounf the belts mounting shaft. Best to take a razor and cut off any fibers so the belt doesn't get hot again

Aug 10, 2010 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover windtinnel suction problem


the intake hos at the bottom might be clogged.first take all the filters out and disconnect the hos completely from the vacuum,then check and see if you have suction.the intake hose is the clear looking one at the bottom that wrapps itself up from the base to the backside of the upright.you can use a coat hanger to push out the clog if there is one just bend the tip till its rounded.work it down into the intake hose from the back.after removing the hose and the filters you should have suction.just make sure all the filters get cleaned .you can blow out the hose with a garden hose

Apr 02, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover WIndtunner 7600 no suction


According to the manual on your machine, you can either have a broken belt, or the switches to the self-propel switch, and brush switch are in the off position. I have included a link to your manual. Please look at pages 13-14 under troubleshooting.

http://www.hoover.com/pdfs/manuals/U6439900.pdf

I hope this helps.

Jan 18, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

3 Answers

Self Propelled does not work


if you look below the headlamp of your vac you will find a cable that attach's to a piece called the actuator arm. either this piece is likely broke or the cable itself. always work the power drive smoothly or things will break. also could be that the smooth belt is stretched and will cause the same problem. belts should be replaced every 4 months. good news is all parts above should be under $5. dont let anyone tell you that you need a power drive assy, that usually isnt the case. good luck!!!

Sep 24, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Suction


absolutely all the air in a vacuum would pass through the filter and if its clogged badly you could loose all your suction and if the belt is more than a year old then replace it even if it isnt broken ( they stretch out over time )

Sep 17, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover self-propelled


No suction on Windtunnel 6630-900. All belts work, brush turns, it just won't pick up anything.

Sep 07, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover Windtunnel selfpropelled bagless vacuum


Hoover emailed me back right away with a solution and a thorough explanation for a very easy fix. I guess I should have thought of that myself. Oh well, but that did not cost me anything. Now that makes me happy.

Jun 18, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Bad smell


it may be the roller bearings?

Dec 26, 2007 | Hoover U5450-900 Windtunnel Supreme Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

270 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...