Question about Sony WEGA KE-42M1 42 in. HD-Ready Plasma Television

2 Answers

Sony WEGA KE-42M1 sound but no picture.

I have a Sony WEGA KE-42M1 Plasma tv that we have had for a little less than 5 years. Suddenly, a problem developed a little over a week ago that when you turn it on, it has sound but no picture. It was like that for a few days and then all of a sudden, we turned it on and the picture and sound were both working again.

That only lasted for a couple of days and since then, only the sound comes on. Can anyone tell me what the likely cause of this problem may be?

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I have the same problem! did you ever solve the issuE??

Posted on Mar 30, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

Your x-main board is probably bad, and/or your power supply. It's most like the x-main board.

Posted on Jan 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony KE-42M1 Volume Out Settings Change


Some of the sets in the service menu you can be altered but usually it is only for initial vol level when set is turned on. All adjustments are done with the Sony remote.

Aug 31, 2012 | Sony WEGA KDE-61XBR950 61 in. Plasma HDTV

1 Answer

Sony wega KE-42M1 .power lead ok . no power at tv. (no standby or power light showing at on switch). house power went off , when it came on tv wouldn't work


This confirms that the main power supply which is the SMPS is faulty.
The fuse could have failed and must be checked, if the fuse fails the SMPS is confirmed to be faulty due to the power outage.
please check the links below for tips and support:

http://www.fixya.com/support/r5826301-working_switch_mode_power_supplies

http://en.wikipedia.org/wiki/Switched-mode_power_supply

Sep 21, 2011 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

1 Answer

Hi, my sony plasma KEP42M1 keeps switching off and on automatically especially during the first hour run, apparently common problem with this model cause also a friend of mine has the same problem. Can you...


its a problem with the onboard power supply it needs to be replaced. im sorry for the bad news hope that doesnt mean a bad rating for me.. you can try to reset the power supply by keeping it unplugged for about 20 minutes.

-brian

Mar 17, 2011 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

2 Answers

Thin white horizontal lines!!! I've had my WEGA KE-42M1 for 5 years with no problems until about three months ago. After about an hour being on, there are thin white horizontal lines that move randomly...


Sounds like your TV is giving out, plain and simple.

If this doesn't sound right, then only one thing comes to mind. Have you moved the TV recently? Are you using a different coax cable, (if using cable that is). If so, just change the cable back to the previous one and you should be fine.

Aug 21, 2010 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

2 Answers

No picture but there is sound i can turn it on but no picture


el televisor lo prende y se oye, pero no se ve. hay veces que lo prendo y se ve.

Jul 22, 2010 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

1 Answer

No picture-Sony


did you ever get your tv repaired?

Apr 29, 2008 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

1 Answer

Sony wega 60" tv


SOUNDS LIKE ANOTHER LAMP. WHICH MAY JUST BE BAD LUCK. PROJECTION LAMPS CAN GO OUT IN ONE DAY OR LAST TEN YEARS THERE SUPPOSE TO AVERAGE 4000 TO 6000 VEIWING HOURS AND THERE ARE MANY DIFFERENT FARIABLES THAT CAN AFECT IT. IM ASSUMING YOU HAVE A KDSR60XBR1 WHICH HAD A PROBLEM WITH THERE OPTICAL BLOCKS. I HAVE REPLACED MANY AND NEVER HAD A CALL BACK YET IN REGAURDS TO THAT BUT LAMPS ARE A DIFFERENT STORY. I WOULDNT WORRY IF I WAS YOU BUT IF THIS NEW LAMP GOES OUT SONNER THAN EXPECTED THEN I WOULD LOOK AT THE BALLAST IT IS WHAT POWERS THE LAMP

Feb 20, 2008 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

1 Answer

Sony Plasma Wega KE-37XS920 No VideoSignal


If you still have your receipt for repair...take it back for repair again.
This time, you should have some kind of warranty on the last repair, so you should have to pay minimal (if anything) to get it fixed again.

If it is the logic board, insist that you are given the faulty one....that way you can see that it has been done and you can then dispose of it at your leisure, "knowing" you have not beem conned into paying for services not given.

Hope this helps

Oct 16, 2007 | Sony WEGA KE-37XS910 37 in. HD-Ready...

Not finding what you are looking for?
Sony WEGA KE-42M1 42 in. HD-Ready Plasma Television Logo

Related Topics:

2,075 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

The Knight
The Knight

Level 3 Expert

76046 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1691 Answers

Steve Allison
Steve Allison

Level 3 Expert

5569 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...