Question about Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum

1 Answer

Bad smell after using my windtunnel for a couple of minutes i noticed an odd smell. i turned it over and checked, the belts are fine but i cleaned out the hair anyway. after doing that the self propel seems to struggle and it is hard to push. when i look through the window on the top i can see the brush spinning freely but then when i push it, it slows down dramatically and then picks up again. the suction is fine. what do you recommend?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    Uploaded 5 video answers.

  • Expert
  • 152 Answers
Re: bad smell - Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum Vacuums

It may be the roller bearings?

Posted on Jan 02, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have a Hoover WindTunnel with a bag that makes a burning smell. I cleaned the brush and the belt looks intact. It still smells really bad. Could it be as simple as needing a new belt?

Hi there,

yes it could be that simple. sometimes the belt will wear and stretch. Generally I advise my customers to replace the belt once per year, or as soon as something gets caught to stop the brush from turning.

Your belt number should be on the model/serial plate on the bottom of the unit there. 38528-###. I am guessing its a 38528-033 but could be 38528-040. Your model/serial plate will be more accurate.

Nov 05, 2010 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

After a few minutes of using my vacume it starts to smell like burnt rubber. like the belt is burningthe only belt I can see looks fine and is turning the brush

but how tight is the belt and how easy is the brush to turn? if the belt is slopy it will slip on the motor drive spindle,,,and it will get very hot then,,, also if the brush head is tight that makes the belt slip too,

Aug 11, 2010 | Hoover U5780-900 Windtunnel Cyclonic...

1 Answer

HI, my motorized brush barely turns.It makes a hot rubber smell. I took apart and noticed the spindle the belt turns on discolored from heat. Cleaned it, but still no turning of the brush.The vac is a...

That means that the belt is stretched and it is slipping on the motor shaft, that is why it is hot and smells like burning rubber. You need to replace the belt. Here is the correct belt you need:

Hoover Windtunnel Canister Belt

Dec 24, 2009 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

The brush roller stops turning and I can smell the belt burning, then it will catch and start working normal. I looked under the plate to check the belts and they looked okay and no hang ups of string or...

better to replace both belts the smaller one is stretched out thats whyits slipping ,be sure to clean the old rubber off the motor shaft before replacing the will cause the new belts to run unevevly and go bad before their time

Aug 30, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Loose paint is stuck in my Hoover 5753-900. Now it won't turn on

Take the bottom plate off where you would install a new belt. the impeller is clogged up. use a wire to poke out the clogs. you can use a shop vac to **** out the debris. check your belt for wear spots while your at it. you may need a new one . befor removing the belt. make sure you notice in what direction it is installed. If you put it on backwards you brush will turn in the wrong direction,not good. draw a picture if need be. Ok good luck DFD

Apr 11, 2009 | Hoover U5753-900 WindTunnel Bagless...

2 Answers

Burning smell coming from vacuum

use a penny to turn the 2 screws on top a quater turn then fold down the vacuum and lift up the cover and you will have access to the belt. Clean the small hepa filter with soapy water. their may be 2 of them. The cannnister filters need to be shaken but not washed. Good luck.

Apr 09, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover U5468-900 WindTunnel Supreme suction is suddenly poor

The other possibility is there is a blockage in the foot. these models have dual channel air flow (windtunnel) and become blocked when not cleaned depending on use. under the roller there is a cavity that can be removed for cleaning. a hot motor can be caused by poor air flow.

Mar 15, 2009 | Hoover U5453-900 WindTunnel Supreme Bagged...

1 Answer

Burning smell when vacuuming, not belt

Try turning the vacuum on and hold the base up so you can see if the roller is turning. Odds are it is not and what you smell is the belt burning (not literally). If the roller is not turning, look for anything that is binding it - after you have unplugged the power cord. Probably the roller head is not fully aligned with the retention lugs that hold it in place or the belt is not properly placed on the roller itself, or if it is a used model, hair and twine can get tangled in the roller and cause it to stop turning.

Dec 26, 2008 | Bissell 5770 Healthy Home Bagless Upright...

2 Answers

Rubber smell, Hoover

Well it sound like you do need a new belt because of how the smell is you might want to stop using it because the smell comes from the burning and over heated belt my solution would be to get a new belt and that should fix it if you need anything else you know whre to find me.

Jun 30, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum Logo

Related Topics:

146 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts


Level 3 Expert

18257 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides