Question about NAD C372 Amplifier

2 Answers

Nad c372 Remote Control

Just purchased a refurbished unit for my son and all works well except the remote does not work the volume. The lights flicker as if the signal is being received but volume will only change at the unit and not with remote. Would appreciate any assistance.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Nad c372 Remote Control

G'Day Bozobob
I have had the same problem which required a replacement motorised pot. I've also had a small cap fitted next to the heatsink on the positive rail regulated supply transistor go pop! Bad smell, protection circuitry operates.
Great amp, great design, poor quality assembly and QC. NAD need to lift their game!
Colin Walker
(30 years electronic repair industry)

Posted on Jan 06, 2008

  • Level 1:

    An expert who has achieved level 1.


    An expert that got 5 achievements.


    An expert who has written 20 answers of more than 400 characters.


    An expert who has answered 20 questions.

  • Contributor
  • 36 Answers
Re: Nad c372 Remote Control

Hello Robert,

If the standby/protection indicator on the amplifier blinks when you specifically press the volume +/- key, it obviously indicates that the unit is receiving the remote's command.
Try the following while pressing the volume key on the remote:
1.- Put your ear as close as possible to the volume control knob and listen for the sound
of a motor spinning, if you hear it, the volume control assembly needs repair. If you
hear no sound, proceed to next step.
2.- Gently rotate the volume control knob on the amplifier unit (it might be stuck and
needs a "little help").

If none of the above applies, the unit needs to be opened and troubleshooted. I've seen many instances where the volume control motor was not properly connected to the board or the assembly was put back incorrectly (specially in units that have been opened to be refurbished). I've heard NAD has a limited warranty for refurbished items. It might be wise for you to check before sending the unit for repair at your expense or trying to tackle the problem yourself. Hope this helps.



Posted on Dec 26, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have an HTR-2 NAD remote. All the buttons except for the ON button are working. is there anyway to fix this?

Remote controls have an operating code which entered right will cause all functions to work. However if you were given the wrong remote or it doesn't have the right code, certain buttons will not work.

Check that the appliance it operates is the right model for the remote. Some remotes will allow reprograming others are fixed. If you can reprogram it will be just a question of finding out which code the amp uses and entering that. You can search online for the codes for your model.

It's not uncommon for the wrong remote to be sent out when first sold. Some people don't know it's wrong as the remote works nearly all the functions, just not all.

Aug 02, 2014 | NAD Amplifiers & Preamps

1 Answer

My NAD C372 integrated amp was working normally everyday. One day, on pushing in the "Power On" button, it did not light up. No response at all.

It could be anything from a blown fuse from a power surge to a shorted capacitor ijn the power supply. There are fuses in all amplifiers. Locate it and test it with an ohmmeter.

Dec 16, 2013 | NAD C372 Amplifier

1 Answer

How do I connect a Mirage Omni s-10 Sub Woofer and a Parasound Model 2100 Pre Amp to the NAD C372 Amplifier?

You DO realize the preamp is duplicating stuff in the Nad C372, right? This Preamps adds nothing but PHONO connectivity and control. That's why they're called "preamps".

Register and download the manual for free at

Model 2100 Picture and article:

Use the Sub Out pair on the Preamp (joined by an RCA Y-cable) for the Sub Input on the sub (duh):

Run RCA from the Preamp Main Out to the C372 Aux In to hear any sources attached to the preamp.

Or, if you don't NEED the preamp because you don't have a turntable,ditch the preamp and connect the sub using the speaker outputs on the NADS, according to the manual.

Mar 08, 2011 | NAD C372 Amplifier

2 Answers

Nad c372 problem with left speaker output

Hiya, did you try to swop the inputs as well and see if the problem swops. Try that as the input could also be low. If so try change the cable.

If not there try cleaning out the balance pot with switch cleaner (have to open to that and only you are comfortable).

If thats not there then likely an internal problem and will have to send it in.
Best of luck

Jul 14, 2009 | NAD C372 Amplifier

1 Answer

Eratic volume

ONe of the leads on the CD cable has a broken ground (thats why it hums loud)
The speaker that has only the tweeter working: The woofer is blown in the speakers.
Check also for good solid wire connections at both ends of your speaker cables

Mar 29, 2009 | NAD C372 Amplifier

1 Answer

Kenwood stereo control amplifier KC-206 doesn't work

I was able to use an universal remote control that I have, a Radio Shack Kameleon 6 in one remote control which I was able to program to run the audio portion of the Kenwood KC 206 control preamp. By adjust the remote sensor volume to max, I was able to get maximum volume out of the unit and drive the power section very nicely. Now I have to get up and manually turn the manual volume control for addition volume adjustment.

Hopefully Ken can find a remote that he can control the Kenwood control preamp the same way I did. Good luck here.

Dec 02, 2008 | Amplifiers & Preamps

1 Answer

Nad c372 prob

The unit is detecting a problem and shutting down in what is usually called "protect" mode. Look for bad connections on the board near the voltage regulators.


Sep 05, 2008 | NAD C372 Amplifier

1 Answer

Driving 2 sets of speakers with an external volume control on one set.

I think it's a bad idea to use a simple potentiomenter to do what you want to. You'd be better off using another amplifier with RCA cables in between them. It's not hard to find an old amp that you could use these days.

Sep 03, 2008 | NAD C372 Amplifier

1 Answer

Sound through one channel

Only the right channel had a sound,the left channel is mute, whatever adjustment you did and whatever balancing you done nothigs happen,even you interchange the speakers. The problem is in the power amp. The STK IC there is busted already, it's better to change it with a new one so the performance become normal again.

Jun 14, 2008 | NAD C372 Amplifier

Not finding what you are looking for?
NAD C372 Amplifier Logo

420 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Amplifiers & Preamps Experts


Level 3 Expert

4518 Answers

The Knight
The Knight

Level 3 Expert

66463 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

286 Answers

Are you a NAD Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides