Question about NAD C372 Amplifier

2 Answers

Nad c372 Remote Control

Just purchased a refurbished unit for my son and all works well except the remote does not work the volume. The lights flicker as if the signal is being received but volume will only change at the unit and not with remote. Would appreciate any assistance.
thanks
Robert

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

G'Day Bozobob
I have had the same problem which required a replacement motorised pot. I've also had a small cap fitted next to the heatsink on the positive rail regulated supply transistor go pop! Bad smell, protection circuitry operates.
Great amp, great design, poor quality assembly and QC. NAD need to lift their game!
Colin Walker
(30 years electronic repair industry)

Posted on Jan 06, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 36 Answers

Hello Robert,

If the standby/protection indicator on the amplifier blinks when you specifically press the volume +/- key, it obviously indicates that the unit is receiving the remote's command.
Try the following while pressing the volume key on the remote:
1.- Put your ear as close as possible to the volume control knob and listen for the sound
of a motor spinning, if you hear it, the volume control assembly needs repair. If you
hear no sound, proceed to next step.
2.- Gently rotate the volume control knob on the amplifier unit (it might be stuck and
needs a "little help").

If none of the above applies, the unit needs to be opened and troubleshooted. I've seen many instances where the volume control motor was not properly connected to the board or the assembly was put back incorrectly (specially in units that have been opened to be refurbished). I've heard NAD has a limited warranty for refurbished items. It might be wise for you to check before sending the unit for repair at your expense or trying to tackle the problem yourself. Hope this helps.

cancerags

I

Posted on Dec 26, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony rm ss251


As all other buttons works properly except Volum Dn, the problem is with the remote control itself. Clean the remote control and check. To clean it, you have to open the remote control. If it too doesn't help you, buy one original remote control from the authorized service center for Sony. No universal remote control will go properly with Sony TVs. If you wish to get some details, check the site linked here. Pull up older posts.

Dec 07, 2013 | Sony Televison & Video

1 Answer

My remoute control joust change the volume and anyother keys doesn't work.


The remote's volume keys are "punch-thru" keys, meaning they'll work for the TV for which the
remote is programmed no matter what mode the remote is in. It seems your remote is not
in "TV mode," but the punch-thru keys (volume UP/DOWN) are working.
The Solution: change the remote from "AUX mode" or "DVD Mode" back to "TV mode", by
pressing the "TV" button at the top of the remote.

Either that, or your remote keypad has failed with the exception of the Volume UP/DOWN keys....
Also, your batteries may be failing, since it takes a tiny amount of energy to light
the IR (infra-red) LEDs at the front of the remote to change the volume.
Is your remote a "multi-function" remote?
Could help more if you could post your Samsung remote model number, since
www.samsungparts.com lists 37 pages of TV remotes (at 10 models per page).

Jul 02, 2011 | Samsung TV Remote Control

1 Answer

How do I connect a Mirage Omni s-10 Sub Woofer and a Parasound Model 2100 Pre Amp to the NAD C372 Amplifier?


You DO realize the preamp is duplicating stuff in the Nad C372, right? This Preamps adds nothing but PHONO connectivity and control. That's why they're called "preamps".



Register and download the manual for free at retrevo.com

http://www.retrevo.com/support/NAD-C372-Amps-manual/id/8043dj592/t/2/

http://www.retrevo.com/support/Mirage-OMNI-S10-Subwoofers-manual/id/14438ag918/t/2/


Model 2100 Picture and article:

Use the Sub Out pair on the Preamp (joined by an RCA Y-cable) for the Sub Input on the sub (duh):

http://www.hometheaterhifi.com/preamplifiers/362-a-secrets-preamplifier-and-power-amplifier-review.html?showall=1

Run RCA from the Preamp Main Out to the C372 Aux In to hear any sources attached to the preamp.

Or, if you don't NEED the preamp because you don't have a turntable,ditch the preamp and connect the sub using the speaker outputs on the NADS, according to the manual.

Mar 08, 2011 | NAD C372 Amplifier

1 Answer

What does it mean when remote input not working on HARMAN KARDON AVR 445 RECEIVER


It means that you need to have both the remote control and the system checked. You may be able to check if the remote is functioning by aiming it at something else. I had a Sony Stereo which had a little LED lamp in the volume control knob which would flicker no matter which remote control I aimed at it....it was very handy for checking if any Remote suspected of being inoperative was transmitting anything !
You can buy remote control testers, that have an LED that flickers if the remote is transmitting. It wont tell you if the codes from the remote are correct.
You might also like to try checking local advertisements to see if someone has an identical unit to yours up for sale. You might get them to let you pop in and see if your remote is working...... for a beer or a small gift as a token of thanks.

Nov 29, 2010 | Harman Kardon AVR 120 Receiver

1 Answer

Lights flicker when turned off by remote


I had this same problem with a Hampton Bay fan with a remote light switch. I call the manufacturer of the of the switch and was told that the model switch I had would not work correctly with CFL bulbs. The problem is with the dimmer function. You either need to change the bulbs to incandescent, or change the remote receiver in the ceiling. Hampton Bay was kind enough to send me a new receiver that works with CFL. The CFL units are white, and the incandescent is black. Hope this helps you.

Feb 26, 2009 | Universal Remote Control Hampton Bay...

2 Answers

Kenwood stereo control amplifier KC-206 doesn't work


I was able to use an universal remote control that I have, a Radio Shack Kameleon 6 in one remote control which I was able to program to run the audio portion of the Kenwood KC 206 control preamp. By adjust the remote sensor volume to max, I was able to get maximum volume out of the unit and drive the power section very nicely. Now I have to get up and manually turn the manual volume control for addition volume adjustment.

Hopefully Ken can find a remote that he can control the Kenwood control preamp the same way I did. Good luck here.

Dec 02, 2008 | Audio Players & Recorders

1 Answer

Nad c372 prob


The unit is detecting a problem and shutting down in what is usually called "protect" mode. Look for bad connections on the board near the voltage regulators.

Dan

Sep 05, 2008 | NAD C372 Amplifier

1 Answer

Intermittend no audio from digital inputs, flicker video monitor out, volume goes up but not down


Since the problem appears only after the unit has been run for a while, I'd be looking for any part close to a heat source. The odd behavior suggests that there is noise on the data lines for the volume control chip and the digital processing areas. Look for a bad 5V regulator +/or bad caps on the 5V line. Also check for poor solder connections in the power supply and final output stages.
Keep us posted.
Dan

May 13, 2008 | NAD T762 Receiver

Not finding what you are looking for?
NAD C372 Amplifier Logo

502 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5554 Answers

The Knight
The Knight

Level 3 Expert

75846 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...