Question about Honeywell HUT-102 1.2 Gallon Humidifier

2 Answers

No mist When I turn it on now there is no mist. When it stopped I replaced the cartridge

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers
Re: No mist

The demineralzation cartaridge seems to be the issue. Remove it and see it the misting starts. If it does put a hole in the center cylinderical support of the demineralzation cartaridge, the one that fits over the white positioning post that is built into the base of the humidifier. This will allow the cartirdge to sink to the bottom and not interfer with the water tank plunger opening up and filling the base.I opened the hole completly but I think a smaller hole will do.

Posted on Mar 16, 2008

  • Level 1:

    An expert who has achieved level 1.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers
Re: No mist - Honeywell HUT-102 1.2 Gallon Humidifier Humidifiers

Return it.

Posted on Jan 26, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Humidifier will produce mist for a min then stop If you look you can see it producing mist within but it will not come out of the top Walgreens cool mist ultrasonic humidifier

I have had times where my Crane humidifier won't produce mist if I haven't turned it on for several days (4+) or more. The water that sits in the reservoir may develop a film on the ultrasonic element which inhibits the creation of the mist to come out the top of your humidifier. I would lift off the tank and empty the reservoir. Then VERY GENTLY with a piece of paper towel, wipe the ultrasonic element (looks like a disk the size of a quarter at the bottom of the reservoir) to clean off any film. Then replace the tank and let the reservoir fill up the tank and try it again.

If your humidifier runs properly for a minute and then makes a whirring noise and goes silent (like the motor stopping), then it's a motor problem. The humidifier motor may have gone out of alignment due to bumping or rough handling of the humidifier when cleaning or emptying it. If that is the case, you will have to empty the humidifier reservoir, unscrew the base, and find the screws holding down the motor and check for misalignment. Loosen them a little and put it back together and try again.

Best of luck

Feb 13, 2014 | Humidifiers

1 Answer

Humidifier not working

Ensure there is water in the tank.
  • This may be caused by mineral deposits in the water channels. Try the following: Clean the water tank, base and vapor nozzel with a damp cloth to remove any build up in the water channel.
  • When was the last time the cartridge was changed. (If it’s been over 3 months, this could be the reason why the unit is not working properly.)
  • Unscrew the demineralization cartridge and run the unit, if it starts to mist then you need a new cartridge. (insert cartridge link here)
  • The screw cap for the water tank, onto which one first screws in the demineralization cartridge, has a small rubber gasket. make sure that gasket is not too far down against the outer screw cap. If it is the spring loaded button would not work properly to let the water descend into the base tank .
    The solution: push up on that small rubber gasket so that it is as far up and away from the screw cap as it can be without falling off, and voila! you get mist!!
  • If you have changed the filter recently then take out the cartridge and run the unit without the cartridge for about 15 to 20 minutes.

May 18, 2009 | Venta Airwasher VS 207 3.7 Gallon...

1 Answer

No mist, but i can see a water droplet fountain on the surface

if it's a cool mist unit it will not produce any mist. now if it's a warm mist unit it should. that's normal. it is possible to replace the transducer if it is damage but you are going to have some leakage from it. but the only way to get the transducer mainly is from the manufacturer

Mar 12, 2009 | Sunbeam Ultrasonic Humidifier

1 Answer

No mist

i would try cleaning the coils for the heat portion. if they are to scally that could be one reason why it's not making any mist. but if it looks pretty clean or if you have cleaned it and it's still not making any mist then it's something internal. now if your under warranty still that's a good thing. you can always call the manufacturer and they can replace theunit for you under warranty . if you have any other questions please let me know.

Feb 26, 2009 | Holmes Products HM500-UC 1 Gallon...

2 Answers

No mist!

unfortunately on a cool mist unit the mist shouldn't show up. on most units that's what it does. the warm mist units show the mist.. the best way to tell is if you put your hand over the spout that the mist is suppose to come out of for about 2 minutes and you pull it away and it feel clammy then it's working. if your hand is still dry please let me know and i'll see what else i can do for you.

Feb 26, 2009 | Holmes Products HM500-UC 1 Gallon...

5 Answers

Air-o-swiss 7135 humidifier not misting

Ours has done the same thing after only 2 weeks. From article research, it appears that this occurs to everyone after cleaning it with the EZ Cal that is recommended. From looking at our unit and figuring out how it works, it appears as though the Ultrasonic Vibration membrane has stopped working. This particular piece is responsible for vibrating the water and making water mist particles which are blown out with the air. We will be calling the manufacturer on Monday to register a complaint and request a replacement unit.

Nov 23, 2008 | Air-O-Swiss 7133 Humidifier

2 Answers

Humidifier makes a huge noise and no mist

According to the Crane's Troubleshooting section:
The power light is green but there is no mist being emitted:
- Check that there is water in the tank.
- Check for possible lime deposits on the water level sensor or the nebulizer.
- Make sure that nothing blocks the vapor output slots.
- Check that the fan vent on bottom of humidifier is not blocked.
- Empty the humidifier and rinse the water basin with cool tap water and allow to dry for 15 to 30 min.

This next part may or may not be relevant.
Humidifier power light is staying red and not turning green. Or, Humidifier is working then stops:
- Ensure that water level sensor is assembled properly.
- Clean water float.
- Call service center and request replacement water float.

Barring that, here is the service center contact info:
Dart Warehouse Corporation
Tel: 1-888-599-0952 (Business hours Mon-Fri 9:00 am - 4:00 pm Ct)
1835 Ferry Road
Naperville, Illinois 60563

Jan 28, 2008 | Crane Cow Humidifier

1 Answer

Noisy ultrasonic humidifire

The grey circle (diaphram) needs replacing. Try Maplin electronics.

Mar 31, 2007 | Swiss Air-O- 7135 Warm Mist Antimicrobial...

1 Answer

The humidifier doesn't make enough vapor

Soak it with vinegar for several hours then use a soft nylon bristled brush to scrape off the minerlized crust and rinse. You probably need to replace the silver stick & mineralization cartridge more often.

Jan 04, 2007 | Air-O-Swiss 7133 Humidifier

Not finding what you are looking for?
Honeywell HUT-102 1.2 Gallon Humidifier Logo

Related Topics:

394 people viewed this question

Ask a Question

Usually answered in minutes!

Top Honeywell Humidifiers Experts


Level 3 Expert

1033 Answers


Level 2 Expert

116 Answers

Barrett Palumbo
Barrett Palumbo

Level 2 Expert

1772 Answers

Are you a Honeywell Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides