Question about Technics SUV500 2-Channel Amplifier

1 Answer

No sound i just got an "AV control stereo reciever (SA-EX300)" and when i turn up the volume there is no sound on the speakers (and yes everything is plugged in right ) no matter what i do. even when it is on the right setting there is still no sound. what do i do

Posted by on

  • joyman796 Aug 06, 2008

    where is the fuse on these [ SU-G70 ] its an older unit



1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

What are you tring to amplify? try using a different input.
also try checking all the fuses! llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll

Posted on Dec 24, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

My partner's AV control stereo receiver sa / GX 650 has presented complications can not crank up the volume without alert saying overload or some s***?

turn it off and take a look at each speaker and wires something is wrong even a bad speaker may show this in your amp so before you burn it test all of them

Sep 16, 2015 | Audio Players & Recorders

1 Answer

My technics av control stereo receiver sa-g76 keeps shutting off(overload). can you please advise on how to avoid this situation?

Is there anything on top of the av receiver? Try and run the reciever so that it has enough cooling. B) Allthough overload, there is a possibillity it is causes by speakercables who are shortcircuiting once in a while. Usually somewhere at the back of the reciever or speakers.

Apr 24, 2014 | Audio Players & Recorders

1 Answer

The volume gets noisy, cracking sounds and fades out

Your volume control is dirty. Apply some deoxit or wd40 directly onto the module.

Mar 22, 2014 | Panasonic Technics SA-G76 AV Control...

1 Answer

Can i hook up my technics sa-g76 to my tv

yes, using the the rca outs of your tv, and they will connect to an input on your reciever that may already be marked for a tv, or cable box

Jul 28, 2013 | Panasonic Technics SA-G76 AV Control...

2 Answers

My Technics AV Control Receiver SA AX530 is in overload

An amplifier should never be turn on without speakers, it will overload internally.
make sure speakers work and try again.

Dec 04, 2009 | Technics SA-AX530 Receiver

1 Answer

How do you hook up the audio from Visio flat panel to SA EX 300

Wild guess. Is the TV volume turned down and its output set to variable instead of fixed?

May 17, 2009 | Technics SA-EX300 Receiver

2 Answers

Technics SA-DA10 jumps into overload after 10 minutes

Have you tried connecting speakers? What was the result?

Yes, when you turn the volume up on these amps (or when the output gets past a certain level) the cooling fan should automatically come on.

Oct 14, 2008 | Technics SA-DA10 Receiver

1 Answer

Over Load light turns on and then we have no sound

please disconnect each speaker one by one and test it until you find the bad one-start with cable change and then the speaker itself.

Jul 04, 2008 | Technics Audio Players & Recorders

1 Answer

Probleme with my home theatre...technics..av control stereo receiver- model SA-G76

just an idea maybe check the position of speaker select switch some models have
a or b
or a+b

Apr 24, 2008 | Audio Players & Recorders

2 Answers

No Output Subwoofer

hi, ya , some recievers have its setup where u have to enable the sub out,, check the menu carefully, also the player menu if the sub is on or off, let me know..

Jan 10, 2008 | Sony SA-W305 Subwoofer

Not finding what you are looking for?
Technics SUV500 2-Channel Amplifier Logo

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts


Level 3 Expert

5318 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Ben Armstrong

Level 2 Expert

357 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides