Question about Amplifiers & Preamps

1 Answer

Amp i got hold of a technics sh-av500 procesor to run with my existing amp but i am not sure how to connect it! could you please help\; Regards Bob

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 682 Answers
Re: amp

Take audio right and left out from your processor and connect it to aux in or line in in your amplifier.

Posted on Apr 24, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Technics su-g75 amp goes to loud static after a few minutes

Hi Aawpharmd,

system control error.
please go for repair shop.

Jan 13, 2014 | Technics SU-G75 Amplifier

2 Answers

Connect a denon amplifier pm-510ae to a technics equaliser sh-8058

Hi Just to let you know what ever you put between the amp and speaker you will degrade the sound quality. Even with the best machines you will muddy the sound. If you read HiFI magizine they will tell you this is true.
But if you don't care about the quality of sound than go ahead hook an equalizer on it. Hope that helps you.

Mar 27, 2012 | Denon Amplifiers & Preamps

1 Answer

Is there volume adjustments on a technics amp model se-tx100?

Technics SE-TX100 is a power amplifier and has no volume controls on it. Uoy can control the volume from the preamplifier tha will give the signal at SE-TX100.

In case of a problem or clarification, don't hesitate to post me a reply.
If you are satisfied, rate my solution with the "thumbs".

Thanks and regards
Please kindly rate this solution
direct FixYa link: In case of a problem or clarification, don't hesitate to post me a reply.
If you are satisfied, rate my solution with the "thumbs".

Thanks and regards
Please kindly rate this solution
direct FixYa link:

May 10, 2010 | Amplifiers & Preamps

2 Answers

Manuals For Technics

The manuals for these are on paper not electronic files. Is there are particular problem you are trying to solve?


Jan 06, 2010 | Technics Amplifiers & Preamps

2 Answers

Technics su-v45a

Hi ferrariman

For sure, even though a manual is a bit hard to find for free, we may be able to help you solve the problem. I have worked on alot of technics amps over the years. What is happening to the amp?


May 14, 2008 | Amplifiers & Preamps

2 Answers

Battery for pyramid 105 amp

There are many many possible batteries you can use for this application, from lead acid to Lithium polymer. You will need to determine what type of power connector that will fit your unit's jack then make sure the polarity is correct. You can then wire connector
accordingly to battery you select. Make sure battery exceeds current requirements but voltage. If unit has internal charger, make sure the battery you choose is compatible or use dedicated charger

Apr 27, 2008 | Amplifiers & Preamps

1 Answer

Lower volume on right side!

I have't seen this porblem, have you tried changing the source place's R with L and see if the sound have change side. If it did then it's your input signal.
I would first check the board for bad solder connection, but it sound like you have a cpu problem or the main ic's procesor. This can be checked with a scope with the ouput of the pre amp to see if the level or the same, with a mono input signal only. You may also have a section of the ouput stage not working, the pre amp , the stage before the main amp out will tell you all by looking at the signal level's.

II know it's not easy, but you will at one point need a scope, without it you will notice you're just going at it blinfowled. When purchasing a scope, put the money it it, a good scope will cost a min of $2k. I'm usind a teck scope and love it, I've also used a leader and find it just the same and sometine better for under $1k.

I hope this help

What About Bob

Feb 11, 2008 | Amplifiers & Preamps

1 Answer

Amplifier Problem

Ok, I've seen this with panasonic, what brand do you have, to look for a problem unplug the amp turn the amp downword, open the butom cover, at were the back panel is, look for cold solder joint, if everything seem's ok then troubleshoot the ouput stage.

You will need the schematic for this, or go on goolges with the output ic # this will help to tell you what it is,


Bob the builder.

Feb 02, 2008 | Amplifiers & Preamps

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts


Level 3 Expert

4518 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

66444 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides