Question about AudioBahn A2150HCT Car Audio Amplifier

1 Answer

All 3 fuses blown on amp worked fine for years

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 108 Answers

If all your fuses are blowing, you are crossing over or arching somewhere. Check you wires connecting to the amp and make sure everything is tight and that no loose strands are touching other wires around it. Hopefully the amp isn't just coroding out under the outer shell causing an internal short.

Posted on Oct 08, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ren 550 s amp does not have blown fuse but is not working


Chances are that you have internal problems with your amp, they have a 1 year warranty so I would check to see if you can get an RMA to get it fixed or replaced. They still sell this model, so chances are good you may be covered. It seems like these are mostly sold in Europe, Onlinecarstereo.com sells them as an authorized seller. To get the 1 year warranty you probably will need to have bought this from an authorized dealer. But try anyway.
http://www.renegadecaraudio.com/renegade_rens_amps.htm

Apr 02, 2013 | Renegade REN 550 S - 550W 2-Channel Car...

1 Answer

JL Amp isn't powering subs and speakers


just go through ur connections man one by one ull find the prob soon.....check teminals on battery...power line to amp ....all fuses within prob area and obviously make sure u have a good ground.....really impotant.....ground is the most neglected thing people do from my experience bein a audio tech oh and if that isnt it check ur subs....stick a 9v batt on the back pos n neg of each sub n c if they pop in r out this will determine if ur subz r blown

May 14, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Well my 5500 amp has evidently stoppe functioning.


What I would do is look around inside and see if anything is burnt or broken, pay close attention to the heat sink area.
With neither channel working you have something that's common to both channels that is causing the trouble.
You should be able to see any fuse by looking inside, they might be covered up, but should be easy to get to.

Nov 25, 2009 | Adcom GFA-5500 2-Channel Amplifier

1 Answer

Kenmore Spacemaker Fuse Blown


its either a 10-15-or20 ceramic fuse and its marked on the side of the fuse or take it to the hardware store they have this type of special fuse.and they can locate the rating for you

Oct 04, 2009 | GE Spacemaker JVM1640SJ Microwave Oven

1 Answer

Subwoofer pushing out problem


it sounds like one channel in your amp had shorted and letting dc go to the speaker...a speaker is an electromagnet and requires ac to make it pulse..the amp has a blown channel and would have to be repaired and a factory service center...there is no quick fix..

May 27, 2009 | Lightning Audio B1.10.4 Car Subwoofer

1 Answer

Kenwood hac 9152d, was working fine now doesnt output any sound


Check the fuse on the amp.

My girlfriend had the same thing, light was on, no sound whatsoever. The fuse on the amp had blown, but I'm guessing some current must have made it through to just put the light on. Make sure you have a 40 amp fuse in it, that's what it needs.

Good luck

Dec 10, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

BLOWN?


Could be a number of reasons, But there should be a fuse on the amp, it may have just blown the fuse. If the fuse is fine then it may just be at end of life. Most amps that I have dealt with have a lifespan of about 3-5 yrs, maybe 7 if you are lucky. Let's just check the fuse, or just replace the fuse and see how we go from there.

Jul 03, 2008 | Phoenix Gold QX90.2 Car Audio Amplifier

Not finding what you are looking for?
AudioBahn A2150HCT Car Audio Amplifier Logo

Related Topics:

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

xxxxxx xxx

Level 3 Expert

4874 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8560 Answers

Are you an AudioBahn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...