Question about Rainbow E series Canister Wet/Dry Vacuum

2 Answers

It sounds fine but it is sucking very little

I took the bottom apart and also rinsed out the filter
still the same problem

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers
Re: it sounds fine but it is sucking very little

If the suction at the port that the hose hooks into has low suction, then most likely you have a problem with the motor. Some of these Rainbow motors sound ok running, but are running at a slower speed, thus reducing the suction and replacing the motor is the solution.

Posted on Jan 15, 2008

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers
Re: it sounds fine but it is sucking very little

Could also be the bearings. If you leave water in the pan after using the vac. the hot bearings attract moisture and then rust. Replacing bearings is a heck of alot cheaper ($3.00) than a new motor ($200+)

Posted on Jan 18, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

My Dyson turns on and is not sucking. It makes a

I have the dyson dc 27. On the bottom left back side of mine there is a circle, and ball inside of it. I turned it on and pushed the ball and it started working again. Sometimes it doesn't cover the whole and stops sucking air through it.

May 18, 2010 | Dyson DC07i Bagless Upright Vacuum

1 Answer

My dyson vacuum is running really rough, I took

clean the filter, clean the upper part of the canister (unclog the holes) check for clogs.

if you vacuumed up fine Powdery materials or something damp/wet.. these are no no's and they involve repair.

Mar 28, 2010 | Vacuums

1 Answer

Constsntly applys water even when shut off/ not running took apart handle I believe trigger is broken

Hi there SmartAlec from here. The trigger definately could be broken but before you take it to a repairer i would really thouroughly clean any little foam filters and rubber seals you can find. I do a lot of work on the Vax range of machines (very similar) and 90% of the time it is the filters and/or the seals once they get a build up of shampoo on them they no longer seal properly but once removed and rinsed thoroughly they work again. Rinsing the machine through with clean water after a shampoo job will help this not happen again.
Hope this helps
Happy Vacuuming! :)

Aug 25, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Hoover U6476-910 - Very little suction from the bottom

If you haven't already, remove the beater bar. This is accomplished by unplugging the vacuum and turning it beater bar up. Remove the clips or screws that hold the plate on the beater bar and set aside. The beater bar sits in sockets, so carefully remove the bar, noting the correct position of the sockets. This will make reassembly much easier. Slip the beater bar out of the drive belt. Now, inspect the suction cavity that the beater bar would discharge into. Usually, things clog up here as there is a flex hose that catches things, creating a pluggage.
Hope this helps, --W/D--

Jul 18, 2009 | Hoover U6476-910 WindTunnel Upright Vacuum...

2 Answers

Bissel proheat is not sucking up water

There is a oblong black seal that sits where the tank lip and the clear noozle window come together, is it there. Also make sure the filter in the tank lid is clean.

Jul 09, 2008 | Bissell 1699 ProHeat Clear View Upright...

2 Answers

Bissel model 6579-3 powerforce

You can download the user manual as a pdf file at Just type the model number in the search box.

Apr 13, 2008 | Bissell 6594 PowerForce Bagless Upright...

2 Answers

Is barely sucking up anything

I dont fix vacumes but I would say if you took the vacume apart you will find that it has a blockage. Clean it out and it should work fine.

Jul 11, 2007 | Kirby Ultimate G Bagged Upright Vacuum

Not finding what you are looking for?
Rainbow E series Canister Wet/Dry Vacuum Logo

Related Topics:

280 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rainbow Vacuums Experts

Roger Potts

Level 3 Expert

694 Answers

Jim Parker
Jim Parker

Level 3 Expert

1040 Answers


Level 3 Expert

18258 Answers

Are you a Rainbow Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides