Question about Car Audio & Video

1 Answer

My calibra amp lit the red power led (to show protection )now my subwoofer won't play

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 117 Answers

Disconnect sub woofer , amp may reset and light will be steady , if so replace wireing to sub and sub its bad

Posted on Nov 25, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have 2 15 inch kicker l7s duel 2 ohm in a built to specs slot port i need an amp that will power them what should i get


this guy know jl amps are ONLY 1.5 - 4 ohm stable? won`t 1 ohm send amp into protection with thermal indicator lit up like the northern star?

Sep 26, 2012 | Kicker Solo-Baric L7 S15L72 Car Subwoofer

1 Answer

60SDX88B. No video, No sound. DP06 Protection


not a solution but i have a 50gx30b doing something similar, no picture no sound, 3 green leds are lit up on the main board and then one red led lit up also on main board, front panel red led stays on for about 30 -50 seconds and then it all shuts off, I then have to unplug and replug to get the same results.

Mar 03, 2010 | Hitachi 60SDX88B 60" Rear Projection...

1 Answer

Kicker 250.2 amp, I have green power led, but the red led on top of the unit does not come on, nor does the red protection led, hear a click out of the subs on occation but nothing else, looked inside and...


Sometimes clicking, or popping sounds from subs are caused by over excursion of the subwoofer, wich can be caused by ultra low frequency, or going below the tuned frequency of your enclosure.

Aug 12, 2009 | Car Audio & Video

1 Answer

Amplifier Problem


never ask geeksquad about amps lol check your ground wire connection and push on sub do you feel scratching if so its blown sub also never turn an amp up all the way it starts pushin dc voltage witch a 200 watt amp can blow a 800 watt sub dc voltage is not good for subs also up all the way can burn out the internal battery in the amp lets hope thats not it just make sure ground is good protection light means that the amp has power but a connection is not bien made sum where to complete the circut

Apr 12, 2009 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

1 Answer

New Dual XIA3145 2/1 LED glows red, guide claims speaker problem


look at these and only these... power or ground...either your power wire has grounded out somewhere (ud be surprised) or youdont have a good enough ground....i would check the ground first....hopefully this helps

Jan 27, 2009 | Dual (DBXPA6100) Car Audio Amplifier

1 Answer

Thumping speakers - no power light is on - wired correctly


the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.

Nov 02, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Hi i am matt


If the protection LED lights only after the remote voltage is applied (head unit is switched on), the amplifier likely has shorted output transistors. If the protection LED remains lit without remote voltage applied, the amp may have other problems.

Does the protection LED light with no speaker wires connected to the amp and no RCAs plugged into the amp?

Jun 22, 2008 | Car Audio & Video

3 Answers

My amp is on but the protection light stay's on!!


Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If the protect light remains on, the amp likely has blown output transistors.

Feb 28, 2008 | AudioBahn A2801Q Car Audio Amplifier

1 Answer

Power and led on but yet no sound


red means protect, check speakers first then disconnect all power,try again in 20 min

Aug 22, 2007 | Visonik V900XD Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

305 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...