Question about Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

1 Answer

Will not turn on, used the hose/switch from a new one, same thing

I took it in to the store and tried it with the hose from a new one, same thing. My hose and switch work on a new canister. I used a multimeter to check the cord, it's fine. I checked the internal fuse, also fine. There is no power to the head or the internal motor. The only thing that makes any sense is that the little printed circuit board inside is cooked.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 430 Answers

If the PCB is cooked, you will often see a burn on it somewhere, but it may be internal in the relay.
Double check the cord and rewind leads in and out for continuity. Rewinds will break internally at the end of the spool. If there is no power to the head itself, your problem lies either at the 3 contacts where the hose inserts in front of the bag chamber, or behind the motor, pointing again to the circuit board .
There is a small relay on the PCB of some Sears multi switched models. That would be suspect location # based on your decription. The parts are generally vavailable thu Sears , but if you can get their part # you can also try to search FSP parts online for a match.
IF the relay has a removable cap, you can inspect it and if burned , with a bit of browsing online often locate a replacement relay to solder onto the board
Sears sometimes re tags the part # internally but not always. Best of luck. Good effort on your part

Posted on Oct 07, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Kenmore vacuum model #116.27515 will not turn on.


When you took the hose apart were there wires that you had to take apart as well. If those wires were inside the hose then you need a new hose. I think they are about one hundred dollars or go to second hand store and get a used one.if you can.

Jan 28, 2016 | Kenmore Vacuums

2 Answers

I have Kirby sentria that shuts off while using the rug attachment and won't start until I change to the hose attachment. I have had it in Kirby repair store 5 times, cord replaced. Took it back t


power switch faulty, slow speed terminal inside switch is burnt,hence

intermittent fault, hose uses second speed different lever inside switch

Oct 12, 2012 | Kirby Vacuums

1 Answer

How do I get an adapter for the faucet for my Bissell 1631 Power Steamer. The brass fitting on the end of the water hose does not fit the faucet. I need one that I can add to the current brass fitting so...


I went to OSH hardware. I unscrewed and took the portion of the faucet- that the hose from the steam cleaner was to fit into and I took the hose right into the store. I just bought my unit at the thrift store. Works great. I love it!

Jun 27, 2011 | Bissell 1631 PowerSteamer ProHeat Canister...

1 Answer

Carpet beater not turning on, rest of vacuum ok, reset button down


Is the PN motor not working, or just the brush not spinning. If it's the brush, a new belt is needed.
If the motor isn't working, it could be due to several things. Follow the trouble shooting steps below.
1. Check all connections from hose handle to PN for discoloration. Any parts showing discoloration or melted plastic need to be replaced.
2. Attach PN directly to the hose. If the motor works, there's a problem in the wand wiring/connections.
3. Attach the Sidekick directly to the hose. If it works, but the full sized PN doesn't, there's a problem in the PN. Problems could include: wiring, connections, bad motor, bad switch.
4. If neither Sidekick nor PN work, the problem is likely in the hose. Potential problems include: bad wiring, connections, or bad switch.
5. You can try another hose known to be good to test the PN. If it still doesn't work, the problem could be in the canister itself.

I strongly recommend taking it to an authorized Aerus Electrolux store for diagnosis and repair if needed.

http://www.aerushome.com/storelocator/

Apr 09, 2011 | Electrolux Epic 6500 Vacuum

1 Answer

I just need the part number for my Guardian Electrolux model C134A i ran over the Hose and that was the part that broke. i need to compare prices so i can determine if it is cost effictive to change the...


The part number for the hose is 47086.
The best thing to do is contact the nearest Aerus Electrolux dealer.
If it's just the switch or handle that broke, it will be more cost effective to have that replaced. If I remember right, the hose costs close to $200 new. A new switch may cost up to $20, but probably quite a bit less.
The nearest Aerus store can be located using the below link.

http://www.aerushome.com/storelocator/

Mar 29, 2011 | Electrolux Guardian Bagged Canister Vacuum

2 Answers

We have an electrolux central vac. The power head won't turn on. It has a 3 way switch on the handle. When to the left it is just air for the floor. center is off and to the right is the power head. ...


I assume you did press the reset switch on the power nozzle. If so, there are a number of things that could cause this. To rule out the hose and power switch, connect the Sidekick (if you have one) to the handle. Turn vacuum on. If the sidekick runs, the problem will be in the wands or power nozzle. Try connecting the power nozzle directly to the hose. If it runs, the problem is the wiring connections in the wands, or from the lower wand to the power nozzle. Check all connections for discoloring and broken or cracked wand fittings.
The wiring in the elbow of the PN is a fairly common problem, especially with certain models. A piece inside breaks, resulting in the wire connection to not make contact. No contact means the PN motor won't run. And there's always the possibility that the PN motor is bad.
If the Sidekick doesn't run when connected directly to the hose, the switch could be bad, the wiring in the hose could have broken, which is another common problem in older hoses, or the ECV board in the vacuum could be bad.
If the problem hasn't been resolved at this point, it's best to take the entire machine to the Aerus Electrolux store near you for a free diagnosis.

http://www.aerushome.com/storelocator/

Jan 07, 2011 | Electrolux Central Vacuum

1 Answer

Electrolux Epic 6500 SR ...no power to power nozzle. I think it is the switch in the handle because if I use my friend's hose/handle (same model), my power nozzle works fine when I turn on the switch. If...


That's about the best one to narrow down a problem, however, there could also be a break in your hose wiring. Switches, hoses, and hose handle assemblies are all available at your local Aerus Electrolux store. Simply take your entire machine in so they can check it to be sure what the problem is.
The nearest store can be found using the below site. Simply type in your zip code and press enter.
http://www.aerushome.com/storelocator/

Oct 07, 2010 | Vacuums

1 Answer

Took out the hose from the handle and now it's not


The dyson should work with or with out the hose wand (handle), so I think its more like the mains lead or the switch is faulty, do you know how to do a continuity test, with a tester? if not you may have to seek an approved engineer to test it.
Does it switch on when its not been used for along time? if it does - could be a blockage

Sep 29, 2009 | Dyson DC07 Bagless Upright Cyclonic Vacuum

2 Answers

I have a 3 year old NuTone CV 353W central vac system and recently the switch on the hose handle does not turn the system on from any outlet in the house. I have to plug the hose into the outlet and then...


http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=567634
Generic problem for all Vacuums
I have a 3 year
posted by patfitz on May 03, 2008
I have a 3 year old NuTone CV 353W central vac system and recently the switch on the hose handle does not turn the system on from any outlet in the house. I have to plug the hose into the outlet and then turn the unit on from the switch on the canister. Any help would be greatly appreciated. Thanks

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. There are a couple of things that come to mind, 1st. you may have a bad switch in the hose and in most cases that can be repaired – if not you would have to purchase a new vacuum hose. 2nd. You may have a bad inlet valve in your hose and most of them are low volt of which would only cost less than $10.00 and can be replaced yourself unless you have what they call a SuperValve of which has 2 low volt wires and then it is wired to your home electricity and that should be replaced by an licensed electrician. It is a low volt and high volt inlet.

#3. the last thing you may check id that you may have a bad relay in the canister itself. Because you should be able to turn on the Central Vac with the switch on the hose and everything should work just fine . feel free to contact your local vacuum cleaner dealer in your area of call the Nutone Factory cust serv line for further assistance. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://nutone.com/ Customer Service
Nutone Inc.
9825 Kenwood Road
Suite #301
Cincinnati, OH 45242
Customer Service 1-888-336-3948
Technical Support 1-888-336-6151
Thanks, Don the Vac Man
Go Ahead. Use Us.

May 03, 2008 | Broan-NuTone CV450 Central Bagged Central...

2 Answers

Stair and upholstery attachment


After tearing things down and inspecting the handle switch, etc., I found that my problem was detergent. It sets idle for a while or doesn't get used very much and the detergent dries and actually clogs the inside of the hose. I cleared it by fully extending the hose, pressing the button and allowing the clog to clear itself. The built in heater helped out a lot once the flow started again. I used a can of compressed air to provide a little blow back to get things moving but not too much or the pump would be damaged. Remove the tool and hold the nozzle into an empty cup while depressing the trigger. A warm vinegar solution clears things out nicely. It's kinda hard for this piece go defective but easy to overlook when wrapping up and storing the unit. Remember, clean water rinse with 1/4 cup white vinegar. There, I fixed it and wasn't even broke!

Apr 08, 2008 | Hoover F5881-900 Vacuum

Not finding what you are looking for?
Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum Logo

134 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...