Question about Aprilaire 1700 Dehumidifier

Open Question

Aprilaire 1700 test cycle unit will go on and go thru its cycle and shut off.after that i try to turn it on 1 thru 7 and unit won't come on,green light behind access panel main board is flashing

Posted by on

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
localwonder
  • 6784 Answers

SOURCE: LG Washer wont start, no power

Make sure there's power getting to the washer. Check for a tripped circuit breaker or a blown fuse. Check the wall socket for power. Sometimes the power cord disconnects at the washer, if this is the case, the wiring must be repaired or replaced.

Posted on Jun 21, 2009

Ad
  • 13 Answers

SOURCE: Dehumidifier will not run.

The power board or control board may not be functioning properly based on the information you provided. In order to best assist you I would recommend you contacting your HVAC installer or contact Aprilaire directly for further insight on this particular issue.

Posted on Apr 23, 2010

heatman101
  • 43501 Answers

SOURCE: Dehumidifier will not run.

Hi,
Have they messed with the wires to the humidistat??
Either they are unhooked or they shorted out the wires and burnt out the transformer...

heatman101

Posted on May 18, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My AprilAire 600 humidifier drips water from the bottom of the unit. I changed the filter and cleaned the parts. Could it be the hose running to the condensation pump that might be the problem?


its going to drip when it is off,it has built up humidity and has nowhere to go,leave it running and let it cycle by itself or cause damage to the system

Jun 24, 2015 | Aprilaire 600m Whole-house Humidifier With...

1 Answer

My Aprilaire 560 humidifer is not getting any water to it I have 2 furnances and 2 Aprilaires and neither get water.


I would check the shut off valve from the supply line, it is probably plugged or off. If on then I would guess it is one of the tube piercing valve types which will fail. Be sure the supply line has pressure.

Mar 21, 2014 | Aprilaire 4277 560 Series Humidifier Water...

1 Answer

Water filter on aprilaire model 700 light keeps flashing


You need to reset by turning thermostat dial all the way to test reset. It will reset itself, then go back to your setting.

Mar 05, 2014 | Aprilaire 700 120V Power Fan Humidifier...

1 Answer

I have a customer who has a model 1700 dehumidifier Connected to ductwork with a/c only air handler. Not Sure why this is needed or correct way to wire. Also There is no remote humidifier & unit is...


I have to agree with you. I don't see the need for the dehumidifier either. As the AC unit alone, does have some dehumidifying capability.

Your customer would be better served using an independent Low Temp dehumidifier in the basement. If that's the area they are trying to dehumidify because of dampness in the basement.. It certainly would be less costly to operate. But, any unit that is not a Low Temp unit won't work well in a basement.

I hope this helps and good luck convincing your customer of this.

Thanks for choosing FixYa.

Aug 24, 2011 | Aprilaire 1700 Dehumidifier

1 Answer

The dehumidifier shut off automatically but will not come back on. Model M7DH45B2A


If the unit shut off automatically, because it had reached the humidity extraction level you had it set on. It won't turn back ON again, until the humidity level rises above the setting you have it on. Lowering the humidity extraction level to 32 -35%, should make it start up again and cycle like it should. If your unit does not have an LED Screen, set the manual control on Maximum.Be sure the bucket is not full and the air intake filter is clean.

Hope this helped you to troubleshoot and solve the problem.

Jun 28, 2011 | Fedders A7DH45B2A Dehumidifier

1 Answer

I have an Aprilaire 1750 installed inline with my upstairs central air system in the attic. The unit's ducting appears to be installed as indicated in the installation manual, but when the unit is running...


Your dehumidifier is likely working correctly. When operating and removing moisture, a dehumidifier will supply warm/hot air to your house. Your dehumidifier moves less air than your A/C, so your supply ductwork in your house is oversized for the dehumidifier. This will lead to uneven feeding of your supply duct branches with just the dehumidifier operating.

Since your dehumidifier is installed in the attic, make sure that the ducting connected to it is well insulated. Also make sure that your dehumidifier cabinet is insulated. These actions will help prevent heat gain from the hot air in your attic.

Is your dehumidifier bringing in fresh air from outside? If the outside air is hot and humid, the dehumidifier will supply warmer air to your home.

Some people run their A/C fans continuously to help with the air distribution, but this is a bad idea since it increases energy usage considerably.

DryDog

Aug 06, 2010 | Aprilaire 1700 Dehumidifier

1 Answer

Dehumidifier will not run.


Hi,
Have they messed with the wires to the humidistat??
Either they are unhooked or they shorted out the wires and burnt out the transformer...

heatman101

May 14, 2010 | Aprilaire 1700 Dehumidifier

1 Answer

Dehumidifier will not run.


The power board or control board may not be functioning properly based on the information you provided. In order to best assist you I would recommend you contacting your HVAC installer or contact Aprilaire directly for further insight on this particular issue.

Mar 25, 2010 | Aprilaire 1700 Dehumidifier

1 Answer

Goldstar dehumidifier


Hi,

Two possibilities:
1. Continuous running and there is water coming out of the unit to the floor drain; the unit is just doing its job. It is probably just that there is that much humidity in the room;
2. the sensors are faulty or were bypassed during the repair - the sensor would be testing the water coming out, if there is water, the unit continues to work, if none, then it shuts off. Most would also have an overfill float switch, again which could be bypassed, that likewise control whether the unit will continue to run or stop.

Hope this be of initial help/idea. Pls post back how things turned up or should you need additional information.

Good luck and kind regards.

Thank you for using FixYa.

Jun 03, 2008 | Goldstar DH504EL Dehumidifier

Not finding what you are looking for?
Aprilaire 1700 Dehumidifier Logo

Related Topics:

38 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilaire Dehumidifiers Experts

Michael Youngman
Michael Youngman

Level 2 Expert

235 Answers

Gil Shultz

Level 3 Expert

3382 Answers

Bill Boyd

Level 3 Expert

52843 Answers

Are you an Aprilaire Dehumidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...