Question about Crown CE4000 2-Channel Amplifier

2 Answers

Amplifier dead no power nothing - Crown CE4000 2-Channel Amplifier

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Crown Master
  • 5,056 Answers

Unplug it. Look inside the unit and see if you locate a fuse. Also look around just to see if anything is damaged or burnt.

Posted on Oct 07, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 313 Answers

Check on the back panel there should be a small head where the fuse is its usually looks like a black dial head undo this and check the fuse there.. I have one on teh back of mine that has blown before.. Good luck.. you have checked the fuse in the plug too I hope..

Posted on Oct 06, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My hifonics Brutus 2000 watt has a dead short in it somewhere,as soon as you put power to it it blows the fuse,no lights nothing.any body got any ideas?i have it all tore apart now,but no burn spots


Call hifonics, they do flat rate repairs on their equipment for a reasonable rate. Most likely, you have a shorted mosfet transistor module in the power supply. these are not a smple repair, most local shops won't touch them. 25321271-zkea2bktkzr3q3lrmfdlr2m5-4-0.jpg

Dec 14, 2014 | Hifonics Car Audio & Video

1 Answer

Power to amp but no light happened when my battery went dead replaced


the power amp has a short in the unit and it drain everything out of the battery, that why the battery is dead. it is really possible that a capacitor is open or shorting out cause the unit to drain the battery.

Mar 26, 2014 | Volfenhag ZX-8400 Car Audio Amplifier

1 Answer

Completely dead NAD M15, is there an internal fuse that I can change ?


NAD M15

Problem : Dead


Possible solution : Check for Power Supply

How to Test a Transformer: 7 steps - wikiHow


If these has been done,


• Check amp power supply and low voltage regulators

These includes fuses ( many of them )



Tech Center tells you how to use a multimeter .

• There could be other electronic components but try on them first.


If the torroidal transformer is OK , then it could be a problem on the

Circuit boards.

There could be a shorted components somewhere.

Jul 29, 2012 | Audio Players & Recorders

1 Answer

Kac-8101 no power


no its not dead u prob blew a couple of heat sensors or a capacitor. most defenetly a capacitor. ceck ur capacitor and see if its blowned

Jun 28, 2009 | Kenwood KAC-8101D Car Audio Amplifier

1 Answer

Peavey 8.5c amplifier. One channel dead. In


FIrst of all, in bridge mode there is only one channel. The "bridge" means that you combine the two channels together to get a single more powerful amp. The swollen part is probably nothing. Sometimes the plastic caps cup like that. Unless there is a specific problem with the amp, don't worry about it. Try placing the amp into stereo mode and testing each channel. If both work, there is no problem with the amp. If for some reason you need repalcement capactors, contact Peavey directly. They supply replacement parts.

Dan

Mar 19, 2009 | Peavey Audio Players & Recorders

1 Answer

Subwoofer has power but not getting sound


Some ideas.

Blown fuse in the amplifier section.
Dead amplifier
Dead speaker.

Amp is not that expensive, call Velodyne

Apr 29, 2008 | Velodyne CHT-10 Subwoofer

1 Answer

NAD C 340


Power surges and lightening can reak havoc. It may just need fuse replacement

Apr 12, 2008 | NAD C350 2-Channel Amplifier

2 Answers

Nothin will work


If you've got 12v constant on the yellow, 12v switched on the red, and chassis ground to black, your fuses are good the radio is powered properly.

When you plug the harness into the back of the radio you should hear the CD transport cycle. That's telling you the radio's getting power. Hit the reset button (pin-hole switch on front panel) and hold the small square open/close button for 2-3 seconds.

If still nothing, the radio needs service. I'd send that model to Alpine in CA for repair.

Jan 26, 2008 | Alpine CDA-7998 CD Player

Not finding what you are looking for?
Crown CE4000 2-Channel Amplifier Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crown Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5056 Answers

The Knight
The Knight

Level 3 Expert

74118 Answers

Paul Bade

Level 3 Expert

1536 Answers

Are you a Crown Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...