Question about Car Audio & Video

1 Answer

My c15 citreon van keeps blowing 10amp fuses for side lights etc since fitting a new radio, i have taken the radio back out but it is still doing it, can someone please help? It seems it is ok when vehicle is static, but when it has been driven for 30 seconds to 1 minute the fuse then blows again. i have been told by a fitter at local cireon garage to connect power antenna cable to negative ground cable, but it still blew once i had started driving .

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 35 Answers

Please check your total circuit related or connected with 10Amp. fuse, anyhow i think it is semi short circuited. u have to find out where the short circuit occurred. to find out the problem u can start checking from side light holder...........

thanks

Posted on Oct 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ive had the pump overhauled by professionals,fitted pump onto van,timed all correct and theres no fuel getting to injectors,also keeps blowing 10amp fuse on glowplugs


Did you prime the system ? Fill the fuel filters with fuel ! For the glow plugs find a wiring diagram an do a voltage drop test on the circuit ! May have a shorted glow plug or the control module. You can find videos on you tube on testing ,probably .

Nov 15, 2015 | Cars & Trucks

1 Answer

Citroen c15 van i have fitted a radio only when you turn the side lights on it blows the fuse


Does the radio work if the dash lights are off?

I'm wondering if the power and lamp wires are reversed in the 3 wire connector that plugs into the side of the radio.

satellite radio receiver

Aug 24, 2012 | JVC KT-SR2000 SIRIUS Radio Receiver with...

1 Answer

Where is the fuse for cig lighter, radio & interior lights on a c15 w reg van


Find a car lot with your van and ask to look inside. Use that vans fuse lid.

Sep 01, 2010 | Car Audio & Video

1 Answer

Hi there, I have bought a replacement brake light bulb for a Citroen C15 van, but I cannot see how to gain access to fit it? Many thanks Steven Chandler


The taillights on most vans are accessed from the storage compartments in the back of the van on each side. You open the cover, and sometimes you have to remove a liner, depending on the vehicle, and you can then access the back of the taillight.

Oct 21, 2009 | 2006 Fiat 124

3 Answers

Starter fuse under the hood keeps blowing....the factory deck was replaced by a new deck...every since then the ignition fuse keeps blowing..


the new radio install is causing this if the power was taped into the starter system. rec. removing wires then try to see if you can blow your starter fuse

Jun 01, 2009 | Car Audio & Video

2 Answers

Gearbox


its not hard, same as usual car, o/s drive shaft, u have to undo the 2 11mm bolts on engine mount, with a large chisel and hammer hit the shaft, there is a steel collar around the shaft, hit it there hard to push it out of the engine mount.

Apr 26, 2009 | 2006 Peugeot 505

1 Answer

Got a new Kenwood KDC-128 car radio recently, fitted it but the radio presets would not stay when the ignition was turned off. Then it stopped working altogether and I noticed the 10amp fuse at the back...


you need to hook the yellow wire off the back of the radio up straight to the battery this keeps memory power to the head unit then wire the wires in color coded sequence red to red black to black so on and so forth if this doesnt fix it you might want to think about replacing head unit

Jan 02, 2009 | Kenwood KDC-128 CD Player

2 Answers

99 Camry it keeps blowing 10amp fuse


I agree with lobsterman...Aftermarket radios kill the gauge fuses.

Aug 24, 2008 | 1999 Toyota Camry

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

48 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...