Question about Cyber Acoustics CVL-1066 Consumer Microphone

2 Answers

Cyber acoustics CVL-1066

I get almost nothing. When I speak my mouth is on the mic for it to pick-up anything. I've purchased 2 and got the same result. I'm using it with Quickcam v11.0

Posted by on


2 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 36 Answers

A couple things you might try:

Right click on your volume icon in Windows, and see if the mic input is lowered at all. Bring the fader up as high as it can go on the mic. Depending on your sound card, you might also see an icon marked "-20 db pad". Make sure this is NOT checked.

According to the specifications, the CVL-1066 has a frequency response of 100-10000 Hz. If your voice is particularly low (and I mean, really, really bass-heavy), it might not be able to pick it up clearly.

One last thing to check is that you've plugged it into the "mic" port on your sound card and not the "line in" port. If you post your sound card type (or motherboard), I'll help you further with which port it should be plugged into. Also be sure to mention if you're using Vista or XP (or another OS altogether).

Posted on Dec 31, 2007


Also try boosting your microphone gain.

Posted on Feb 25, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Cyber Acoustics AC-201 Micrphone Problem

i have cyber acoustics headset and i cant hear anything but my Mic works, my sound is all fine, when i plug my headset out i can hear but when its plugged in, i cant hear anything.

Mar 09, 2010 | Cyber Acoustics AC-201 Consumer Headset

1 Answer

NO one can hear me, tryed changeing settings

Goto the mixer, select microphone as recording source and set the slider at about 80%, then bring up microsoft sound recorder and hit record. When you speak into the microphone you should see a voiceprint if the microphone is working correctly.

If you do not see a voiceprint, then it may be a faulty microphone.

Dec 18, 2009 | Cyber Acoustics CVL-1064 Consumer...

1 Answer

CYBER ACOUSTICS CVL-1066 - not working

Have you installed batteries in it? It has to have apower source. It probably has an on/off switch as well. Good Luck

Aug 18, 2008 | Cyber Acoustics CVL-1066 Consumer...

2 Answers

Problem with CVL-1064

Sounds like the port/ soundcard has issues.
My advice to anybody using mics wich plug into soundcards is get an interface mic pre and a real mic. Interfaces can be had for cheap these days as long as mic pre quality doesn't matter to you, and you can get a shure sm-57 mic for $80 wich will last a lifetime.

Jul 06, 2008 | Cyber Acoustics CVL-1064 Consumer...

1 Answer

Isralling a new microphone

You computer should have a symbol of a mic above or below the port for it. It will probably fit in only one. Make sure that you have batteries in your mic and that it is turned on once you have it connected to the PC.

Apr 27, 2008 | Cyber Acoustics CVL-1066 Consumer...

1 Answer


Install batteries in it
Connect it to the back of your PC
Turn it on

Hope this helps. It shouldnt need software.

Mar 03, 2008 | Cyber Acoustics CVL-1066 Consumer...

2 Answers

There is nothing!

I had the same problem. Here's how i fixed it.

I uninstalled the sound completely from my computer. Then i restarted the computer. This will reinstall the drivers for your sound and the one you need for your mic. I have vista but this should still work for XP.

-right click on computer (should be on ur desktop or under start menu)
-select manage
-device manager
-click on the plus next to sound, video and game controllers
-right click on the audio (high definition audio device)
-select uninstall
- restart your computer.

This will do the trick.
your computer should recognize the mic.

Nov 22, 2006 | Cyber Acoustics CVL-1064 Consumer...

Not finding what you are looking for?
Cyber Acoustics CVL-1066 Consumer Microphone Logo

Related Topics:

240 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cyber Acoustics Audio Players & Recorders Experts

mukhtar21 shaikh
mukhtar21 shaikh

Level 3 Expert

2022 Answers

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

620 Answers


Level 3 Expert

77939 Answers

Are you a Cyber Acoustics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides