Question about Pioneer GM-7200M Car Audio Amplifier

1 Answer

Red light on the amp.

I have everything hooked up right. I think. I have had it this way for years. Know when I hook the amp up the red light turns on. I do not know what the problem is.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Have you checked your speakers to make sure they're connected to the amp (a wire could have broken or pulled loose)?

Have you confirmed that you have a good signal reaching the amp?

The red light isn't always a good indicator that the amp is functioning properly. If you have speakers connected to the amp and have a good signal feeding the amp, the amp may have failed.

Posted on Dec 23, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Tc 8001 red light


on some amps there is a duel light. red and green usually. red means it is in protect mode or you didn't hook up your remote wire. if in protect mode, it could mean a number of things. did you hook it up with speakers and everything?

Mar 01, 2012 | MTX Thunder® TC8001 Car Amp

1 Answer

There's a flashing green and red light when my car is on and the sub attached to the amp is making a heartbeat like noise when the light goes green and then the light goes red right away. everything is...


Check the wires for short circuiting at the car body or speaker wires. Triple check really everything.
Make sure the connectors are 100% connected to the wires. There maybe some resitance if the amp isn't getting enough power from the battery.

Aug 19, 2011 | Jensen JXP680 Car Audio Amplifier

1 Answer

Sony xplod amp won't work it stopped for no reason


try hooking the amp up with 3 wires, the red power wire, the black ground wire, and the remote wire, do not hook up the speakers at this time

Apr 25, 2010 | Car Audio & Video

1 Answer

Have power but no sound


U may have blown the High Out put.


Not sure but is the Protection Led light on the AMP. if it has one it should be green if everything is Fine. Red or Flashing Red is not good.

U can test it has a low in out put . But if only has RCA out then u may want check the Fuses inside the AMP... Be careful because if u open it up after it was just turn on u will get a ZAP if the amp is not fully discharged.Look for any burnt Resistors etc,

Let me know if this works!!
Thank U Jayson
Please feel free to rate my suggestions.
we depend on your votes!!!

Jul 04, 2009 | Clarion APX400.4M Car Audio Amplifier

1 Answer

Amp runs but then will just turn off and red light comes on


you may have fried the amp pre outs in the head deck, try the amps on another stereo

Jun 01, 2009 | Lightning Audio Bolt B2.150.2 Car Audio...

1 Answer

Subwoofer wont play


change your rca's you may have a bad one that is grounding out or one of your spkr

Apr 14, 2009 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

Turns on but nothing displays.


it sound like the memory wire is hook up wrong, check the yellow wire first then the red wire if still the same problem, connect the red and the yellow wire together to see if it come on it should come on you might have to run a hot wire from the battery in the dash then hook the yellow wire to it so your memory stays on

Apr 11, 2009 | Dual XDVD8170 Car DVD Player

1 Answer

My fiance purchased a pair of P1 RF speakers and their matching amplifier. when he hooked them up in our car everything worked well. we unhooked everything and then ran all the wires and re-hooked...


well let me see i can bet something happened so what happened??? i bet the amp is not working right? hahaha here's my sign right!!! all right enough fun. is the light on the amp coming on? you might also need to turn the key all the way to the run position, if not wired exactly right then amp will only power up when vehicle is running or key is in the run position i need to know this before we really go any further. let me know so i can get you up and running quickly.

Mar 07, 2009 | Rockford Fosgate Car Audio & Video

2 Answers

Subs and amp problems


make sure you have the wires from the amp to the box, and the box to the subs hooked up right... red is positive black is negative

Dec 28, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Pioneer GM-7200M Car Audio Amplifier Logo

Related Topics:

291 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Audio & Video Experts

The Knight
The Knight

Level 3 Expert

75888 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Marvin
Marvin

Level 3 Expert

83096 Answers

Are you a Pioneer Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...