Question about Pioneer VSX-D509S Receiver

2 Answers

Just fried my 2nd home stereo receiver

Fried the last one a couple weeks ago. Assumed it was due to poor ventilation (it had something sitting on top of the vent) went out and got a pioneer the same day. It has played fine all the way up till today...it's completely fried and won't even turn on.
The first one (sony) we've had for about 5 years. The only change that has been made is we added an optimus 12'' subwoofewer that I picked up from a yard sale. Could it be frying the receivers???

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

If the Optimus subwoofer is passive (no internal amplifier, powered by the Sony or Pioneer) it is possible that the subwoofer's driver (cone) has a shorting voice coil. This will blow the amplifier section of your receiver(s). Check the receiver's fuse(s). If you are lucky, the fuses blew and the receiver circuitry is OK, if not, it will require professional service. In any case all the rest of your audio system should be checked before reconnecting the receiver.

Posted on Oct 04, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 84 Answers

Yeah check the ohms for the receiver an see what the subwoofer ohms are.that can fry them

Posted on Oct 04, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Do all Kenwood Home stereos have fuses?


yes there are fuses. usually they are glass fuses near the power input on the board inside the unit. but you could also have fried or corrosion damaged other electronics if you have dropped water inside it

Nov 24, 2013 | Car Audio & Video

1 Answer

I spilled a liquid in my jvc rx-502ov receiver and a message reads dsp micom ng what do i do?


You fried the poor thing to put it mildly, Get a different one end cut down on your partying ,(GUY) Unless you have money to burn

Dec 05, 2012 | JVC Rx 5020v Stereo Receiver

1 Answer

My home stereo Sony when turn on the word 'protect' comes on and doesn't moves from there


"protect" usually means speaker wires are crossed or speaker ohm load is too low. if you have more than one speaker connected. if you did not change anything since the last time you used the radio the internal amp might have fried and you should have the radio serviced if the cost is worth it.

Dec 23, 2010 | Sony Audio Players & Recorders

1 Answer

Motor does not fire but did this morning before i took it out


well most likely you fried the control module .hooking battery up backward even for a couple seconds will do it .

Mar 08, 2010 | Boating

1 Answer

Stereo won't turn on


It could be fried, but some of these stereo's have fuses on the back of the radio. Example: I have a fuse under the dash and 2 on the radio. Take the radio out and check the fuses, then check your radio harness for power. If you have power coming through your harness, then most likely the radio is fried.

Feb 24, 2010 | 2001 Audi A6

4 Answers

My powerbrick lightis orange but my xbox360 wont turn on


If the light on the power brick stays orange after turning the console on it means the brick is not properly functioning. You can attempt to clean the power brick with a can of air. Also make sure it has ventilation and is not sitting on carpet. This can cause the power brick itself to overheat and cause issues with it and the console itself. Also make sure your 360 is not plugger into a surge suppressor as this can cause issue due to double protection.
If possible, test the power brick on a different console, and test the console on a different power brick. This will narrow down your problem area.

Dec 22, 2009 | Microsoft Xbox 360 Pro System Console

2 Answers

Yamaha RX-V750 wont power up


Check the fuse. You might have had a power surge which blew a fuse. If not, check the fuse for the socket. Reset the fuses for that socket. If it still doesn't work, it sounds like the internal boards got fried, or the power supply got fried. The power supply is replaceable, but we don't know if it is the power supply. To check, connect a voltage meter to the power supply.

Something like this happened to me. I found a new kenwood stereo next to the dumpsters, stickers and all still on it, plugged it in, it worked, shut it off to plug in a speaker, didn't turn back on, months later after leaving it plugged in, turned on, I used it, then shut it off for the night, in the morning the standby light was still on, tried turning it on, but it wouldn't for some reason, unplugged it, then the light wouldn't come on, it was once again sitting on a shelf as a paperweight, one day it randomly came on again, and now it 100% works, and I use it as an amp for my RE audio subwoofer, and its worked great since! The reason this kinda applies to you is because its kinda simmilar what happened to you. Just leave it plugged in, and maybe sometime you will walk by it noticing it works.

Oct 10, 2009 | Yamaha RX-V750 Receiver

1 Answer

Car overheating


Good chance. The temp sensor in the radiator could not be reading correctly. Or the fan control module is on its way out.

May 26, 2009 | 1995 Volkswagen Golf

1 Answer

My panasonic sa-ak58 home stereo, it turns on o.k. but after a couple of seconds i loose audio, on all speakers, but the led screen shows normal volume level, no matter if is high or low on volume.


go on the back of the stereo take a aux cable and hook to the back and touch the end were it plugs in to the mp3 r what ever you use and if its still making the nosie your amps fried

Aug 28, 2008 | Panasonic Audio Players & Recorders

1 Answer

Front buttons won't work


The microprocessor may be locked up. While pressing and holding "video 1", press "speaker A". When "clear" appears in the display, the micro has been reset to the factory default condition. To do a full reset without taking it apart, it may have to sit up to 3 weeks for the backup battery to run down.

Dec 21, 2007 | Onkyo TX-DS474 Receiver

Not finding what you are looking for?
Pioneer VSX-D509S Receiver Logo

233 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

John
John

Level 2 Expert

509 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Are you a Pioneer Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...