Question about Vacuums

1 Answer

Performance indicator I have a canister vacuum. I cleaned the filter and now the performance indicator is red, is it supposed to be red or green?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

Put tape over it so u cannot see it

Posted on Oct 03, 2009


1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Red light indicator comes on with suction only


Hi there Christy! It sounds like you possibly have a clog in your main hose. To check the hose for clogs remove the hose completely from the vacuum from both ends. Use a broom stick or something similar to loosen and remove any clogs from the hose. Remove the bottom plate and the brushes. Use a wooden spoon to gently break up and remove any clogs from the lower hose. Hope this helps!

Jun 16, 2014 | Hoover Nano Cyclonic Compact Bagless...

1 Answer

Red power light blinks even with completely clean canister and filter


Check for a filter where the air blows out of the machine. Could be clogged.

Jul 26, 2013 | Hoover S3755 WindTunnel Bagless Canister...

1 Answer

What color is the air flow indicator supposed to be? Mine is yellow but I have no suction. I have read that some people have red, others yellow. I have cleared out all hoses and cleaned the filters with...


Hi there,

the unit may be experiencing something other than a blockage. Perhaps the dirt canister is not put back into place properly and the unit is sucking through there instead of through the hose.Check to see if the lid and the canister are both on the unit correctly and see what happens. I do not think that the unit is blocked up on you.

Normal air flow indicator color by the way is the same as when the unit is in the off position. The indicator is generally like a pen spring and stretches when the hose or suction is blocked off.

Good luck.
Mark

Nov 09, 2010 | Hoover Elite Rewind Bagless Upright...

1 Answer

Bissell Momentum 12amp


did you change both filters. Mine had the same problem. After changing both filters, (one under canister and one on side of vaccum) the problem left.

Aug 02, 2008 | Bissell Vacuum - Momentum Cyclonic 1 ea...

2 Answers

Performance indicator light


check to make sure the bag isn't being sucked into the air filter. open the access door where the bag is and you'll see the air filter at the bottom. to check, leave the door open while you would see the performance indicator light on, and then pull up the bag. this is one of many solutions i'm sure to the performance indicator problem.

Oct 17, 2007 | Kenmore 23913 Progressive PowerMate Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

178 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...