Question about Karcher K2.26 Electric Power Washer

Open Question

The detergent suction tube does'nt ****! Is it just a case of pulling it out of the front and placing in the detergent, or am I missing something? Thanks

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Troy bilt pressure washer 020207 won't draw soap


Below is a list of the MOST COMMONLY reported troubleshooting issues.

you might want to try these steps:
No detergent
Reservoir is empty
Add more detergent

No detergent
Detergent suction tube not properly connected to the machine
Check connection

No detergent
Detergent is too thick Dilute detergent

No detergent
Filter on detergent suction tube is closed
Open the filter by turning it to the desired detergent intake

No detergent
Filter on detergent suction tube is clogged
Run warm water through filter to remove debris

No detergent
Damaged or clogged detergent suction tube
Remove obstruction or replace detergent suction tube

No detergent
Spray wand is in high pressure position
Turn spray wand tip to low pressure position

No detergent
Discharge nozzle is obstructed Blow out or remove debris with a fine needle

reference from:

http://troybilt.custhelp.com/app/answers/detail/a_id/10652/~/basic-troubleshooting---pressure-washers-%28gasoline-powered%29

please consult the operators manual you can get from link below:
Parts Manual Finder

or a Professional Shop Manual for model specific technical information.

If professional service is needed, please utilize the Authorized Service Center Directory to have the equipment professionally inspected and serviced.
You may also contact our Customer Technical Support department at:

Toll-Free Sales and Support (U.S.A. Only) 800.828.5500

Hours of Operation (EST)
Monday-Friday: 8:00am - 8:00pm
Saturdays: 9:00am - 8:00pm
Sundays: 10:00am-6:00pm



May 11, 2014 | Comet BXD2527 Pressure Washer Pump

1 Answer

Won't suction up the water


The most common reason for lack of pick up is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Jul 05, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Steam vac sucktion problem


The most common reason for lack of suction is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Jul 05, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

My machine is only a few months old and has worked perfectly until now. I cannot get the machine to pull the solution back into dirty tank. I have tried the suggestion with the lid and that did not help....


If you are sure the lid is in place, another reason for lack of suction is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Apr 01, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

I have a hoover stemvac that wont **** up any water/solution It has suction but it's not pulling up any liquid? Does anyone know how I can fix this?


The most common reason for this is that the lid is not fully seated on the dirty water tank. Be sure to hook the lid in front, and then snap it in place at the rear. Another problem could be that the duct is missing from the front of the tank. The duct is removed to install the hose assembly, and may not have been put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A less common problem is that the round rubber seal that the tank sits on has fallen of the motor cover suction tube. Look beneath the tank for the missing seal.

Mar 31, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Why it doesnt **** up the water


The most common reason for this is that the lid is not fully seated on the dirty water tank. Be sure to hook the lid in front, and then snap it in place at the rear. Another problem could be that the duct is missing from the front of the tank. The duct is removed to install the hose assembly, and may not have been put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A less common problem is that the round rubber seal that the tank sits on has fallen of the motor cover suction tube. Look beneath the tank for the missing seal, and place it back on the large tube that sticks up from the motor cover.

Feb 23, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

My steam-vac carpet cleaner doesnt seem to be pulling the dirty water back out of the carpet.


The most common reason for this is that the lid is not fully seated on the dirty water tank. Be sure to hook the lid in front, and then snap it in place at the rear. Another problem could be that the duct is missing from the front of the tank. The duct is removed to install the hose assembly, and may not have been put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A less common problem is that the round rubber seal that the tank sits on has fallen of the motor cover suction tube. Look beneath the tank for the missing seal.

Add a comment

Feb 22, 2011 | Hoover Vacuums

1 Answer

I have a brand new Hoover model F5918-900 scrubber. It was doing fine. I turned it off and emptied the water tank. When I turned it back on the suction completely failed. No suction at all. I made...


The most common reason for this is that the lid is not fully seated on the dirty water tank. Be sure to hook the lid in front, and then snap it in place at the rear. Another problem could be that the duct is missing from the front of the tank. The duct is removed to install the hose assembly, and may not have been put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A less common problem is that the round rubber seal that the tank sits on has fallen of the motor cover suction tube. Look beneath the tank for the missing seal, and place it back on the large tube that sticks up from the motor cover.

Add a comment

Feb 22, 2011 | Hoover F5918900 Steam Cleaner

1 Answer

No suction


The most common reason for lack of pick up on the F5900 series is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Feb 20, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

No suction of the water from carpet after soap is applied


Hello :

1: A vacuum pulls air through the bag, then through the tube attachment and then through the base (with the spinning agitator brush).

2:Check for signs of suction. Remove the tube attachment from its cradle and, after turning on the vacuum, put your hand to the end of the tube. Is there any suction at all? If there is a little bit of suction then you may have a clogged air tube.

3:Check the vacuum bag. It may be very full. If it is then remove the bag and replace it with a new bag. Check the suction power again. Has the suction improved?

4:Check the tube attachment. Completely remove it from the vacuum. You usually have to twist and pull the tube attachment out of place at the point where it connects to the back of the vacuum. Check the suction power again. This time you place your hand on the vacuum right where the tube used to come out of the back of the vacuum. Has the suction improved?

5:If the suction power has improved then you probably have a clogged tube. Dog hair, people hair, leaves and more can get lodged in the tube slowly over time and then suddenly block the tube completely.

6:Clean the tube by first trying to shake the debris out of the tube. If this does not work then go outside and run a hose through the tube. Use a pressure nozzle if you have one. Run the hose through one end of the tube. Then run it through the other end. Repeat until the debris is disloged. Dry the tube and then reattach to the vacuum.

7:Has suction power improved or returned to normal power? If yes then you can stop reading now. If not then read on.

8:Check the air hose in the base of the vacuum. This hose is usually pretty short and you can see if there is any blockage. If you see blockage then try to remove it. You may need to reach into the hose with a tool (like a screw driver or something long).

9:Has suction power improved or returned to normal power? If yes then you can stop reading now. If not then read on.

10:If you made it to this step then you may have a problem with the motor on your vacuum. If this is the case then you will need to take the vacuum in to a repair shop.

Things you will need :
1 Philips screw driver
1 flat head screw driver

Warning :


# Always unplug electrical devices before you work on them.

# Never work on electrical devices around water or when you are wet.

I hope this will help .

please rate !


Apr 27, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

Not finding what you are looking for?
Karcher K2.26 Electric Power Washer Logo

Related Topics:

376 people viewed this question

Ask a Question

Usually answered in minutes!

Top Karcher Garden Experts

John Trevino

Level 3 Expert

1383 Answers

andy just round the...

Level 1 Expert

47 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Are you a Karcher Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...