Question about Crunch Powerzone P2125 Car Audio Amplifier

1 Answer

I have a crunch pzi 1000 that blows the main fuse when ever the main power wire is connected and power comes out through the inputs??

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 199 Answers

Hello ! there is a short circuit   on power section  need to  be checked and fixed  some Transistor or IC, diode  burnt  .
The fuse gets blown coz power is reversed back  at primary level ,power supply.

good luck 

Posted on Oct 03, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I can't figure out if my crunch powerzone pzi 250.2. 1000 watt amp is compatible with my 2000 watt pioneer premier 12" sub, I seem to be blowing fuses will someone please help me out


There may be an impedance mismatch between the two. If the amplifier "sees" a load impedance of 2 ohms or less, for example, the fuse(s) will open to protect the output stage from failure.

Feb 09, 2017 | Pioneer Car Audio & Video

1 Answer

I have a rockford fosgate punch 800 car amp and the problem i seem to be having is everytime i connect my remote wire to my stereo deck and i turn my stereo on it burns the fuse its only when i connect my...


Check the wires at the amp. Make sure that the wires are neatly bundled and clean cut when connecting them, a stray wire may be going under one of the connections from the battery input to the ground input of the amp, there for causing a direct short and blowing the fuse. I am assuming you mean that the amp's fuse is blowing. Get yourself a test light and test the wires for power. battery power?(12V) is always on and remote power(12V) comes on only when the radio is on(it should be the blue wire in color). Then make sure you have a very good ground, I always use the seat belt bolt or car seat bolt(direct to chassis). If you checked all these steps with no luck then the culprit may be your amp.

Jul 22, 2011 | Car Audio & Video

1 Answer

I turn the key on my 04 gsxr 1000 and theres no electrics, battery is charged and working fine and all wires are connected... but still no power


You need to locate the main fuse. It may be in the main box with the other fuses. On the bikes I am familiar with they put it on the starter solenoid. Your owners manual will tell you where it is. If the main fuse blows you lose everything. The only other thing that causes the condition you mention is a broken connection in the battery. Testing the cells shows a full charge but no juice comes out. You have to load test the battery to find out if the battery is bad. You could jump the bike from another battery(with the other vehicle turned off)if your bike lights up , this would tell you your battery was broken internally.

Sep 15, 2010 | Suzuki GSX-R 1000 Motorcycles

1 Answer

I have an amp that turns on (green light) but has no sound coming out


Crank up the rotary gain potentiometer for in and out from the amp.

Apr 30, 2010 | Crunch Maxxsonics PZi 3000.1D Car Amp

1 Answer

AMP WONT TURN ON


Hi.

A short on Amp power contact can blow the internal power adapter. Before deciding if to replace or repair the amp, check if it has an external fuse mounted at the back side of the amp. In that case replace it.

Also ensure that the wires that you are connecting to the amp are still powered. Read Volts on wires before connecting to test the amp.

If the Amp has blown, then the damage will be located in the power supply circuit, and can be repaired testing and replacing few components.

Mar 27, 2010 | Crunch Maxxsonics PZi 550.5 Car Amp

2 Answers

I have a new Generac 20KW Propane generator with a rtse 200A3 automatic switch. I had an electrician install the switch and make the connections from to the generator. The generator is blowing the 7.5 amp...


Sounds like the electritian wired something wrong. Control wiring for that generator should be:
N1 and N2 = 240 vac utility input
Wire 0 = ground
Wire 194 (15B) = + battery
wire 23 = transfer signal

Sep 02, 2009 | Generac Guardian 200 Amp Transfer Switch...

1 Answer

My amplifier is not in protection mode everything works fine but my subwoofers play a very small sound . and it is not my subs at fault i already tested my subs and they work fine. i know theres a problem...


THERES A PROBLEM WITH YOUR RCA'S,IF YOU JIGGLE THEM WHILE THERE HOOKED UP TO THE AMP AND THEY MAKE THINGS LOUDER OR POP THAN YOU NEED TO GET THE RCA TERMINALS FIXED.

May 07, 2009 | Crunch Maxxsonics PZi 3000.1D Car Amp

1 Answer

Crunch amplifier


there is a bad ground or some other wiring issue in your car you will have to re wire all new to find it unfortunately

Dec 12, 2008 | Kicker KX600.1 Car Audio Amplifier

1 Answer

My subwoofers cut out


You are most likey running too much power from the amp to the speakers.. you might want to try just notching the bass down a notch or 2.. just enough that the bass will hit

Nov 16, 2007 | Car Audio & Video

3 Answers

Red LED "Protection Light is on" What is the problem


The red light means the amp is in protection mode. A few things can cause protection mode..... First disconnect the subs completely from the amp, and turn it on, if it powers up you have blown subs. Also try checking the main power wire at the battery...sometimes the current your meter is seeing is backfeeding from the remote wire, so your main power line could be blown at the fuse under the hood. hope this helps

Jul 17, 2007 | Crunch BlackMaxx BMX2250 2 Ch 1000W Amp...

Not finding what you are looking for?
Crunch Powerzone P2125 Car Audio Amplifier Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crunch Car Audio & Video Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1147 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Are you a Crunch Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...