Question about Kicker KX400.1 Car Audio Amplifier

2 Answers

Amp not powering at all

I recently got a Kicker KX400.1 from my cousin and when I hooked it up just to the battery, there was nothing lit. No power or protection. What can be done about this

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

No electricity

Posted on Jan 21, 2008

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Did you apply 12v to both the B+ terminal and the remote terminal?

Did you check the fuses?

Posted on Dec 21, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

ZX 1000.1 amp stays in protection mode


It is normal for them to go into the protect mode, If the speakers are not hooked up to it,

Nov 09, 2012 | Kicker Car Audio & Video

1 Answer

Why does my amp turn off when i hook up my 12 inch kicker


Possibly due to a poor battery, you could try installing a power cap to prevent the amp shutting down/protect due to low voltage when the starter kicks in.

May 10, 2012 | Kicker 07CVT124 12 inch ShallowMount...

1 Answer

I have an AudioBahn A4004T Amp. It was working fine and then I had it sitting in my house for a few months. My cousin wants to use it in his car so he hooked the power cables up to his battery to see if it...


If you only hooked up the power and ground the amp will not turn on. You must also hook up the remote wire. This either can come from your radio, your fuses, or your power wire itself. If you hook it up to your radio then it will turn on when the radio is turned on. If your radio doesn't have a remote wire to amp then you can read your owners manual and hook it up to the radio fuse and when the radio turns on the amp will turn on. An lastly you can run a wore from your power wire to your remote plug in. But if you do this the nano will constantly be on if it is hooked up to the battery.

Dec 25, 2010 | AudioBahn A4004T Car Audio Amplifier

1 Answer

Kicker impulse 254 amp red light on top?


1st check all of your wiring, make sure the remote wire is hooked up, check to see it the RCA's are hooked up. I know this sounds stupid, but i've done it a thousand times, check to see if you hooked up the speakers. If you checked all of those and still nothing, double check your ground. Make sure where you have it grounded, you have all the paint sanded away and its a good grounding point. The red light on the top of the amp, its not a protection light is it??

Apr 03, 2010 | Car Audio & Video

1 Answer

I have a 1000.1 kicker amp and when i have the amp


you might not have the battery power to power it or it might not be the right ohms. i just had this happen to me after i hooked up 4 cvrs to the same amp. today it just quit.i got to get it checked out to see if i blew it.

Nov 22, 2009 | Kicker ZX10001 Car Audio Amplifier

1 Answer

My Kicker 04KX400.1 stopped working. Checked fuses/cables. Plz help!


Hello dbarlow_it,

You do not say if the amp is showing an indication of powering up or not. If it is getting power, the "power" LED should be lit.

There's also an inline main power fuse that should be located within a foot or two of the positive battery terminal. If you have checked it also and it's good, test for 12V+ at the amp power terminal. If you are getting power, then check that the remote turn-on lead is still functioning. It should also have 12V+ on it when the receiver/head unit is turned on.
If the amp is getting power, and a turn-on signal from the remote, it's most likely that the amp itself is defective.

Hope this helps.

Aug 13, 2009 | Kicker Car Audio & Video

1 Answer

Kicker kx 800.4


Generally, if a Kicker amp has the power light lit and the protection light isn't lit, it's working. Are you sure that you have signal feeding the amp?

Are you sure your speakers are OK?

Nov 04, 2008 | Kicker KX800.2 Car Audio Amplifier

2 Answers

Kicker zx1500.1: no sound output


Does it make the same noise if the RCA cables aren't plugged in?

Apr 10, 2008 | Kicker ZX10001 Car Audio Amplifier

1 Answer

Kicker amplifier


Sounds like you popped a fuse my man. Check your Manual on how to replace them.

Feb 11, 2008 | Kicker KX600.1 Car Audio Amplifier

Not finding what you are looking for?
Kicker KX400.1 Car Audio Amplifier Logo

Related Topics:

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

hoyzee1

Level 2 Expert

150 Answers

yadayada
yadayada

Level 3 Expert

78257 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...