Question about Hoover U5753-900 WindTunnel Bagless Upright Vacuum

1 Answer

I just changed the belt an dthe vacumn doesn't have any suction.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 294 Answers

Check the dirt canister lid and that the lock lever is in proper position

Posted on Oct 11, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My vacumn won't pick or suction up and bag is not full. I cleaned out the hose checked and belt running I have no other answer please help. It's an upright lux guardian


The output filter on that unit is HEPA and traps all particles. You need to clean or replace that filter because the airflow cannot leave through it and it wont develop suction.

Feb 06, 2015 | Vacuums

1 Answer

My windtunnel vacumn U5464-900 has lost suction in the hose. It is not clogged. What may the prob b?


The beater bar belt more than likely needs replaced. When they get stretched out they no longer work properly.

Jim

Sep 09, 2010 | Vacuums

1 Answer

Volta ultima 2000 watt vacumn - hardly any suction at all


change your bag.or your motor is going bad so have that looked at.

Jul 03, 2009 | Electrolux UltraLux 2000 Bagged Canister...

1 Answer

Vacuum is whistling and there is no suction through the hose.


Sometimes mine "wand" has no suction too. . . Make sure the vacumn column is clicked into the "standing" position, don't have it at an angle. Also you may have to play with the settings on the bottom part AND the power button together. I think this vacumn sucks (pardon the pun) mine turns off after 10 minutes of use, then I let it sit for an hour and then it'll start again. POS!

Apr 22, 2009 | Fantom Vacums XT450K Upright Vacuum

1 Answer

How do I change the belt on my vacumn


there should be some screws on the bottom of the machine. take out the screws and remove the cover

Apr 18, 2009 | Bissell 6594 PowerForce Bagless Upright...

1 Answer

Beater bar has stopped turning


All beater and rotating brush bars are fairly easy to get to with a couple of screw on the bottom of your wan. They are driven by a belt and these belts come off, break, or the bar itself is stuck with rug material. Unplug your vacumn and get our screwdriver. It;s easy to figure out once inside the wan.

Mar 02, 2009 | Kenmore 23313 Whispertone Bagged Canister...

1 Answer

No suction or very little


Make sure you have a good bag installed in the vacuum and the door is properly in place. Remove the attachment hose from the bag chamber and turn the machine on. You should have good suction coming from the hose inlet. If you don't you have a problem in the bag chamber. Bad bag, door is not on correct, door is defective, dirty secondary filter.

Connect the hose back to the machine and pull the other end out from the bottom, and turn the machine on. You should have good suction there. If you don't you have a clog or hole in the attachment hose and it needs to be unclogged or relplaced.

Reconnect the to the bottom. Flip the mahine upside down. Take the screws out of the bottom plate and remove. Remove the brushroller and belt. Turn the machine on and you should have suction at the inlet coming off the brushhousing. It you don't, then you have a clog in the nozzle hose and it needs to be removed. It will probably be more accessable from the bottom side since that is the way that it entered.

Sometimes a suction problem can be confused with an brush problem. The belts on that machine should be replaced every 6 to 8 months because they will strentch and wear. This is an inexpensive maitainance that will dramatically improve its function. Part Numbers are 38528-035 and 38528-034

Nov 21, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

No wand suction


  1. i cleaned out my fanton and no suction in wand and still whistles

Aug 17, 2008 | Fantom Vacums XT450K Upright Vacuum

1 Answer

Nutone Vacumn 450 built in vacumn system


definately something stuck in the hose. Take the hose of and check for blockage.

Jun 02, 2008 | Vacuums

1 Answer

No vacumn action


Is the roller turning, if not you may need a new belt and/or brush roll. Did you check the inlet by the brush roll?

Feb 09, 2008 | Eureka 2961AVZ Bagless Upright Vacuum

Not finding what you are looking for?
Hoover U5753-900 WindTunnel Bagless Upright Vacuum Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18392 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1461 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...