Question about Pyle PLA2200 Car Audio Amplifier

1 Answer

No power all wires are hooked up, but my power light doesnt come on.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Posted on Dec 20, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I put a Pioneer AVH 1400 DVD in 06 solstice have it hooked up working but no sound through speakers I have hot ground remote and speaker wires hooked up what other wires have to be hooked up 4 sound


If the car had an amplified sound system prior to removal you will need to turn on the factory amp. You need to hook up the blue wire with the white stripe. You may have a dedicated wire that you need to hook it to or you may have to hook it directly to the 2 blue wires for the power antenna. Now you may not have a power antenna but hook them up anyway. If that doesnt work you have a dedicated amp turn on wire. If you find that and it still doesnt work check your fuses for the amplifier with a digital multimeter. Replace any blown fuses that you cant find

Apr 17, 2016 | Pioneer Car Audio & Video

1 Answer

Wont work


try wiring it up with both the constant power and the switch power directly to your battery. if it works, then your switch wire inside the vehicle isnt a 12v output.
if it doesnt, then something is wrong with your head unit

Apr 26, 2017 | Kenwood KDC-HD455U

1 Answer

99 neon dome light wire diagram


Hooked all wires up right??? Fuse is fine??? Somehow, I do not think this is the case. I wish I had a dollar for every time I have seen this happen....I would be a VERY rich man!

You do not need a dome lamp diagram. You need to replace Fuse #13 (10 Amp) in the Power Distribution Center in the engine compartment. This will make the power return to the PINK wire and get your dome lamps working.

The only way that the RED/WHITE wire is going to have power with the ignition switch off is if either the ignition switch is shorted to power or the RED/WHITE wire got hot enough to melt the insulation in the wire harness and short to another B+ wire. This wire is supposed to have power when the ignition switch is in the RUN and ACC positions. Make sure it is in the OFF position. If this wire still has power, then YES, you probably smoked the wiring harness. If this is the case, the dash should be removed so that full access to the wiring harness can be achieved, allowing a full inspection/repair of ALL of the damage (there are most likely several other wires in the harness that have also been damaged).

Dec 24, 2011 | Dodge Cars & Trucks

1 Answer

My amp blew the 20 amp fuses. Replaced and they blew as soon as the radio kicked in. Took the back off to look for any burnt connections or blown open/expanded capacitors or resistors. It smells like...


Remove all the wires from the amp including the remote turn on wire. Once you do that, after about 30 seconds the amp will reset. Hook the power up first, then the ground then the remote. Turn the unit on and check for power WITHOUT the speakers hooked up. If you get no power by now it's a good chance that the amp is cooked. If you do get power, try hoking up your speakers first on one channel then the other channel and then bridged. If it cuts out or off when you touch the speaker wires to one channel or the other, then that channel is no good. Hope this helps.

Mar 17, 2011 | Kenwood KAC-728S Car Audio Amplifier

1 Answer

Brake light socket was replaced with newer type and it has 2 black wires and one green wire, the older on has only 2 black wires how do I hook this up a friend hooked it up and the brake light doesnt work...


If the old one had two wires and the new one has three wires you have the wrong socket or you replaced the wrong socket.

The green wire is ground. One of the black wires will be power for the park lights and the other will be power for the brake/turn signal. Since you don't know what black wire goes to what you can temporarily connect then two the wires on the car to make sure the park light is dimmer than the brake light. If it is not than swap the two black wires and continue with the repair.

I’m happy to assist further over the phone at https://www.6ya.com/expert/jeremy_d728a59f986299fa

Nov 11, 2010 | 1993 Plymouth Sundance

1 Answer

All hooked up and power lights on but it still doesnt work


ARE YOU SURE YOU CONNECTED THE YELLOW WIRE TO CONSTANT POWER AND THE RED WIRE TO ACCESSORY POWER.THE YELLOW IS FOR THE MEMORY AND ALWAYS HAS TO HAVE POWER EVEN WITH THE KEY IN THE OFF POSITION AND THE RED HAS POWER ONLY WHEN YOU TURN THE KEY.MAKE SURE THAT THERE IS POWER IN BOTH AND ALSO CHECK THE GROUND AND THE ANTENNA,BUT MY GUESS IS WITH THE POWER.HOPE THIS INFO HELPS.TAKE CARE AND GOOD LUCK, MANNY

Feb 20, 2010 | Dual Electronics XD5125 Car CD Player

1 Answer

When i hook my trailor's lights to my 2003 yukon xl, park lights doesnt work, but all other lights work


You mean the truck parking lights dont work, or the trailer running lights dont work? Does the trailer just have tail lights or does it have front and rear side markers? I think you mean the trailer lights. Check for power at the plug,(Brown Wire) if there is power, then you could have wiring problems, but a better description of what works and what doesnt work needs defining.

Dec 18, 2009 | 2003 GMC Yukon XL

1 Answer

My dual xd7500 cd player doesnt turn on anymore while hooked up only the power button light turns on nothing else works this is hooked up in my bedroom but the problem should be the same as in car can...


Is the red wire in the back hooked up to a power source? You will need that in order for it to turn on. It is the wire tells the radio to turn on when you turn your key.

Oct 18, 2009 | Dual XD-7500 CD Player

1 Answer

Mower wont start


Solenoid has dead short. Replace it. Cost is low. Crossing terminals on today's engines with electronic ignition parts is dangerous to the other parts.

May 24, 2009 | Mtd Garden

1 Answer

Mine is actually a q4000 4 channel amp


First of all, you MUST HOOK UP YOUR GROUND WIRE FIRST. You may have damaged it if you hooked your power and trigger wire first and then the ground wire. Unhook EVERYTHING except the hot wire, ground wire and trigger wire. If you still can't get the unit to come on then it is time for a trip to the repair shop. Good luck.

Feb 01, 2007 | Cadence Q200 2 CHANNEL POWER AMPLIFIER...

Not finding what you are looking for?
Pyle PLA2200 Car Audio Amplifier Logo

Related Topics:

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyle Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4991 Answers

The Knight
The Knight

Level 3 Expert

75846 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8841 Answers

Are you a Pyle Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...