Question about Yamaha STEREO POWER AMPLIFIER 750X2 @4 OHMS - P5000S Car Audio Amplifier

1 Answer

The amp just quit. will not power back up.

The amp just quit. no smoke or burning smell. will not power up at all. internal fuse checks okay. any type of reset to look for that I may be overlooking?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Ok there is a few steps to check in this case.
1. Make sure the positive cable is secured proply on the battery termnial also while you are there as well check to make sure the fuse on the positive cable isn't blown.

2.Make sure your ground cable is secured proply down on the frame of the car or if you are runing a negitive cable back to the battery(the same apply,s as step 1 - less the fuse).

3.Check to make sure the remote turn on cable is not lose on the amp connection.


Hope this will help a bit.
Alex

Posted on Oct 02, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The motor does not spin at all but the l.e.d light comes on when in the on position? Could it be the switch?


sometimes the drill has level right above the trigger, if in the center it locked in place, right turns right, left than turns left, the other button may also have 3 position forward, reverse, lock mode.
if all that okay the motor not getting power, check the cord, inspect the cord for kinks inside the cord itself, if the battery type check the battery for proper voltage with a voltmeter,
if your advertencies take it apart, check the fuse/fuse-link.
make sure the wiring okay, not burned, smell to see if burned up
that smell you will know right away the system has failed.

Sep 17, 2015 | Drills

3 Answers

My LG washer stopped mid-load at spin cycle, how can I fix this?


It sounds like a serious fault if there is no power the fuse has gone or some item has burnt out . You will have to arrange for a service engineer to look at it more closely.

Apr 28, 2015 | LG WM-2277HW Front Load Washer

1 Answer

I forgot to disconnect the Amp before changing the Distributor on my car, now I don't see a light on my amp, did I blow the amp? the fuses appear to be in working condition, and I got a reading with a...


Hello Permicioust, Hi, beside the fuse outside the amplifier, is a fuse inside, so check it out first, smell the amp for smoke or burnt parts, check for fuse type resistors on the power supply line inside the amp.

Feb 13, 2011 | Sony Car Audio & Video

1 Answer

It was working fine and just quit it acted like it had blown a fuse but all of them that I have found look okay. Is there a reset switch on this model anywhere? When it kicked off the first time it stayed...


is this like charades
what the beep are we talking about here is it a toaster a car or may be a phone
the question makes no sence with out knowing the item that has the problem

Jul 25, 2009 | Gem Sound GemSound PA-585 2-Channel...

3 Answers

I have a 1990 Lexus LS400, Keeps blowing the 30a Fusable link


if you smelled smoke you probably have a short you will need to do some more extensive searching to find the burned\shorted wires.

Dec 29, 2008 | 1998 Lexus LS 400

1 Answer

Went to a family dollar with a roof top unit and at the time could only check right above the drop ceiling, where there was a return and supply flex and a piece of square duct going through the roof and a...


sounds like a smoke detector to me. usually they just break the red or the green through a relay, if it smells smoke. could be dust burning off the heat strips first use, or you could get on the roof and find burned wires or motor. lots of old wires burning up with heat strips kicking in this time of year. i usually have em turn off alarm so fire dept wont come and turn to max heat and burn off the strips , measure amps, check wires, and all relays etc. you may have to bypass smoke detector till done. then return to correct "as found" wiring and reset alarms. hopefully no call backs. good luck.

Nov 21, 2008 | Heating & Cooling

1 Answer

X type lose of power +white smoke


hi its not the egr valve white smoke indicates water combined with loss of power indicates headgasket oil blow back faulty pcv or piston rings worn yates210456

Jun 19, 2008 | 2003 Jaguar X-Type

Not finding what you are looking for?
Yamaha STEREO POWER AMPLIFIER 750X2 @4 OHMS - P5000S Car Audio Amplifier Logo

Related Topics:

120 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5126 Answers

The Knight
The Knight

Level 3 Expert

74211 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Yamaha Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...