Question about Generac 13,000 Watt / 13,000 Watt Home Standby Generator

7 Answers

Generac 43903 standby Generator overspeed indicator on starting

After 1.5 years my Generac 43903 standby Generator now refuses to run more than 3-4 seconds and stops with an overspeed led light lit. Will start on manual setting, but still stops as described above.

I once got it to run normally on manual, and set it back on automatic, but the next time it tried to do it's weekly test run, the same problem came back. I have tried removing the 15a and 7.5a fuses to reset the control board, but that did not work, now it wants the exercise cycle reset and the unit won't reset.

How can I determine if there is a sticking governor, or other problem?


Posted by on

  • 4 more comments 
  • J E White Oct 02, 2009

    I can check that, but my unit has a low oil LED but it has never come on, and I added some oil to the unit but it still would not work correctly. A local Generac-trained technician thinks it may be a sticky governor, however, and is sending some repair diagrams. I did try moving the throttle lever to and fro, and start it manually several times... it seems to have started working again, but I don't know if it really solved the problem. I will try starting it manually for a while in a few days to see if that helps.

  • J E White Aug 04, 2011

    Thanks for the suggestion Robinmar. The battery is still good (3 years old/5 year battery) and the unit cranks and starts OK. It is a sealed type and since it starts the unit I don't want to break the seals yet. It turns out that starting it on Manual 5-6 times with some rest in between seems to solve the problem at the time finally, and I let it run 5-10 minutes to make sure.

    But after a month or two, it often re-occurs. The unit does run once a week on the schedule, but if the over-speed problem occurs, I need to do the manual starting until it works again.

    I don't know if it is just a lubrication problem with the governor mechanism or what. I am going to contact Generac to see if they have any experience with this problem.

  • J E White May 23, 2012

    After working with a local Back-up Power service technician, the problem turned out to be a loss of the energizing current on start up which establishes the 12 vdc to activate the various sensors, and caused the false "overspeed" indication which shuts down the generator after 5-10 seconds of running. It turned out that Generac has a repair kit which solves this problem! I found that the Generac recommended service company in Northern Nevada, APS-FAB, knows how to diagnose this problem and how to order the repair kit (although I had to contact Generac support management to find out about this solution, and the repair kit came without any installation instructions, so proper modification of the circuit was a bit of a trial and error process). The modifcation assures 12 vdc to energize the sensors even if the process circuit board fails to do so, as was the case for my unit. The faliure became evident after 2+ years, intermittent at first, and finally a hard failure. Replacement of the main PC circuit board also solved the problem, but costs over $200 just for the part. So, "overspeed" fault, in my case, had nothing to do with the governor or the actual speed control of the unit. I commend Generac for providing a low-cost fix to this problem which seems to be a fairly common mode of failure, but most folks will need the knowledge and diagnosis of a field service representative to resolve these problems.

  • trollpaint
    trollpaint Aug 12, 2012

    yes i have a generac model 04109-3am having the same problem for the last three years after having three different dealers here in the birmingham al. area and around $1000 spent i still have problem

  • J E White Nov 01, 2012

    Trollpaint, See my post of May 23 - have your service company check for the 12 volts that should be generated upon starting, which supplies the sensors. In my case, that voltage was intermittant or missing and that caused the control board to not find the speed sensor signal, resulting in the false overspeed indication.

  • Sean Aug 06, 2013

    I have the Generac 43902 and it would not start. I pulled the fuses to reset control board and re-gapped the plugs to 0.20 and she fired right up! Thanks for the suggestions.

×

Ad

7 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 14 Answers

I have a generator that did the same thing. It would start and then stop within a few seconds. The more expensive generators have an oil level safety switch to prevent the engine from burning up. There is usually a wire connecting to the switch on the outside of the engine near the oil fill hole. Remove this wire and try to start the generator. If it runs without a problem then it is the switch. You need to remove the switch and take it apart carefully and clean it. There is a small float inside the assembly. When the oil runs low the float allows the switch to short to ground which kills the spark to the spark plug. Hope that helps.

Bob Janelli

Posted on Oct 01, 2009

Testimonial: "This is good information in the event that the low oil switch is part of the problem."

  • J E White Nov 05, 2012

    My problem was lack of the 12v. supply to the sensors, not the oil switch. lack of the 12 volts to the sensors results in the overspeed error by default. See my comment for the solution and fix.

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Check the starting battery. If it is low, the n cank LED will light, and the unit will just click. remove the battery, charge it, fill the cells with distilled water, and put it back in the generator. Carefull to not short the battery leads when you remove the battery. Just went trhu this with mine and all better now. Battery leads were either loose or the cells had lost so much water in teh heat we're having this year, the battery couldn;t start the generator, thus 'overcrank' - actually , it just didn;t run, but thought it did!<!-- from fixya rte -->

Posted on Aug 11, 2010

  • 1 more comment 
  • J E White Aug 04, 2011

    Thanks Robimar, but the unit cranks fine and the battery is good.
    I found that trying to start the unit 5-6 times on manual with some time in between attempts is generally successful, and i run it 5-10 minutes to make sure it is OK. But the problem re-occurs without warning. I guess I will have to contact Generac to see if they are aware of the cause or have a solution.

  • DH52 Sep 08, 2011

    jwhit2, I am having the EXACT same problem with a 43902. Any luck finding a solution?

  • J E White Nov 01, 2012

    DH52 - yes, see my post below, May 23, 2012

×

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I'm having the same problem with generac unit. It's got the 6- cylinder motor and runs on a natural gas line. It will test run fine on test run sometimes. Other times it revs too high and the over run light comes on. Shutting the system down. Need to figure out how the run speed is set and why it is not staying at the preset level.

Posted on May 20, 2012

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I HAVE 15KW GENARAC AND WILL ONLY RUN FOR 10 SECOUND I CHANG OIL UNIT TEMP UNIT THROTTLE WELL FREE AND LUBED AND STILL THE SAME THANKS JOE

Posted on Aug 03, 2011

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Have the same new issue with my 17kw.
The tech came out for a couple of hours and determined that one cylinder had low compression which gave the overspeed messages. It does the same think , starts and runs for about 10 seconds. He suggested replacing the engine. I have a hard time believing that.
Mark.

Posted on May 19, 2018

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

Over speed ingeing alaram. them strekap the ingeing.prai wehil said runing weth dainamo avr or gavenar problam

Posted on Jan 20, 2013

  • 2 more comments 
  • J E White Jan 20, 2013

    ranjithsomar - My problem was that 12 volts DC was not being generated after starting. If 12 volts are not present, the fault/error sensors will shut the generator down with and "overspeed" error. Generac has a repair kit for this problem. You need a repair technician to test for 12 volts and request repair kit from the manufacturer. contact me (in English, please) if you need more information.

  • J E White Jan 20, 2013

    ranjithsomar - My problem was that 12 volts DC was not being generated after starting. If 12 volts are not present, the fault/error sensors will shut the generator down with an "overspeed" error. Generac has a repair kit for this problem. You need a repair technician to test for 12 volts and request repair kit from the manufacturer. Contact me (in English, please) if you need more information.

  • Mark Goldman Aug 06, 2013

    I have the 43903 , same problem with the same generator. can you please provide the generac repair kit name and part number?

  • J E White Jul 28, 2014

    Mark, Sorry, i don't have the details, as my repair technician received the the repair part kit. You should be able to get that information from Generac Support. Note that the installation instructions had the 12v. connctions reversed, but my repair tech fixed it by reversing the leads. (sorry to be late in replying, as i did not get notification of your post).

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I just installed two 8k units with the same problem, the arm on the stepper motor fell off and one of them I couldn't get to stay on so I put a screw through it, it is a crappy setup.

Posted on Oct 31, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Generator hard to start and sputters like its missing


About 15,000 results (0.73 seconds) Search Results

    2 - Generac : Questions, Answers, How To, FAQs, Tips ...

    answers.generac.com/answers/1506-en_us/searchquestions.htm?...
    Can I run an 8kw standby generator on a 100 lb propane tank? 2 answers ... What am I getting for the extra cost of the Guardian unit? ... The engine starts hard and runs rough. 1. Air ... On auto start, unit sputters and I smell gas. ... Does the gas and electrical feed into the unit from the back as previous air cooled units?

    2 - Generac Questions and Answers

    answers.generac.com/answers/1506.../generac.../questions.htm?...
    On auto start, unit sputters and I smell gas. .... The 20kW automatic standby generator has the option to delay start up during an ... This is for a guardian 20kw. ....has been designed to make the battery installation and removal so difficult? ... The air cooled generators are designed to allow for the smallest footprint while still ...

    3 - Generac Questions and Answers

    answers.generac.com/answers/1506.../generac.../questions.htm?...
    Generac's Guardian Series 17kw automatic standby generator does not come with a.... The automatic response features of our air-cooled units initiates the unit's startup,.... This week I tried the same and it tries to start but just sputters and fails until .... A C delayed start still chocks 17kw generator would a hard start kit help?

    On auto start, unit sputters and I smell gas. On manual start ...

Feb 08, 2016 | Generac Guardian Air-Cooled Standby...

1 Answer

Why does it crank and almost start on 1st try?


Generac Generator Troubleshooting - YouTube

? 1:39
https://www.youtube.com/watch?v=AKN2dc59cxY
Dec 20, 2013 - Uploaded by Appliance Princess
I want to learn about Generac generator troubleshooting. ... I have a 16 kW propane fueled standby air-cooled generator. ... I have a brand new generac 20K guardian Evolution and the first time my power went out my generac ...

Generac Power Systems - ConsumerAffairs.com

www.consumeraffairs.com > Homeowners > Utilities

Rating: 1.3 - ‎26 votes
Hey, Generac, make a change and start making generators that work, don't cost .....Standby generators are not supposed to be used as a primary power source ... and three months ago, I spent $4,000 to have a Guardian generator installed at ...

Generac standby generator - Propane - wont start?? - DoItYourself ...

www.doityourself.com/.../487838-generac-standby-generator-propane-w...
Feb 4, 2013 - I have a Generac 4LM41A standby generator that I need help introubleshooting and repairing. It is about 12 years old and hasn't been used ...

141 GENERAC complaints and reviews @ P'ed Consumer


Dec 12, 2015 | Generac GUARDIAN Standby Generator 10 kW/9...

1 Answer

Generac Guardian 12 KW Model 04456-2 shuts down on overspeed in cold weather


Leigh,
See my 5/22/12 comments on my "overspeed fault" problem resolution [Generac 43903 standby Generator overspeed indicator on starting] . If it only runs for a few seconds and then quits, you may have a similar condition to the one my unit had. A good technician should be able to diagnose the problem and determine if you have a similar failure to the one I had, or one of the other causes suggested by RSG000.

Jan 20, 2012 | Generac 13,000 Watt / 13,000 Watt Home...

1 Answer

I have an older 30KW Generac SG 030 1800rpm running on Nat Gas which I bought used. It has set up for several years. I installed a new PN0830890SRV master control board I bought from the local Generac...


need to calibrate the main control board. 83089. also is it overspeed or overcrank? if the board does not see the right rpm or is blow a certain threshold it will think it has not started yet and shut down on overcrank.

Mar 13, 2017 | Generac 13,000 Watt / 13,000 Watt Home...

1 Answer

10kw Generac shut down overspeed


Make sure that the throttle linkage is all there and not damaged/misadjusted, then get a manometer and check your inlet gas pressure. Gas pressure should be 8 inches of water column and stay there running or not.

Carl

Apr 06, 2009 | Guardian Electrical Supplies

2 Answers

Generac Guardian 15 kw overspeed fault


Did you remember to set the overspeed shutdown threshold on the control board?

Apr 03, 2009 | Generac 13,000 Watt / 13,000 Watt Home...

Not finding what you are looking for?
Generac 13,000 Watt  / 13,000 Watt  Home Standby Generator Logo

16,001 people viewed this question

Ask a Question

Usually answered in minutes!

Top Generac Electrical Supplies Experts

Craig Butler
Craig Butler

Level 3 Expert

1723 Answers

dennys23601

Level 2 Expert

80 Answers

Don  Farrell
Don Farrell

Level 3 Expert

1018 Answers

Are you a Generac Electrical Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...