Question about Pyramid PB1500 Car Audio Amplifier

2 Answers

PB1500 no diag. lights - Power - OK

I have a PB1500, now owned for about 6 months.. today i noticed the power LED was off on the remote and thus no sound.. i figured it was just a fuse.. No diagnostic lights are on (power/protect) but i know it has power cause the blue LEDs on the side light up.. any suggestions??

P.S. Both my fuses check out as good.. i am lost

Posted by on

2 Answers

Re: PB1500 no diag. lights - Power - OK

Check if the terminals are well connected and also check the sub the pyramid can't handle 2 ohm bridged it must be 4 ohms by the way i but the 2600watts and its not even close that power...

Posted on Mar 13, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers
Re: PB1500 no diag. lights - Power - OK

I don't know how you checked the fuses but if you didn't use an ohm meter, you need to confirm that you have B+ and remote at the amplifier.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If the voltage is sufficient at the remote and B+ terminals, the switching power supply has probably failed in the amplifier.

Posted on Dec 21, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Pyramid PB1500 vs. Metrik Rem. Bass knob????

Yeah it's probably not going to work because it's not even the same brand

Jan 18, 2010 | Pyramid PB1500 Car Audio Amplifier

1 Answer

Amp burned out but fuses still good?

this is caused by inproper wiring from the speakers/subs to the amplifier.. an amp will still put out power to subs and speakers when it's wired improperly but it won't last for very long doing it... 6 months is longer than usual....

Dec 05, 2009 | MA Audio M1900XE Car Amp

1 Answer

The led on my lxa 600 watt amp in my dodge magnum

If the light is all that is on then it will be fine. It would take days to weeks for it to kill todays car batteries. If the amp is drawing more power than just that though, I would move the remote wire to the ignition or the headunit, because the fusebox is getting constant power to tell the amp to stay on.

Oct 10, 2009 | Car Amplifiers

1 Answer

Kicker zx750.1 Amp in Protection Mode (Red LED)

My kicker amp zx1500.1 keep going in protection mode I unhooked the sub speak wires and put the ACR cords back in and it didn't go in protection mode what next

Mar 18, 2009 | Kicker 06ZX750.1 Car Audio Amplifier

2 Answers


Start removing wires from the amp, one by one (except for the +12V, Ground, and remote) until the amp seems to work fine. Usually, this type of issue is due to a speaker wire shorting to something it shouldn't be touching. Check the "non-amp" end of all the wiring to make sure they are solid and correct.

Apr 04, 2008 | Volfenhag ZX-8300 Car Audio Amplifier

1 Answer

Whats wrong with my lanzar amp

check ur ground wire , it might not be good ground, secondly check ur fuses..

Dec 25, 2006 | Lanzar HTG264 Car Audio Amplifier

2 Answers

Rockford power 1001bd amp

There are two LEDS. One on top and one on the end. Did both light up? If not, which one lit up?

Sep 13, 2006 | Rockford Fosgate Power 1001BD Car Audio...

1 Answer

Kenwood KAC-9152D Car Amp

use a multimeter to check for power on the +ve wire, could be your fuse, it only rus a sec when you jumper the remote to +ve because the remote cannot give out the nessary current to run the amp.

Sep 13, 2006 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Blinking Led power light

I have a alpine MRP-M350 700 watts class D... i will ask if it can support 2 subwoofer a 1200 watts 10" JBL subwoofer?

Aug 22, 2006 | Alpine MRP-M350 Car Audio Amplifier

Not finding what you are looking for?
Pyramid PB1500 Car Audio Amplifier Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyramid Car Amplifiers Experts

Alan Timperley
Alan Timperley

Level 2 Expert

91 Answers


Level 1 Expert

2 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Are you a Pyramid Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides