Question about Sony Xplod 1100 Watt Max 10" Subwoofer, XS-L100P5W Car Speaker

1 Answer

Amp works for a few minutes

Amp light is green when i turn it on after a few minutes it turns red

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 38 Answers

Too much power. turn your amp down a bit and let er rip.

Posted on Oct 03, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony KDF-55E2000 power led blinks red 3 times....


Are you using an extension cable? If you are, try plugging it directly into the wall.

Alternatively, call up the helpline and they may be able to provide more insight into your specific problem.

Jul 20, 2017 | Sony Grand WEGA KDF55E2000 55" Projection...

1 Answer

Still having amp problems


Hello lilmario,

After eliminating wiring problems and possible shorts, grounds and low impedance in the speakers, most likely the amp is failing internally. A partial failure of either the output MOSFET's or the thermistor. In either case, the repair requires removal and replacement of components on the circuit board. Depending of the age and original cost of the amp, such repairs are sometimes expensive.

I'd recommend having a professional audio shop test the amp and provide an estimate for repair.

Hope this helps.

Sep 21, 2009 | Car Audio & Video

1 Answer

Red light comes on for a few seconds


Check the feed fets or the audio amplifier IC´s are damaged

Aug 16, 2009 | Rockford Fosgate Punch 401S Car Audio...

3 Answers

Red Power Protector light


Hi, the only way i can see the amp resets the stereo is that power is dropping. The amp should have its own wires directly to power/battery so as to not affect anything else.

On the protect, try to disconnet all the speakers, make sure the power is OK. If it appears to work, the there could be a problem with speakers/cables. Try a different speaker to see if it works. If the problem continues with speakers off, a different speaker etc, then there is a problem with the amp. Hope that helps

Jul 21, 2009 | Sony XM-2100GTX Car Audio Amplifier

1 Answer

Sony xplod 1000 watt amp not working


you need a amp kit your battery or alltinator isn't powerful enough to handle the wattage you need a juice can it gives yur battery more power

Jun 30, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Amp runs but then will just turn off and red light comes on


you may have fried the amp pre outs in the head deck, try the amps on another stereo

Jun 01, 2009 | Lightning Audio Bolt B2.150.2 Car Audio...

2 Answers

Jh202 amp works for a few minutes stops for a few minutes any ideas


Sounds like the amp is going into Protection Mode. Does yours have green LED light then RED LED on it? The green is power and the red is Protection. You will need to either change the OHMS wiring or Put A Fan on it to Keep it Cool Inside.

May 11, 2009 | MTX JackHammer JH202 Car Audio Amplifier

4 Answers

No response from amp


it sounds like you have a bad ground make sure its on the froame or body and make sure any rust or paint is sanded or scraped off

Feb 09, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Amp runs but then will just turn off and red light comes on


you need to get a fan for it because it does not come wit one and when you get the fan you have to hook it up from the inside by taking the torture tested/bolt sign off and look for a small white pug to attach it to

Dec 08, 2006 | Lightning Audio Bolt B2.150.2 Car Audio...

Not finding what you are looking for?
Sony Xplod 1100 Watt Max 10" Subwoofer, XS-L100P5W Car Speaker Logo

Related Topics:

149 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4885 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...