Question about Pyle PLA1200 Car Audio Amplifier

1 Answer

I got a pyle 1800w amp and a 1500w kenwood subs but as i increase the volume in the headunit it goes on protect mode why the other problem i got is as increase the volume in the headunit the bass of the subwoofer goes down

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

The protection modes in these units ****. Most new units have them. What I do is turn down settings on deck and turn up amp as much as possible. Then the protection won't turn on because you won't have to turn it up as high.

Posted on Sep 30, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound from my subs


it should have a red light on if it is in protection mode. If it does not have the red light then buy a new amp and check all you wiring

Nov 22, 2013 | Kenwood KAC-9105D 1800W Max Class D 1 Ch...

1 Answer

'"hi i have a power


The refurb may not have been complete

Mar 24, 2017 | Power Acoustik Car Audio & Video

1 Answer

Got a problem with my car amp.Everything was working fine until 2day.Amp goes in to protection mode.Jumps from power to protection indicator every i would say 3 seconds and each time it goes in to...


Ok check the remote wire running from the headunit to the amp should be giving v12 feed whiles headunit is on.

check or change grounding position.

take cover off the amp as the circuit may be over heating.

Sep 22, 2010 | Car Audio & Video

1 Answer

Amp problem


why, why, why, that is the question here.

Sep 30, 2009 | Pyle PLA1200 Car Audio Amplifier

1 Answer

Amp goes into protect mode after volume is turned up


Not enough juice, check the power and ground connections, another possibility is to have dc in the input, try to use in line filter available from radio shack to cut the dc, also test the with one speaker at the time, you could have a bad speaker (shorted) too.

Apr 08, 2009 | Pyle PLA4240 Car Audio Amplifier

2 Answers

The protect light stays on


is your amp grounded well?
are all of your fuses fine?
connections to stereo?

if all else fails you might have blown your amp like mine, you can see about getting it fixed but i just found another one.

how many watts is your amp? how much does your sub need?

Nov 18, 2008 | Pyle - Elite: 2 Channel 1800W Elite Series...

1 Answer

How to adjust the controls and gain on my kenwood 9104d 1800w amp


Hook the speakers in series to decrease your chances of blowing the amp and/or speakers themselves. And at high volumes make sure that the bass control is set for flat response.

Jun 25, 2017 | Car Audio & Video

1 Answer

Car system


if you have dual voice coils connect on each seporate sub negative left channel to possative right channel of the subwoofer same to other sub then conect the left possative and the right neggative to your box power terminal same to other sub then conect the two sub outs on your box left speaker positive to your positive left channel bridge then conect left speaker negative to the right speaker possative then connect your right speaker negative to your right channel negative brigdeg to your amp is single coil hook the box its self up the same way to your amp i have two dual voice cooil 12" hooked up to the same amp that way and it rocks without the power protecter turning on

Nov 09, 2008 | Pyle PLA2200 Car Audio Amplifier

1 Answer

Car audio amp in protection mode


If you power up the amp with the RCAs plugged in, does it go into protection mode.

If you power up the amp with the RCAs plugged in, does the woofer pop?

Oct 26, 2008 | Pyle PLAD413 Car Audio Amplifier

Not finding what you are looking for?
Pyle PLA1200 Car Audio Amplifier Logo

87 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyle Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4869 Answers

The Knight
The Knight

Level 3 Expert

74383 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8522 Answers

Are you a Pyle Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...