Question about Husqvarna Lawn Tractor 48" Deck, 23 Hp, Model# Yth2348

1 Answer

Transaxle not working.

The pump is making noise like the fluid is low. The drive is not engaging, forward or reverse. The manual says that the trans-axle is factory sealed. A friend says he added fluid to his and all is good. What type of fluid and where do you ad it?

Posted by on

  • davehess Oct 01, 2009

    No fluid needed. The rusty valve is not fully opening or closing. The disengage rod is connected to the transaxle valve lever with a spring. This lever is prone to rust. You will can not tell the valve is not functioning until you inspect it.

    Remove the chassis end plate (the one with the hitch) by removing four bolts. Spray the transaxle valve lever and shaft down with rust buster or WD-40, work it free and lube with grease. Assemble and go cut your grass!

  • davehess Oct 04, 2009

    It turned out to be a rust actuator lever. It's lubed up and works fine now. Thanks for your response.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 472 Answers

On the back of the mower you will need to remove the back there is a hose comeing out of the trans its a vent tub remove the plug and put some good 30 w oil in the tub tha should fix it

Posted on Oct 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My mower stopped moving forward and reverse. engine starts easy but hydrastatic pedal does not engage


check pedal connection rod or cable -- check under unit for drive belt problems ---look at axle override lever or rod not engaged --park brake engaged--if all look good possible failure of axle unit

Jun 03, 2017 | Garden

1 Answer

Why isn't something engaging when accelerator pressed?


It would help to know more information about the mower in question. Walk behind push mower? walk behind self-propelled mower/ Riding lawn mower? Lawn tractor? Or goat...just kidding...lol. The engine horse -power or cc's and make of the mower and engine. Anything happen before the problem or was it straight out of storage. Does the gas pedal feel normal? Could you be talking about the forward/ reverse pedal? These types don't engage by depressing them, they engage by releasing the pedal.
I'm going to guess you have a riding lawn mower or lawn tractor. The pedal for those types of mowers controls the transaxle ( rear wheels, transmission and differential basically). If the pedal move properly and it was working ok when it was stored, then check to see if you can push it with little effort. On most transaxles there is a disconnect rod to disengage the transaxle for towing the mower without damaging it. Pulled out for disengaged and in for engage. If that all checks out it could be very low on transmission fluid or the drive belt might be off or broken depending on which type you have. If it is low on fluid, you have a leak. Hope this helps.

Mar 11, 2016 | Garden

1 Answer

Won't move forward or backward.


Most are sealed. Is your drive belt ok?

Feb 15, 2016 | Husqvarna Garden

1 Answer

Have a craftsman LT1000 Riding Mower 17HP. changed the oil in the transaxle and now can't get the automatic forward and reverse to engage. Any suggestions? !


get it off the groud rear wheels put a weight on forward drive if it works fine if not with the weight still on start turning wheels by hand if it work let run like this 30 minutes if not did you use the right fluid not transmission fluid if you did buy new hydrostatic pump buy one any way pumpsounds like bured up 200 dollars for pump before you do this isworth it if mower over 4 years buy new mower you will save a lot of money in long run

Aug 24, 2014 | Garden

1 Answer

I have a LT1042 hdrostatic drive and it won't go forward or reverse what is wrong


can only guess

Low on cub cadet hydro fluid?
other hydro filter other and cub cadet?
linkage came unhooked from drive mechanism
your engage disengage lever at the back of the mower is set so it can be pushed,engage lever to allow hydro pump not to be bypassed

Jul 28, 2014 | Cub Cadet Garden

1 Answer

Yardman riding mower no reverse forward jerking motion


It sounds like you either have a lose belt that is slipping or the fluid in the transaxle is low, or the transaxle is going bad, if it is a hydrostatic transaxle, drain and replace the fluid first, if that fails, you may have a bad seal in the pump or a worn gear

Oct 16, 2013 | Yard Man Garden

1 Answer

Lawn mower transmission


This can be a loose belt that is slipping, low fluid in the transaxle, a bad pump (if hydrostatic transaxle) or worn gears, start by checking belt tension, then replace the fluid and filling to proper level, if that fails, the trans will need to be inspected for internal damage to pump and gears

Oct 16, 2013 | Yard Man Garden

1 Answer

Transmission will not engage in forward or reverse. when car is first started it will engage. after 5 minutes i hear a vibration noise, (almost like a power steering pump low on fluid when steering wheel...


Take it back make them fix it. It sound like the pump in the transmission is going. Thick fluid pumps easier that thin fluid and it would talk about 5 minutes for it to heat up going from thick to thin.

Feb 07, 2011 | 2001 Pontiac Montana

1 Answer

Murray front engine 18hp wont go forward or reverse. Belts all look good, makes a moaning sound when pedal is engaged.


Sounds like your transaxle is bad. Is it a hydro or standard? Hydro maybe low on fluid or if it has a filter...it maybe plugged. We sell new and used tranny's www.nnyparts.com

May 29, 2010 | Garden

Not finding what you are looking for?
Husqvarna Lawn Tractor 48" Deck, 23 Hp, Model# Yth2348 Logo

370 people viewed this question

Ask a Question

Usually answered in minutes!

Top Husqvarna Garden Experts

Phil Walker
Phil Walker

Level 3 Expert

605 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Are you a Husqvarna Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...