Question about Infinity BASSLINK Car Subwoofer

1 Answer

Basslink "Motorboating" I have an Infinity Basslink which I installed and had working fine for over a year.  Recently the unit has begun to make a thumping noise and a "motorboating" noise (as described on infinity's website) for a few seconds before going silent.  The power led is still lit when this happens. I have checked all the wiring connections and they seem fine, they're all the same as they were when I had the unit working. I've scoured the web for solutions and have come up with nothing although Infinity mention this problem on their website. Can someone please offer me some assistance before I go crazy!

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers
Re: Basslink "Motorboating"

Good evening, my name is Colmen here is a guy that might be able to help you 917 504 0461 please let me know how you make out, he has done a lot for me, by the way his name is Cee...

Posted on Dec 20, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Phntom bass sounds

uhhh....try you change your wire setup

Sep 17, 2008 | Infinity BASSLINK Car Subwoofer

2 Answers

Infinity Basslink

That popping you hear is most likely the voice coil blown and your not going to get much out of it now. Discontinue use of the unit so it doesn't blow the amp, and you can get the sub replaced if you don't want to toss it.
Good luck, hope this helps

Aug 02, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

2nd Basslink, still no power-on. Please help

this is in response to the post below:

I just bot a basslink t and i wired it up and nothing it just keeps blowing the fues in the unit i got mine on ebay2.gif so i dont know if i can use the warranty dose anybody have an ida for me- britter623

I got a used basslink about a month ago and had the exact same prob kept blowing fuses...found out that the voice coil had blown on the I had a brand new dvc polk 10 sittin in the closet, I swapped them out, put the polk in the place of the infinity sub, however, the magnet is much larger, hence, dual voice coil, it would rattle sooo much from the passive radiator against the magnet, also could not turn the gain up at all due to the rattle. I got the bright idea to build a "custom fiberglas enclosure for the polk and incorporate the infinity's parts(amp/control) I finished the box finally last night and hooked it up this morning, no power, no lights, no nothing! s@#%, F&@%! ANyone had a prob w/the amp not having the lights turn on, no power??? Hope that helps about your fuse blowing issue.

Jul 15, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

Basslink keeps cutting off into protection!!

From what i have heard, If you have a speaker level input connection. this sympton does occur. You buy a scosche LOC and try giving the input to Basslink, it should work fine

Jun 24, 2008 | Infinity BassLink II Car Subwoofer

1 Answer

Infinity Basslink killing battery

Both issues sound like they are related to a non-connected or loosely connected remote wire on the Basslink.

If you're using RCA preamp wires to connect your stereo to the Basslink, make sure the remote wire input on the Basslink is solidly connected to the stereo's remote output.

If you're using the speaker level inputs on the Basslink and not the RCA preamps, make sure the remote input is not connected, as the Basslink will automatically turn on when it senses the speaker level inputs are active.

Mar 19, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

Infinity Basslink

You need a thicker guage Ground wire... I had the same issue.

Mar 19, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

No Sound from Basslink

Do you have speaker wiring or RCA's hooked up from AMP to Basslink? Also check the settings, make sure you are have bridged the channels on amp.

Feb 02, 2008 | Infinity BASSLINK Car Subwoofer

3 Answers

Infinity basslink is messed-up

You may have blown the fuse in the AMP. Check it and let me know.

Jan 15, 2008 | Infinity BASSLINK Car Subwoofer

1 Answer

Basslink servo light constant on

defect age,short worn its time through had the same thing happen to mine,A SUGGESTION PUT A 25 AMP FUSE,AND PULL IN AND OUT THE GAIN TUG IT,IT SOMETIMES STICKS AND SHORTS YOUR UNIT OUT,GOOD LUCK

Feb 23, 2007 | Infinity BASSLINK Car Subwoofer

2 Answers

Amp keeps blowing fuse

I have this same problem. You have blown the internal amp. I have had 2 of these do the same thing. There is nothing you can do but report it to infinity and try to get the unit replaced.

Dec 21, 2006 | Infinity BASSLINK Car Subwoofer

Not finding what you are looking for?

Open Questions:

See all Infinity BASSLINK Car Subwoofer Questions

Infinity BASSLINK Car Subwoofer Logo

556 people viewed this question

Ask a Question

Usually answered in minutes!

Top Infinity Car Speakers & Subwoofers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21840 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Are you an Infinity Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides