Question about Car Audio & Video

1 Answer

My mrv f345 amp reads CUR on display screen and has no sound.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Vice President:

    An expert whose answer gotĀ voted for 100 times.

    Sniper:

    An expert who has posted more than 50 answers, of which 90% or more were rated as helpful.

  • Expert
  • 100 Answers

That error appears usually when the speakers (especially subs) aren't getting the current they need from the system. Check your wiring and make sure you're using the appropriate gauge wire. Too small of a gauge in wire can cause this.

Posted on Sep 30, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Alpine mrv-f345 cuts off when...


Yes sounds like your not getting enuff power from the battery could be your alternator you should have it tested. Also have you try'd a capacitor? I put one in my car and it stopped cutting out...

Feb 05, 2010 | Alpine MRV-F345 Car Audio Amplifier

1 Answer

My amp turns on but the sound goes in an out


yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Jan 25, 2010 | Alpine MRV-F345 Car Audio Amplifier

1 Answer

Amplifier displays "CUR"


Hello anwbrown,

The "CUR" display means that the amp is drawing excessive current and the protection circuit is activating. Too low impedance or shorted speakers will cause the amp to draw excessive current.

The Alpine V12 is a Class D mono amp with only one set of speaker outputs. All versions, M301, M501, and M1001 are only stable to 2ohms. Assuming that all 6 of your connected subwoofers and speakers are 4ohm and they're all connected in parallel, the amp sees a .67 ohm load, far below it's rated impedance.

When brand new, the amp could probably operate at low to moderate volume levels without drawing excessive current. But as electronic components age, their tolerances change and they become less able to withstand excessive current or mismatched impedances.

I'd get a 4-channel amp and drive the 4" speakers off the front channels and the 6X9's off the rear channels. And just power the subs off the V12 making sure that they are connected to show a minimum load of 2ohms.

Hope this helps.

Jul 27, 2009 | Alpine MRV-F345 Car Audio Amplifier

2 Answers

Fan not working


iT SOUNDS LIKE THE FAN IS NOT WORKING RIGHT, SO CHECK OTHERWISE IT WILL COOK YOUR AMP

May 16, 2009 | Alpine MRV-F345 Car Audio Amplifier

1 Answer

Mrv F345 power cut out and now the screen flashes blue


disconnect all of the speaker wires at the amp and turn your system on -if the amp stays on then you likely have a roasted coil in one of your speakers somewhere and causing a short which is shutting your amp down into protection mode-if the amp wont stay on with nothing connected to it then you have probably roasted something inside the amp and uhhh good luck bro

May 09, 2009 | Alpine MRV-F345 Car Audio Amplifier

1 Answer

Alpine MRV-F345 VLT ERROR


Hello,

This is an indication of a voltage error, I have seen this when the voltage regulator or the car battery is begining to have a problem supplying enough current to the amplifier. Check the voltage levels with the amp turned off and then turn on the amplifier, if the voltage drops this means that there is poor voltage regulation and this may mean that you will have to replace the car's voltage regulator.

I hope this helps,

Thank you,

Shuttle83

Apr 20, 2008 | Car Audio & Video

1 Answer

Displays "CUR"


You probably have too low of an impedance load on ot (too many speakers or wrong kind). It has to have a minimum of 2 ohms on each channel, or 4 ohms if bridged (that means don't put 2 subs on the bridge!!).

Sep 22, 2007 | Alpine MRV-F345 Car Audio Amplifier

2 Answers

Over heating


you trouble shoot the problem by opening unit and force-powering fans to test for overheating during "being used loud for a few minutes". Read the fans' label for proper voltage to apply and proper polarity. I am guessing the fans will run on car battery voltage of 12 volts. Also, attempt to close up the unit to simulate real conditions. There should not be fuses for the fans. If unit is now cooling, then look for faulty thermistor, which turns the fan on during rising temperature. Once thermistor is located, a fast test is to "jumper" its two wires to simulate turn on.

Jun 16, 2007 | Alpine MRV-F345 Car Audio Amplifier

1 Answer

Alpine Amplifier Cuts in and out on Passenger side while driving


this isnt a complex problem but both units may need service

Mar 12, 2007 | Alpine MRV-F345 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

85 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...