Question about Olympus EVOLT E-500 Digital Camera

1 Answer

My olympus evolt E-500 camera was working fine but battery was low, put in fully charged battery and camera wouldn't turn on. got home and took battery out of charger(green light was on charger)put in in camera and it still wouldn't turn on, any ideas what the problem is?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,714 Answers

Clean off the contacts where the battery makes contact with camera contacts. Use a pencil eraser of a match book striker (for the sandpaper). Make sure the battery is seated tightly against the contacts. If it's not tight, use a piece of the cover from the match book for a small 'shim' to hold the battery tight.

Posted on Sep 29, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I switch the lens on my Olympus evolt e500


1. Switch off the camera
2. Prepare the lens you want to put on
3. Remove the rear lens cap by turning it anticlockwise
4. Put the camera in your left hand's palm so you can press the lens release knob wit the finger, and press it down.
5. rotate the lens anticlockwise, and remove it
6. immediately put another lens on the camera. The both red dots, on the camera and the lens must be aligned
7. Rotate the lens clockwise.
8. Put the rear protectiv cap on the lens you just removed.
9. Now yuo can turn the camera on and take the photos.

May 02, 2011 | Olympus EVOLT E-500 Digital Camera

2 Answers

MY OLYPUS E-500 SAYS CARD ERROE WHEN I TURN ON MY


Did you try to format the card using the camera's software or your computer?

May 20, 2010 | Olympus EVOLT E-500 Digital Camera

1 Answer

Camera or battery problem?


Sounds like a battery problem. When a rechargeable battery is allowed to completely discharge from non-use, it usually will not come back.

Dec 15, 2009 | Olympus EVOLT E-510 Body Only Digital...

1 Answer

Olympus evolt 500 - Flash won't pop up


did you have the auto pop up in the menu on?

Jun 20, 2009 | Olympus EVOLT E-500 Digital Camera

1 Answer

My e-500 goes completely dead when shutter is depressed. battery must be reloaded to power on. all other features works fine.


reset the camera back to default using the menu... (custom reset and camera needs to be in P,s,a, or M for reset to work) else it is repair

Mar 26, 2009 | Olympus EVOLT E-500 Digital Camera

4 Answers

Olympus E-300 Evolt - LCD Screen doesn't come & SSWF light stays on


My camera is working again, but the problem is not completely solved. What I did was to put on the old lens, take out the battery then turn on the camera and finally put on the battery again. And now it works. But the problem with the new lens (Zuiko digital 40-150) continues.

Jun 30, 2008 | Olympus EVOLT E-300 Digital Camera

1 Answer

Battery charger for Olympus E-500 camera


dear cienkusmike,
This charger should work to charge the battery that came with the olympus E-500.

Sincerely,
Agent Allan
Go Ahead. Use Us.

Apr 08, 2008 | Olympus EVOLT E-500 Digital Camera

1 Answer

No power?????


Not sure if this will help, but it seemed to fix my issue......I used a freshly charged battery. Removed both xD and Compact Flash memory from the camera. Powered on. You will see the menu flash and read that there is no card inserted. Power down. Place memory back in the camera. I can't explain my issue. The camera may have gone into a stand-by mode until the battery died and it just needed a reset? Anyway, hope this can be of use to someone. =0)

Mar 30, 2008 | Olympus EVOLT E-500 Digital Camera

1 Answer

EVOLT E-500 LCD Problem (Mirror Image)


This is new one one. It would seem to be an electronic failure of some sort Suggest you refer to Olympus Support on this one

Aug 20, 2007 | Olympus EVOLT E-500 Digital Camera

Not finding what you are looking for?
Olympus EVOLT E-500 Digital Camera Logo

Related Topics:

26 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Cameras Experts

kakima

Level 3 Expert

102366 Answers

Willem.
Willem.

Level 2 Expert

359 Answers

Steven Wander
Steven Wander

Level 3 Expert

579 Answers

Are you an Olympus Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...