Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

2 Answers

Hoover U6439: Belt keeps slipping off

Th belt on my Hoover U6439 slips off almost everytime I use it.

Posted by on

  • mckbak Sep 28, 2009

    This has been an ongoing problem. I have changed the belt a few times but this problem keeping happening consistently whether it is a new belt or not.

  • shelby whaley May 11, 2010

    did you replace it?

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 701 Answers

The belt is stretched and you simply just need to replace it. You can get the belts you need for this model here:

http://www.vacbelts.com/hoover-self-propelled-windtunnel-belt.htm

Posted on Oct 27, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 430 Answers

The belt although not broken has been stretched. You need to replace with a new genuine belt, which will me about 3/4 the size of a stretched one in most cases.
Buy two belts and keep a spare replace every 3-6 months before it slips, for best cleaning results.
Clean the brush roll and motor shaft when installing. Unscrew the brush end caps to remove hair , dirt and thread.

Posted on Sep 28, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does drive belt on Hoover U6434 keeps slipping off. Even new ones.


Hi! If you have replaced the belt with a new one and your brush-roll is still not spinning, your brush-roll may need to be replaced. Remove the brushroll and clear it of hair and debris. Spin the end caps with your hand. They should spin easily with no tension. Inspect the area on the brushroll where the belt rests on for damages. To order a replacement brushroll click on this link. Search Results It could also be that the incorrect belt is being used with the vacuum. Make sure you are using genuine Hoover parts when replacing the belt. Click on these links to order a replacement belt. Search Results & Search Results

Hope this was helpful!

Jun 08, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Drive belt on Hoover U6434 keeps slipping off. Even new ones.


Check the motor shaft for residue from a previously burned belt. Also the brush roller may be defective.

Jun 08, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

I have a Hoover upright windtunnel. The belt that spinns the brush keeps slipping from the spindle on the motor. How do i keep it on there?


for a temporary fix, double up a rubber band on the outer tip of the spindle. if the belt slips over that, it's stretched out too much. replace the belt

Feb 28, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

My Hoover upright model 6437-900 makes a distressed sound when I turn it on and it also burns rubber. The roller turns. I've checked the thick black belt and it's intact, but has lots of 'pitting'. ...


It certainly sounds as though the belt needs replacement. (Part # 38528035) If the belt has stretched, it will slip, causing a burning rubber odor. Get a new belt and compare it to the used one.

Feb 22, 2011 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

My hoover tind tunnel model 5453-900 series the belt keeps slipping off the agitater brush-what can i do to fix it


your belt has probobly stretched even though it continues to function. try a new belt assuming the belt path is clear and any guides are properly positioned when the cover is properly replaced and the hump on the brush roll that contacts the belt is not mishapen.

Oct 18, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

The small belt attached to the roll brush keeps slipping off. It's a brand new belt and the vacuum is only 1 yr old.


The small belt rarely gives the problem you describe. The larger belt can jump off if the belt is worn or if th roller gets caught on something suddenly.The belt should be replaced every 9 - 12 months. If your carpet setting is too low this will cause the belts to wear faster that the estimated given time

Oct 04, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

My Hoover U6439-900 also losing belts


When upside down there is no resistance,on carpet there is.
You need to try a a fresh, genuine hoover belt and buy a spare, belts stretch and slip after 30 -90 a days of normal use, often to 25-30% oversize Hoover belts generally fit very snug. If your belt looks shiny inside, that is likely the issue. Try that and post results

Sep 28, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Flat belt on Hoover Windtunnel requires to be replaced regularly


No it is not normal. The brush roll may be bad causing extra stress on the belt. The other option is the belt is installed incorrectly. I believe this model has a brush on/off option and the belt must be correctly installed around both the motor shaft and the shaft for that brush on/off switch.

Apr 15, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Roller Belt Keeps Slipping Off


You could try contacting Hoover for parts availability. If it's and older WindTunnel and Hoover no longer has the part, try eBay.

May 14, 2017 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Brush won't turn


The belt may look ok, but if it is more then a few months old, then it has stretched to where it won't turn under load, just slips. If it is very tight feeling, then check down where the pulleys are, the V belt has a black roll that maybe jammed and not pushing against the V belt when the handle is in the down position.

Sep 18, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

471 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...